aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/rust-mode/rust-mode-1.0.0_alpha.ebuild')
-rw-r--r--app-emacs/rust-mode/rust-mode-1.0.0_alpha.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-emacs/rust-mode/rust-mode-1.0.0_alpha.ebuild b/app-emacs/rust-mode/rust-mode-1.0.0_alpha.ebuild
new file mode 100644
index 0000000..732c388
--- /dev/null
+++ b/app-emacs/rust-mode/rust-mode-1.0.0_alpha.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit elisp
+
+MY_PV="rustc-1.0.0-alpha"
+
+DESCRIPTION="A major emacs mode for editing Rust source code"
+HOMEPAGE="http://www.rust-lang.org/"
+SRC_URI="http://static.rust-lang.org/dist/${MY_PV}-src.tar.gz"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="!!<=app-admin/eselect-rust-0.1_pre20140820
+ !<=dev-lang/rust-0.11.0-r1:0.11
+ !<=dev-lang/rust-999:nightly
+ !<=dev-lang/rust-9999-r2:git
+"
+
+S="${WORKDIR}/${MY_PV}/src/etc/emacs"
+
+SITEFILE="50${PN}-gentoo.el"