aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOGINO Masanori <masanori.ogino@gmail.com>2013-12-25 08:04:47 +0900
committerOGINO Masanori <masanori.ogino@gmail.com>2013-12-25 08:04:47 +0900
commit8d41abbce11a5ed4c53d227821792ef2e72cd1ca (patch)
tree0ccdf2e7f4378be6e3b5866e49102d3915cb21b3 /dev-lang
parentAdd app-{emacs,vim}/rust-mode/metadata.xml. (diff)
downloadrust-8d41abbce11a5ed4c53d227821792ef2e72cd1ca.tar.gz
rust-8d41abbce11a5ed4c53d227821792ef2e72cd1ca.tar.bz2
rust-8d41abbce11a5ed4c53d227821792ef2e72cd1ca.zip
Add `emacs` and `vim-syntax` USE flags.
As I've mentioned before, app-vim/rust-mode has not only syntax highlighting support, but AFAIK `vim` USE flag has different meaning. Thus I decided to use `vim-syntax`. Signed-off-by: OGINO Masanori <masanori.ogino@gmail.com>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust/rust-0.8.ebuild11
-rw-r--r--dev-lang/rust/rust-9999.ebuild11
2 files changed, 12 insertions, 10 deletions
diff --git a/dev-lang/rust/rust-0.8.ebuild b/dev-lang/rust/rust-0.8.ebuild
index f8b34d1..9ef3515 100644
--- a/dev-lang/rust/rust-0.8.ebuild
+++ b/dev-lang/rust/rust-0.8.ebuild
@@ -13,29 +13,30 @@ LICENSE="|| ( MIT Apache-2.0 )"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-if [[ ${PV} != 9999 ]]; then
- IUSE="clang debug"
+IUSE="clang debug emacs vim-syntax"
+if [[ ${PV} != 9999 ]]; then
SRC_URI="http://static.rust-lang.org/dist/${P}.tar.gz"
else
inherit git-2
- IUSE="clang +heather debug"
+ IUSE="${IUSE} heather"
if use heather; then
EGIT_REPO_URI="git://github.com/Heather/rust.git"
else
EGIT_REPO_URI="git://github.com/mozilla/rust.git"
fi
- EGIT_MASTER="master"
fi
-
RDEPEND="sys-devel/llvm"
DEPEND="${RDEPEND}
clang? ( sys-devel/clang )
>=dev-lang/perl-5.0
>=dev-lang/python-2.6
"
+PDEPEND="emacs? ( app-emacs/rust-mode )
+ vim-syntax? ( app-vim/rust-mode )
+"
src_configure() {
"${ECONF_SOURCE:-.}"/configure \
diff --git a/dev-lang/rust/rust-9999.ebuild b/dev-lang/rust/rust-9999.ebuild
index c4dccf6..6288515 100644
--- a/dev-lang/rust/rust-9999.ebuild
+++ b/dev-lang/rust/rust-9999.ebuild
@@ -13,29 +13,30 @@ LICENSE="|| ( MIT Apache-2.0 )"
SLOT="0"
KEYWORDS=""
-if [[ ${PV} != 9999 ]]; then
- IUSE="clang debug"
+IUSE="clang debug emacs vim-syntax"
+if [[ ${PV} != 9999 ]]; then
SRC_URI="http://static.rust-lang.org/dist/${P}.tar.gz"
else
inherit git-2
- IUSE="clang heather debug"
+ IUSE="${IUSE} heather"
if use heather; then
EGIT_REPO_URI="git://github.com/Heather/rust.git"
else
EGIT_REPO_URI="git://github.com/mozilla/rust.git"
fi
- EGIT_MASTER="master"
fi
-
RDEPEND="sys-devel/llvm"
DEPEND="${RDEPEND}
clang? ( sys-devel/clang )
>=dev-lang/perl-5.0
>=dev-lang/python-2.6
"
+PDEPEND="emacs? ( app-emacs/rust-mode )
+ vim-syntax? ( app-vim/rust-mode )
+"
src_configure() {
"${ECONF_SOURCE:-.}"/configure \