aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOGINO Masanori <masanori.ogino@gmail.com>2014-01-11 11:25:29 +0900
committerOGINO Masanori <masanori.ogino@gmail.com>2014-01-11 11:29:53 +0900
commit7c96f13097bff2c934cebe93658b4e143398bc18 (patch)
tree32fbf749d1ed4a7ee3140b63dedb36f81e505e24 /dev-lang
parentAdd dev-lang/rust-0.9. (diff)
downloadrust-7c96f13097bff2c934cebe93658b4e143398bc18.tar.gz
rust-7c96f13097bff2c934cebe93658b4e143398bc18.tar.bz2
rust-7c96f13097bff2c934cebe93658b4e143398bc18.zip
Remove dev-lang/rust-0.8.
Because of an internal compiler error, the ebuild couldn't install correctly and version 0.9, including a fix for the ICE, has been released officially. I think it's about the time to remove 0.8. Signed-off-by: OGINO Masanori <masanori.ogino@gmail.com>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust/Manifest1
-rw-r--r--dev-lang/rust/rust-0.8.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/dev-lang/rust/Manifest b/dev-lang/rust/Manifest
index 059dfea..906ab8e 100644
--- a/dev-lang/rust/Manifest
+++ b/dev-lang/rust/Manifest
@@ -1,2 +1 @@
-DIST rust-0.8.tar.gz 16720822 SHA256 42f791ab1537357fe0f63d67ffe6bcb64ecf16b2bd3f1484ab589823f5914182 SHA512 494817e045af87055ca22a6b15799f14ab4e5a4d1e7be883c211bfbbc2b9b1c498711d91c40c130dd8b8307f226d4ed6100b51064aab8a9f3939f19bd829b0e4 WHIRLPOOL 907838591486cf6336b697bab338ca3aa970f2c0daa352c78dba53ccaa5bb77b3f1e2f110b345bab67e4476846a30b71c612ee0726176b23e49bc3fd4cba17e3
DIST rust-0.9.tar.gz 17152912 SHA256 c0911c3545b797a1ca16f3d76bf5ed234754b828efd1e22c182c7300ac7dd5d1 SHA512 a8cdd59e3b2eacf319068511ee30166f218ba2772f9facf8193fa9b7da77a4b01685711b201e8aa6bcc9e4d7068c2d48a9e2c5e9af80e319bf513a6652083e0a WHIRLPOOL 4e86a3156fec7ebc5d4efd4f3c86d8357b66dc8b7858a1609237607ed70ab6ef7426401fcf232b654dc5e9fa00ac28830f3a834defe04375e93adbebe44e43f6
diff --git a/dev-lang/rust/rust-0.8.ebuild b/dev-lang/rust/rust-0.8.ebuild
deleted file mode 100644
index baa6fb1..0000000
--- a/dev-lang/rust/rust-0.8.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="5"
-
-inherit multilib
-
-DESCRIPTION="Open source programming language from Mozilla"
-HOMEPAGE="http://www.rust-lang.org/"
-
-LICENSE="|| ( MIT Apache-2.0 )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="+bootstrap clang debug emacs vim-syntax zsh-completion"
-
-if [[ ${PV} != 9999 ]]; then
- SRC_URI="http://static.rust-lang.org/dist/${P}.tar.gz"
-else
- inherit git-r3
- IUSE="${IUSE} heather"
-
- if use heather; then
- EGIT_REPO_URI="git://github.com/Heather/rust.git"
- else
- EGIT_REPO_URI="git://github.com/mozilla/rust.git"
- fi
-fi
-
-
-RDEPEND="zsh-completion? ( app-shells/zsh )"
-DEPEND="${RDEPEND}
- clang? ( sys-devel/clang )
- >=dev-lang/perl-5.0
- >=dev-lang/python-2.6
-"
-PDEPEND="emacs? ( app-emacs/rust-mode )
- vim-syntax? ( app-vim/rust-mode )
-"
-
-src_configure() {
- "${ECONF_SOURCE:-.}"/configure \
- --prefix="${EPREFIX}"/usr \
- $(use_enable clang) \
- $(use_enable debug) \
- $(use_enable debug llvm-assertions) \
- $(use_enable !debug optimize) \
- $(use_enable !debug optimize-cxx) \
- $(use_enable !debug optimize-llvm) \
- $(use_enable !debug optimize-tests) \
- $(use_enable !bootstrap local-rust) \
- --local-rust-root="${EPREFIX}"/usr \
- --disable-manage-submodules \
- || die
-}
-
-src_install() {
- default
-
- if use zsh-completion; then
- insinto "/usr/share/zsh/site-functions"
- doins src/etc/zsh/_rust
- fi
-
- rm -f "${ED}/usr/$(get_libdir)/librusti.so" || die
- rm -f "${ED}/usr/$(get_libdir)/librustc.so" || die
- rm -f "${ED}/usr/$(get_libdir)/librust.so" || die
- rm -f "${ED}/usr/$(get_libdir)/librustpkg.so" || die
- rm -f "${ED}/usr/$(get_libdir)/librustdoc.so" || die
-}