aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/tym')
-rw-r--r--x11-terms/tym/Manifest1
-rw-r--r--x11-terms/tym/tym-3.5.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/x11-terms/tym/Manifest b/x11-terms/tym/Manifest
index f8627076a..389540d49 100644
--- a/x11-terms/tym/Manifest
+++ b/x11-terms/tym/Manifest
@@ -1 +1,2 @@
DIST tym-3.5.0.tar.gz 154324 BLAKE2B 47053dc6011d7288556c7d6e37a6b492d5daf75b0a36b23efb56939c64e49a17e96a8c853a684fc9626005256e8aefeb05f5de7e3ee519c30cc0065f9c8f83b4 SHA512 dcf716d1a8b95b02495358027769a78b093b70b9a475ed4621da5fb5e6793f5d970571ef28cbb63b52b68e073be6df5ccc9244ad60a1018f3ad76f24b64997b8
+DIST tym-3.5.1.tar.gz 154615 BLAKE2B 93755c2a1a392e7b9fe12ece595314cf97ae828dd8e6f3af0453f10c7fb5ac4b72a63d30e97d50b23bcffab1712086c1e569437f8bbfe88f31b19594e8acb300 SHA512 c1eb138fd0c0c7a3485528720bdadcac5b8353abf68f81ae8293bc28a3d3951c41fc665a52877f446b000cdd863413fc734ef227b0bdc51c2a7d1fb0c0237639
diff --git a/x11-terms/tym/tym-3.5.1.ebuild b/x11-terms/tym/tym-3.5.1.ebuild
new file mode 100644
index 000000000..d04bc7d45
--- /dev/null
+++ b/x11-terms/tym/tym-3.5.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-3 luajit )
+inherit lua-single xdg
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3 autotools
+ EGIT_REPO_URI="https://github.com/endaaman/tym"
+else
+ SRC_URI="https://github.com/endaaman/tym/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Lua-configurable terminal emulator"
+HOMEPAGE="https://github.com/endaaman/tym"
+
+LICENSE="MIT"
+SLOT="0"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+DEPEND="
+ ${LUA_DEPS}
+ x11-libs/gtk+:3
+ x11-libs/vte
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ # see https://github.com/endaaman/tym/issues/115
+ sed -i '/^CFLAGS=""/d' "${S}"/configure.ac || die
+
+ # the categories provided by eclass do a better job than upstream, and
+ # having duplicate list of categories fails on QA
+ sed -i '/^Categories=.*$/d' "${S}"/tym-daemon.desktop "${S}"/tym.desktop || die
+}
+
+src_configure() {
+ if [[ ${PV} == 9999 ]]; then
+ eautoreconf
+ fi
+ econf --enable-luajit=$(usex lua_single_target_luajit yes no)
+}