aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycpio/pycpio-0.9.0.ebuild')
-rw-r--r--dev-python/pycpio/pycpio-0.9.0.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/pycpio/pycpio-0.9.0.ebuild b/dev-python/pycpio/pycpio-0.9.0.ebuild
new file mode 100644
index 000000000..4544d8ad0
--- /dev/null
+++ b/dev-python/pycpio/pycpio-0.9.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+inherit distutils-r1
+
+DESCRIPTION="Python CPIO library"
+HOMEPAGE="https://github.com/desultory/pycpio"
+SRC_URI="https://github.com/desultory/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=dev-python/zenlib-1.7.2[${PYTHON_USEDEP}]"