aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/sherlock/sherlock-9999.ebuild')
-rw-r--r--app-misc/sherlock/sherlock-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-misc/sherlock/sherlock-9999.ebuild b/app-misc/sherlock/sherlock-9999.ebuild
new file mode 100644
index 000000000..8e94dba9a
--- /dev/null
+++ b/app-misc/sherlock/sherlock-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..13} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1
+
+DESCRIPTION="Hunt down social media accounts by username across social networks"
+HOMEPAGE="http://sherlock-project.github.io/"
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sherlock-project/sherlock.git"
+else
+ SRC_URI="https://github.com/sherlock-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/certifi-2019.6.16[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/PySocks-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.22.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-futures-1.00.0[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/openpyxl-3.0.10.0.0[${PYTHON_USEDEP}]
+ ')
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs