aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/afetch/afetch-2.0.1.ebuild')
-rw-r--r--app-misc/afetch/afetch-2.0.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-misc/afetch/afetch-2.0.1.ebuild b/app-misc/afetch/afetch-2.0.1.ebuild
new file mode 100644
index 000000000..166978dbf
--- /dev/null
+++ b/app-misc/afetch/afetch-2.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit savedconfig
+
+DESCRIPTION="Simple system info written in C"
+HOMEPAGE="https://github.com/13-CF/afetch/"
+SRC_URI="https://github.com/13-CF/afetch/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="savedconfig"
+
+src_prepare() {
+ default
+ restore_config src/config.h
+}
+
+src_install() {
+ emake DESTDIR="${ED}" PREFIX="${EPREFIX}"/usr install
+ save_config src/config.h
+}