aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/aspectlib/aspectlib-1.4.2.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-python/aspectlib/aspectlib-1.4.2.ebuild b/dev-python/aspectlib/aspectlib-1.4.2.ebuild
index 27cc072a1..f38deef24 100644
--- a/dev-python/aspectlib/aspectlib-1.4.2.ebuild
+++ b/dev-python/aspectlib/aspectlib-1.4.2.ebuild
@@ -5,6 +5,8 @@ EAPI=7
PYTHON_COMPAT=( python3_6 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
inherit distutils-r1
DESCRIPTION="An aspect-oriented programming, monkey-patch and decorators library"
@@ -18,6 +20,10 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+# could not get this working, it tries to do all sorts of weird things
+# it calls a tests outside the tests folder, which then fails, removing the file results in import error
+RESTRICT="test"
+
RDEPEND="
dev-python/fields[${PYTHON_USEDEP}]
"
@@ -33,5 +39,7 @@ DEPEND="
)
"
+S="${WORKDIR}/python-${P}"
+
distutils_enable_tests pytest
distutils_enable_sphinx docs dev-python/sphinx-py3doc-enhanced-theme