aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorSPRATAY <spratay+linux@getgoogleoff.me>2024-01-04 23:07:11 +0300
committerSPRATAY <spratay+linux@getgoogleoff.me>2024-01-04 23:07:11 +0300
commit5a4ee4ee4d3a8db696bbea69063b320fda7e49e2 (patch)
treef14eedc7d7b719888fa3193af9960147b497083e /x11-wm
parentdev-go/lichen: drop package since it is in the main tree (diff)
downloadguru-5a4ee4ee4d3a8db696bbea69063b320fda7e49e2.tar.gz
guru-5a4ee4ee4d3a8db696bbea69063b320fda7e49e2.tar.bz2
guru-5a4ee4ee4d3a8db696bbea69063b320fda7e49e2.zip
x11-wm/qtile-extras: new package, add 0.23.0
Signed-off-by: SPRATAY <spratay+linux@getgoogleoff.me>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/qtile-extras/Manifest1
-rw-r--r--x11-wm/qtile-extras/qtile-extras-0.23.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/x11-wm/qtile-extras/Manifest b/x11-wm/qtile-extras/Manifest
new file mode 100644
index 000000000..a3bc41ad2
--- /dev/null
+++ b/x11-wm/qtile-extras/Manifest
@@ -0,0 +1 @@
+DIST qtile-extras-0.23.0.tar.gz 4382844 BLAKE2B f3ac92b07d36135261664656bb79a277b1d8413a5c92d2573b27f73b291b307c0e803350510672369c39f8b404c49614c6a6a175c4013545be7eacb95c455451 SHA512 2f561a263356129de74c21f2ac3db410b86021e605f2b398148a48b941c3b851a6a00a3548bdaebaf637ba9f2bcfd2081d22278e98eff4e77b82ca4a90415d2c
diff --git a/x11-wm/qtile-extras/qtile-extras-0.23.0.ebuild b/x11-wm/qtile-extras/qtile-extras-0.23.0.ebuild
new file mode 100644
index 000000000..dcfb54729
--- /dev/null
+++ b/x11-wm/qtile-extras/qtile-extras-0.23.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=no
+PYTHON_COMPAT=(python3_{9..12})
+
+inherit distutils-r1 desktop
+
+SRC_URI="https://github.com/elParaguayo/qtile-extras/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="amd64"
+
+DESCRIPTION="Run Windows Applications on Linux as if they are native (Using a VM and FreeRDP)"
+HOMEPAGE="https://github.com/casualsnek/cassowary"
+
+BDEPEND="dev-python/setuptools
+ dev-python/build
+ dev-python/installer
+ dev-python/setuptools-scm
+ dev-python/wheel
+"
+
+RDEPEND="x11-wm/qtile"
+
+DEPEND="${RDEPEND}"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=7.0.0
+
+python_compile() {
+ ${EPYTHON} -m build --wheel --no-isolation
+}
+
+python_install() {
+ ${EPYTHON} -m installer --destdir="${D}" dist/*.whl
+}