aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Kalyan <contrib_x@protonmail.com>2021-05-19 01:23:16 -0600
committerJames Kalyan <contrib_x@protonmail.com>2021-05-19 01:23:16 -0600
commite2f0e77ef027ec44412fdff40683408a045f270c (patch)
tree641c83ae82a589ae9bbf8a6f8ae303f2ef851742 /x11-themes
parentsys-apps/drm_info: add 2.3.0 (diff)
downloadguru-e2f0e77ef027ec44412fdff40683408a045f270c.tar.gz
guru-e2f0e77ef027ec44412fdff40683408a045f270c.tar.bz2
guru-e2f0e77ef027ec44412fdff40683408a045f270c.zip
x11-themes/qogir-icon-theme: new package
Signed-off-by: James Kalyan <contrib_x@protonmail.com>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/qogir-icon-theme/Manifest2
-rw-r--r--x11-themes/qogir-icon-theme/metadata.xml12
-rw-r--r--x11-themes/qogir-icon-theme/qogir-icon-theme-2020.11.22.ebuild51
3 files changed, 65 insertions, 0 deletions
diff --git a/x11-themes/qogir-icon-theme/Manifest b/x11-themes/qogir-icon-theme/Manifest
new file mode 100644
index 000000000..e7b88b33a
--- /dev/null
+++ b/x11-themes/qogir-icon-theme/Manifest
@@ -0,0 +1,2 @@
+DIST 2020-11-22.tar.gz 6242726 BLAKE2B 130f9fcafa8b42f833c6164ea45d8bb1f5de3561245f9815a273ff1bb9a5f2ff375a76a4125c4467ea437a87ac5f516d799b43239527d1b4d09457b7a601a312 SHA512 0d7849fbeff4ea3fb4f279e5f55cf794207407626bee80862d963ec60b08631b12e875ad7ba9b8a38394d5991953e52202fdca536ee5374435001ca05afd1148
+EBUILD qogir-icon-theme-2020.11.22.ebuild 1280 BLAKE2B 3bf1738f516db7da3c6cb36abf92407948525b333deb9908fc70d06a98b29cb69bf53091d5a7e77a55f46fce421884c630b9b9c743840f1bc7fde8be82989da6 SHA512 1c8f9c1419d7f008e8bade23fb461b1f87ffc789818010c73fe9eeb47b94e2d79f6c5b11cca07028c0428730490ad08666f7bc0fceb883ce5ea7e5eeef4ba63b
diff --git a/x11-themes/qogir-icon-theme/metadata.xml b/x11-themes/qogir-icon-theme/metadata.xml
new file mode 100644
index 000000000..63c99d8b8
--- /dev/null
+++ b/x11-themes/qogir-icon-theme/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">vinceliuice/Qogir-icon-theme</remote-id>
+ <bugs-to>https://github.com/vinceliuice/Qogir-icon-theme/issues</bugs-to>
+ </upstream>
+ <maintainer type="person">
+ <email>contrib_x@protonmail.com</email>
+ <name>James Kalyan</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-themes/qogir-icon-theme/qogir-icon-theme-2020.11.22.ebuild b/x11-themes/qogir-icon-theme/qogir-icon-theme-2020.11.22.ebuild
new file mode 100644
index 000000000..0bc264cc0
--- /dev/null
+++ b/x11-themes/qogir-icon-theme/qogir-icon-theme-2020.11.22.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# To update icon cache
+inherit xdg-utils
+
+DESCRIPTION="A flat colorful design icon theme for linux desktops"
+HOMEPAGE="https://github.com/vinceliuice/Qogir-icon-theme"
+SRC_URI="https://github.com/vinceliuice/${PN}/archive/refs/tags/2020-11-22.tar.gz"
+
+# Extract to a non-default name
+S=${WORKDIR}/Qogir-icon-theme-2020-11-22
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# No binaries are installed so we don't need these portage features
+RESTRICT="binchecks strip"
+
+# Unsure about dependencies
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eapply_user
+
+ # Don't install the ubuntu/manjaro variants
+ sed -i 's:THEME_VARIANTS=.*:THEME_VARIANTS="":' \
+ install.sh || die "Sed failed to remove theme variants!"
+
+ # Install cursors to Gentoo's cursor location
+ sed -i -e "/cp.*cursors/i mkdir -p \${CURSOR_DIR}/Qogir\${color}" \
+ -e "s:\(cp.*cursors\"\).*:\1 \${CURSOR_DIR}/Qogir\${color}:" \
+ install.sh || die "Sed failed changing cursor location!"
+}
+
+src_install() {
+ mkdir -p ${D}/usr/share/icons
+ CURSOR_DIR=${D}/usr/share/cursors/xorg-x11 ${S}/install.sh -d ${D}/usr/share/icons
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}