aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2024-09-06 16:16:26 +0200
committerPaul Zander <negril.nx+gentoo@gmail.com>2024-09-06 16:22:54 +0200
commit918ecf81ca1459fcc61eea5a33de3d729137b141 (patch)
treebed4c38af8b9f88a9492e71a3956933ac2493c5c /x11-drivers
parentsci-mathematics/frama-c: drop 23.1-r1, 24.0-r1 (diff)
downloadguru-918ecf81ca1459fcc61eea5a33de3d729137b141.tar.gz
guru-918ecf81ca1459fcc61eea5a33de3d729137b141.tar.bz2
guru-918ecf81ca1459fcc61eea5a33de3d729137b141.zip
x11-drivers/evdi: add 1.14.6, add filter-lto
Fixes: ERROR: modpost: missing MODULE_LICENSE() Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/evdi/Manifest1
-rw-r--r--x11-drivers/evdi/evdi-1.14.6.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/x11-drivers/evdi/Manifest b/x11-drivers/evdi/Manifest
index 35153bb9e..1ff924738 100644
--- a/x11-drivers/evdi/Manifest
+++ b/x11-drivers/evdi/Manifest
@@ -1 +1,2 @@
DIST evdi-1.14.5.tar.gz 90775 BLAKE2B ccee5c1fa1644bef98ddbc2d06eff990c56d2f5a58042f5ee1557816f25da850bd5c5cc5bd60ca48cc341fe167359ab513425e5ef5d3b248426c1e81a5e5cd10 SHA512 6374c88a4433da0142fc1e9ae7fa48791253747694deb86b4897a2f503783ba45c46f5e5f53718dc73ce47cb4a03479b989300ca57c4d847a912915b36a72142
+DIST evdi-1.14.6.tar.gz 91220 BLAKE2B 7b500096d45f0ac8329059d6ba092b3536039fa2647e39c40a863efd01756cae03dbc06076513e9ba68344e3997838727512003fb75c69c70a277a9276ee945c SHA512 8fc77d1b4a78395f05541ac3f9babb69c3fa59d89383d95b5a429a61d8941cddbc5087348f02125296eeec1c656135580f5a34d61430f4bce4b25c4ca685f735
diff --git a/x11-drivers/evdi/evdi-1.14.6.ebuild b/x11-drivers/evdi/evdi-1.14.6.ebuild
new file mode 100644
index 000000000..f6edbd98f
--- /dev/null
+++ b/x11-drivers/evdi/evdi-1.14.6.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit linux-mod-r1 python-single-r1 flag-o-matic
+
+DESCRIPTION="Extensible Virtual Display Interface"
+HOMEPAGE="https://github.com/DisplayLink/evdi"
+SRC_URI="https://github.com/DisplayLink/evdi/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+IUSE="python test"
+
+RDEPEND="${PYTHON_DEPS}
+ x11-libs/libdrm
+ python? (
+ $(python_gen_cond_dep '
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+ ')
+ )
+"
+
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RESTRICT="!test? ( test )"
+
+# module/Kconfig
+CONFIG_CHECK="~FB_VIRTUAL ~I2C ~DRM ~USB_SUPPORT ~USB_ARCH_HAS_HCD MODULES"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.14.4-format-truncation.patch"
+)
+
+pkg_setup() {
+ linux-mod-r1_pkg_setup
+ use python && python-single-r1_pkg_setup
+}
+
+src_compile() {
+ filter-lto
+
+ local modlist=(
+ "evdi=video:module"
+ )
+ local modargs=(
+ CONFIG_DRM_EVDI="m" # https://github.com/DisplayLink/evdi/issues/476
+ KVER="${KV_FULL}"
+ KDIR="${KV_OUT_DIR}"
+ )
+ linux-mod-r1_src_compile
+
+ emake -C library
+
+ use python && emake -C pyevdi
+}
+
+src_test() {
+ use python && emake -C pyevdi tests
+}
+
+src_install() {
+ linux-mod-r1_src_install
+
+ local -x DESTDIR="${ED}" PREFIX="${EPREFIX}"
+
+ LIBDIR="/usr/$(get_libdir)" emake -C library install
+
+ use python && emake -C pyevdi install
+}