aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Joldasov <bratishkaerik@landless-city.net>2024-10-29 03:08:10 +0500
committerEric Joldasov <bratishkaerik@landless-city.net>2024-10-29 03:08:10 +0500
commit792ca5ff15b5ef5b16a07c63acccc63270812d25 (patch)
tree5c7b4332a455cd7465abd4311e45463f6e7cb01a /www-apps
parentdev-util/juliaup: add 1.17.10, drop 1.17.9 (diff)
downloadguru-792ca5ff15b5ef5b16a07c63acccc63270812d25.tar.gz
guru-792ca5ff15b5ef5b16a07c63acccc63270812d25.tar.bz2
guru-792ca5ff15b5ef5b16a07c63acccc63270812d25.zip
www-apps/mycorrhiza: add 1.15.1
Signed-off-by: Eric Joldasov <bratishkaerik@landless-city.net>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/mycorrhiza/Manifest2
-rw-r--r--www-apps/mycorrhiza/mycorrhiza-1.15.1.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/www-apps/mycorrhiza/Manifest b/www-apps/mycorrhiza/Manifest
index cdb127e91..b1e63ccbc 100644
--- a/www-apps/mycorrhiza/Manifest
+++ b/www-apps/mycorrhiza/Manifest
@@ -1,2 +1,4 @@
DIST mycorrhiza-1.15.0-vendor.tar.xz 670776 BLAKE2B d43effa83bbff937419d4c9aeacb6c0107141653e26e78b98e27c975db47f170bdaf40f49a9f3d24a382a897963480f1500549ec3b16af3703b0702016a89a7a SHA512 5145107c91e8c58a71b7778731c6a40d4df791ada86a850c52c7358000fc398788510334b93d0e28e1053d1ed7013e80aaf0d500bc87c906e33822990467d7ca
DIST mycorrhiza-1.15.0.tar.gz 141894 BLAKE2B ebb47ac42d0a1c2779e531473cb18c91c4e926a0f8d3c492b5aa8221d0e44f6ac79d9e7ba8e586375ec962e4fc0eb0c5a2c579bf28ca6c492e63cf106e9164ec SHA512 6ff0aada001d0b6be31aa1d8418e42b4db7166f0a97a5a5d627e7bfed64d9fe84bdc5fe30640249955fb406d6a725e4bd26fbf9931602b5a5ab9655d9da8432b
+DIST mycorrhiza-1.15.1-vendor.tar.xz 684328 BLAKE2B dd6dff33d1169a830863ec52c861ac8580340da737036c8058b78965678a8b513e19bbd59c7fa9336ac49c51be292074c29639a45c6db1b327f8b6796bbf6d86 SHA512 f08c047d42e2b8b8dc7be188648405a365a01390f95d5f72d31526dbdf727f63a9fb9c50438d28326ff878fdcaac2023f0b5bdc2a38a1562c93272e7a26305f4
+DIST mycorrhiza-1.15.1.tar.gz 135532 BLAKE2B e7895f32b942a02ae9b732f1ef5bbe4691d6fa60ecf47561d9579ab535504d7c05327da1036ff78cb493502e8799710f728a7d0fda7b39e20767f26d281e3d6a SHA512 54f6b18b7dc9bdcbbe6461f0f39be0cafe49c2f6d2bfb43831bc899dd1cdeffd3e8a7a52c6e9fac685619048867888945bcc9e4f2999a0915b3a6ec04ea4cee6
diff --git a/www-apps/mycorrhiza/mycorrhiza-1.15.1.ebuild b/www-apps/mycorrhiza/mycorrhiza-1.15.1.ebuild
new file mode 100644
index 000000000..aaa026ade
--- /dev/null
+++ b/www-apps/mycorrhiza/mycorrhiza-1.15.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Git-based wiki engine written in Go using mycomarkup"
+HOMEPAGE="https://mycorrhiza.wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/bouncepaw/mycorrhiza"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/bouncepaw/mycorrhiza/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://codeberg.org/BratishkaErik/distfiles/releases/download/mycorrhiza-${PV}/mycorrhiza-${PV}-vendor.tar.xz
+ "
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="AGPL-3 MIT Apache-2.0 BSD BSD-2 CC-BY-4.0"
+SLOT="0"
+
+RESTRICT="mirror"
+
+BDEPEND=">=dev-lang/go-1.22"
+RDEPEND="dev-vcs/git"
+
+DOCS=( "README.md" )
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ go-module_live_vendor
+ fi
+ go-module_src_unpack
+}
+
+src_compile() {
+ GOFLAGS+=" -mod=vendor -trimpath"
+ local go_ldflags="-s -linkmode external -extldflags \"${LDFLAGS}\""
+ ego build ${GOFLAGS} -ldflags="${go_ldflags}" .
+}
+
+src_install() {
+ dobin mycorrhiza
+
+ einstalldocs
+ doman help/mycorrhiza.1
+}
+
+pkg_postinst() {
+ elog "Quick start: mycorrhiza /your/wiki/directory"
+ elog
+ elog "It will initialize a Git repository, set useful default settings"
+ elog "And run a server on http://localhost:1737"
+ elog "More information here: https://mycorrhiza.wiki/"
+ elog "Also your wiki has built-in documentation :)"
+ elog "You can view this documentation at http://localhost:1737/help"
+}