aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Joldasov <bratishkaerik@landless-city.net>2024-08-01 00:50:54 +0500
committerEric Joldasov <bratishkaerik@landless-city.net>2024-08-01 00:50:54 +0500
commit9eca745ac1fed61e1f57eb97f967a8ddb9b50fdb (patch)
tree97a2cde9ce90b7d49f5d49677261e369ab78e0d8 /www-apps/mycorrhiza
parentdev-zig/zls: add 0.12.0 (diff)
downloadguru-9eca745ac1fed61e1f57eb97f967a8ddb9b50fdb.tar.gz
guru-9eca745ac1fed61e1f57eb97f967a8ddb9b50fdb.tar.bz2
guru-9eca745ac1fed61e1f57eb97f967a8ddb9b50fdb.zip
www-apps/mycorrhiza: add 1.15.0
Signed-off-by: Eric Joldasov <bratishkaerik@landless-city.net>
Diffstat (limited to 'www-apps/mycorrhiza')
-rw-r--r--www-apps/mycorrhiza/Manifest2
-rw-r--r--www-apps/mycorrhiza/mycorrhiza-1.15.0.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/www-apps/mycorrhiza/Manifest b/www-apps/mycorrhiza/Manifest
index 7661b0a72..0c0f1b646 100644
--- a/www-apps/mycorrhiza/Manifest
+++ b/www-apps/mycorrhiza/Manifest
@@ -1,2 +1,4 @@
DIST mycorrhiza-1.14.0-vendor.tar.xz 655368 BLAKE2B 86060d537b37f37d4aa5695d74664090d517fb59e33c089fffa7103a1c79d1cb8ce42aceff198f448e223ade032d37cf836c4035456e47ed5762a26658888014 SHA512 97819fe2fa23783fec8f8249fdcd2eea25d3dafa6bbe81ecffe481a48086a591507dd341ee08a484281f8b6c6bc9a5ef31d75ad7781b3f2e4221496d44af6eaf
DIST mycorrhiza-1.14.0.tar.gz 137956 BLAKE2B 202c0e8591b480a13e24133a7d5f76a71669b69ea70bfb86981721269ce808e07a3c0177dca19f33dadbd4ccaef25fac28134b8f44a0bc6c2b7c7e2cbee22c39 SHA512 fe40f5d382255e5439ace7218c28c1df62e368325835e48d563a52c3432e1f0a967924e4cd569d860f3094f942b94d4a6807d8fbf76db6c6b758a8c74a92b77c
+DIST mycorrhiza-1.15.0-vendor.tar.xz 670776 BLAKE2B d43effa83bbff937419d4c9aeacb6c0107141653e26e78b98e27c975db47f170bdaf40f49a9f3d24a382a897963480f1500549ec3b16af3703b0702016a89a7a SHA512 5145107c91e8c58a71b7778731c6a40d4df791ada86a850c52c7358000fc398788510334b93d0e28e1053d1ed7013e80aaf0d500bc87c906e33822990467d7ca
+DIST mycorrhiza-1.15.0.tar.gz 141894 BLAKE2B ebb47ac42d0a1c2779e531473cb18c91c4e926a0f8d3c492b5aa8221d0e44f6ac79d9e7ba8e586375ec962e4fc0eb0c5a2c579bf28ca6c492e63cf106e9164ec SHA512 6ff0aada001d0b6be31aa1d8418e42b4db7166f0a97a5a5d627e7bfed64d9fe84bdc5fe30640249955fb406d6a725e4bd26fbf9931602b5a5ab9655d9da8432b
diff --git a/www-apps/mycorrhiza/mycorrhiza-1.15.0.ebuild b/www-apps/mycorrhiza/mycorrhiza-1.15.0.ebuild
new file mode 100644
index 000000000..78b08f61f
--- /dev/null
+++ b/www-apps/mycorrhiza/mycorrhiza-1.15.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Git-based wiki engine written in Go using mycomarkup"
+HOMEPAGE="https://mycorrhiza.wiki"
+SRC_URI="
+ https://github.com/bouncepaw/mycorrhiza/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://codeberg.org/BratishkaErik/distfiles/releases/download/mycorrhiza-${PV}/mycorrhiza-${PV}-vendor.tar.xz
+"
+
+LICENSE="AGPL-3 MIT Apache-2.0 BSD BSD-2 CC-BY-4.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RESTRICT="mirror"
+
+BDEPEND=">=dev-lang/go-1.22"
+RDEPEND="dev-vcs/git"
+
+DOCS=( Boilerplate.md README.md )
+
+src_compile() {
+ ego build -buildmode=pie -ldflags "-s -linkmode external -extldflags '${LDFLAGS}'" -trimpath .
+}
+
+src_install() {
+ dobin mycorrhiza
+
+ einstalldocs
+ doman help/mycorrhiza.1
+}
+
+pkg_postinst() {
+ elog "Quick start: mycorrhiza /your/wiki/directory"
+ elog
+ elog "It will initialize a Git repository, set useful default settings"
+ elog "And run a server on http://localhost:1737"
+ elog "More information here: https://mycorrhiza.wiki/"
+ elog "Also your wiki has built-in documentation :)"
+ elog "You can view this documentation at http://localhost:1737/help"
+}