aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2022-08-15 14:22:41 +0000
committerAisha Tammy <gentoo@aisha.cc>2022-08-15 14:22:41 +0000
commit4bc118ee0320a8a5e1e44ae2667316b36fbb41b7 (patch)
treee6fd9a77b7eeeac73338fe1b7e92744236743502 /sys-kernel
parentnet-libs/dpdk: drop 22.03 (diff)
downloadguru-4bc118ee0320a8a5e1e44ae2667316b36fbb41b7.tar.gz
guru-4bc118ee0320a8a5e1e44ae2667316b36fbb41b7.tar.bz2
guru-4bc118ee0320a8a5e1e44ae2667316b36fbb41b7.zip
sys-kernel/rte_kni-kmod: drop 22.03
Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/rte_kni-kmod/Manifest1
-rw-r--r--sys-kernel/rte_kni-kmod/rte_kni-kmod-22.03.ebuild86
2 files changed, 0 insertions, 87 deletions
diff --git a/sys-kernel/rte_kni-kmod/Manifest b/sys-kernel/rte_kni-kmod/Manifest
index 69dd6fcc9..26d1a089d 100644
--- a/sys-kernel/rte_kni-kmod/Manifest
+++ b/sys-kernel/rte_kni-kmod/Manifest
@@ -1,3 +1,2 @@
DIST dpdk-21.11.1.tar.xz 15115156 BLAKE2B 089e98279922b5494b205d957f9ac05001a668f4536d45e5fd89b9f7d04779e0671ec428b2408963641da3ae999d5943a1ff5dc59c23020ccefce824609c8f11 SHA512 d7afc0c918626b1706a18a129086fcd3741b251c28fa00c5711eb85a03137e5ee6e08de7bd5ebe957e442dc9b901314042b382b223e74f0fdd5d560ac657f1b3
-DIST dpdk-22.03.tar.xz 15055548 BLAKE2B 16fb52618e72deba7097e4d920e160e14f1332eed2b8f2f2957f3dd1b847859e6b8b8cd6adef0513cd7bc528a37d4c481f803e8c5badaa299d2bb2af3615e696 SHA512 b3940642f99767323f39470c1e3e0eab7a07bcaca225e2a714b62ba6c59d2c66e4ea17d38e8266f37ed8b5c5c2ad272930fd28f545324ec0a1cb185685e06a5f
DIST dpdk-22.07.tar.xz 15231912 BLAKE2B 29e36519fb91d440645259932863b5fb6c2386f78d9ba78a871505d7d32e9f4803012aa62044aa578585eee4507aa1c277bda6ec0428a27820faef644f5bfd79 SHA512 8b2adb8a47732efca4e35a68ab03d6c579fc0f699344c0c10be45e62c90d412ebea5ddc37a26efd08a9af08e65c84de177817300a66e6107674f15ecfe3e696c
diff --git a/sys-kernel/rte_kni-kmod/rte_kni-kmod-22.03.ebuild b/sys-kernel/rte_kni-kmod/rte_kni-kmod-22.03.ebuild
deleted file mode 100644
index f0b7092e5..000000000
--- a/sys-kernel/rte_kni-kmod/rte_kni-kmod-22.03.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit linux-mod python-single-r1 meson
-
-DESCRIPTION="DPDK Kernel Nic Interface module"
-HOMEPAGE="https://dpdk.org/"
-SRC_URI="https://fast.dpdk.org/rel/dpdk-${PV}.tar.xz"
-S="${WORKDIR}/dpdk-${PV}"
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-# tests need root
-RESTRICT="test"
-
-RDEPEND="${PYTHON_DEPS}"
-
-DEPEND="${RDEPEND}
- $(python_gen_cond_dep '
- dev-python/pyelftools[${PYTHON_USEDEP}]
- ')
- app-crypt/intel-ipsec-mb
- dev-libs/elfutils
- dev-libs/isa-l
- dev-libs/jansson
- dev-libs/libbpf
- dev-libs/libbsd
- dev-libs/openssl
- net-libs/libmnl
- net-libs/libpcap
- sys-apps/dtc
- sys-cluster/rdma-core
- sys-process/numactl
-"
-BDEPEND="
- ${PYTHON_DEPS}
-"
-
-PATCHES=( "${FILESDIR}/dpdk-22.03-binutils.patch" )
-
-pkg_setup() {
- linux-mod_pkg_setup
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
- sed -e "s/@OBJDUMP@/$(tc-getOBJDUMP)/g" -i \
- buildtools/meson.build \
- buildtools/check-symbols.sh \
- devtools/check-abi-version.sh || die
-}
-
-src_configure() {
- linux-mod_pkg_setup
- python-single-r1_pkg_setup
- # we still have to do meson configuration as it creates
- # header files needed for compiling the rte_kni module
- local emesonargs=(
- -Denable_kmods=false
- -Dmachine=default
- -Dplatform=generic
- )
- meson_src_configure
-
- # export after meson_src_configure as BUILD_DIR is needed for module compilation
- export MODULE_NAMES="rte_kni(extra/dpdk:${S}/kernel/linux/kni)"
- export BUILD_PARAMS="-C \"${KERNEL_DIR}\" M=\"${S}\"/kernel/linux/kni \
- src=\"${S}\"/kernel/linux/kni \
- MODULE_CFLAGS=\"${HAVE_ARG_TX_QUEUE} -include ${S}/config/rte_config.h -I${S}/lib/eal/include \
- -I${S}/lib/kni -I${S}/kernel/linux/kni -I${BUILD_DIR} -I${S}\""
- export BUILD_TARGETS="modules"
-}
-
-src_compile() {
- linux-mod_src_compile
-}
-
-src_install() {
- linux-mod_src_install
-}