aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@gentoo.org>2024-02-17 17:37:58 +0100
committerArsen Arsenović <arsen@gentoo.org>2024-02-17 17:37:58 +0100
commit8e0b467ca8f62b33a23b08ccad204a7e00869034 (patch)
tree68411111b4414e7a90acc843ef319224a8cda5e2 /sys-boot
parentdev-libs/qschematic: drop 1.5.0 (diff)
downloadguru-8e0b467ca8f62b33a23b08ccad204a7e00869034.tar.gz
guru-8e0b467ca8f62b33a23b08ccad204a7e00869034.tar.bz2
guru-8e0b467ca8f62b33a23b08ccad204a7e00869034.zip
sys-boot/limine: add 7.0.5
Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/limine/Manifest1
-rw-r--r--sys-boot/limine/limine-7.0.5.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-boot/limine/Manifest b/sys-boot/limine/Manifest
index 2f4768c9d3..c0660c195d 100644
--- a/sys-boot/limine/Manifest
+++ b/sys-boot/limine/Manifest
@@ -1,2 +1,3 @@
DIST limine-7.0.0.tar.xz 1318064 BLAKE2B 7986d948fe84c80b338e5cc66edca5f511d277d2e854484c87183666bf1b075480b61213c177b6e39a1145502cc9e07b9e1442c3dcf3171339af5b55ac9c184f SHA512 40575711e0e51799cbca2b2de74eff813022ab760c32de7d485f0cb70aa6daa8c842d20ed3d740e8c59e4be63eab43969b0cf809f2e796107d7e9be221bd9bf6
DIST limine-7.0.3.tar.xz 371416 BLAKE2B 7450784d53ef86993f53c84da4f51ee8a1beb826153da8fa2cef1a0669688de370a53ced321a92276e4b53fb7c9c1081f71b4a4c7adf432b271d395e96f00595 SHA512 d8d92f237f56249555fa54b5608ad2bdeff7c7b53e055f925acb3a7feeb783407c4c5d7ce092dba0b9a93441cfd1d0dcc4ec01a9e94c14e1742119a50f63aa06
+DIST limine-7.0.5.tar.xz 371612 BLAKE2B 029953e1a5adeac2b1cd92bfff3b3a893b8ad1f458f1560b194ad0607638a3cc77d4927f1f4376a958d7ae513400ec615ab092ef97cbb220e5866821e83f7fdc SHA512 149bc59785d06b293a9a9d18722afee66301e698fdd349bc5bd211720873213239617af0de665e22dc43299e7a580359d4d407c9eb6ffd6ac85c1de484124055
diff --git a/sys-boot/limine/limine-7.0.5.ebuild b/sys-boot/limine/limine-7.0.5.ebuild
new file mode 100644
index 0000000000..73ea272148
--- /dev/null
+++ b/sys-boot/limine/limine-7.0.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Limine is a modern, advanced, and portable BIOS/UEFI multiprotocol bootloader"
+HOMEPAGE="https://limine-bootloader.org/"
+SRC_URI="https://github.com/limine-bootloader/limine/releases/download/v${PV}/limine-${PV}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+bios +bios-pxe +bios-cd +cd-efi +uefi32 +uefi64 +uefiaa64 +uefirv64"
+
+MY_LLVM_TARGETS="AArch64 ARM X86 RISCV"
+MY_LLVM_FLAGS="llvm_targets_${MY_LLVM_TARGETS// /(-),llvm_targets_}(-)"
+
+BDEPEND="
+ app-alternatives/gzip
+ dev-lang/nasm
+ sys-apps/findutils
+ sys-devel/clang[${MY_LLVM_FLAGS}]
+ sys-devel/lld
+ sys-devel/llvm[${MY_LLVM_FLAGS}]
+
+ cd-efi? ( sys-fs/mtools )
+"
+
+src_configure() {
+ local myconf=(
+ "$(use_enable bios)"
+ "$(use_enable bios-cd)"
+ "$(use_enable bios-pxe)"
+
+ "$(use_enable uefi32 uefi-ia32)"
+ "$(use_enable uefi64 uefi-x86-64)"
+ "$(use_enable uefiaa64 uefi-aarch64)"
+ "$(use_enable uefirv64 uefi-riscv64)"
+ "$(use_enable cd-efi uefi-cd)"
+ )
+
+ TOOLCHAIN_FOR_TARGET=llvm \
+ econf "${myconf[@]}"
+}