aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Słomiński <kacper.slominski72@gmail.com>2024-09-02 15:51:28 +0200
committerKacper Słomiński <kacper.slominski72@gmail.com>2024-09-02 15:51:28 +0200
commit2724d3f48bb917948fd1367dae7f6d1b0a26af90 (patch)
tree9d636b9ac6239315dc55bfdf579108667a453a33 /sys-boot
parentdev-python/guidata: disable py3.13 (diff)
downloadguru-2724d3f48bb917948fd1367dae7f6d1b0a26af90.tar.gz
guru-2724d3f48bb917948fd1367dae7f6d1b0a26af90.tar.bz2
guru-2724d3f48bb917948fd1367dae7f6d1b0a26af90.zip
sys-boot/limine: add 8.0.7
Signed-off-by: Kacper Słomiński <kacper.slominski72@gmail.com>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/limine/Manifest1
-rw-r--r--sys-boot/limine/limine-8.0.7.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sys-boot/limine/Manifest b/sys-boot/limine/Manifest
index e1deec35e..5f922a745 100644
--- a/sys-boot/limine/Manifest
+++ b/sys-boot/limine/Manifest
@@ -6,3 +6,4 @@ DIST limine-7.5.0.tar.gz 518804 BLAKE2B 745929606cf5e5e297f55690573e26bea8b63f8c
DIST limine-7.9.2.tar.gz 562984 BLAKE2B da301c51dfc487b83e87c25be37457ae7bd532140b3124a1903b6cc46ec15508412445cadb24675193e972fc1d1d4259441ce51282825a84e9713cabad80efb9 SHA512 d3526d1ac4e8b9172b93f6e113c78b8be3ad5196dc82e27cc2a9eb23bfb7581d421b96a736f5a149ec83be6363c2210f23af22ae6c039447ea202e56c21b9d6c
DIST limine-8.0.5.tar.gz 551786 BLAKE2B 20e6fc247c27163ab0b57790853549479671f6b9f00000e9da43c686485798f249d4e36fafeda426935074b28dd4676539d079c7125b27bbcd83ccb92ec30e2d SHA512 4fbab007c7ebc9648e5ba513b4cc19e42615f3c30ae4e3ee7ef10f782b38581c3fe9685eb497bf0ee6b685e032624143e606766569e1045d82321223fd5a0e61
DIST limine-8.0.6.tar.gz 553792 BLAKE2B 69a654b86a0d277893c099591fe6551328a7bbe403c64c2f4de931149fc720320f6c5d794a327346241eee6d9ee665eff9c83061d8a573daf568bc7018d4db90 SHA512 17b5b31f5ccaf22eb7c3708b42e52f15f10a2acf590c93129a01c0a4ce5ca5aa90a11bfc11572b28c1bdbda5a7013e4aef61b851a9e3dddadcd6a4feb1fb6913
+DIST limine-8.0.7.tar.gz 553771 BLAKE2B 353ddfc22bf4609c926aa94297b7b3895727cba0f8676e621c00894422421f7a4f2b03d1381870e5422125868c622100f8c39e1e2f63eb3586c5e5d627f231c7 SHA512 e72bd39ed473c9d27b1b926ce7cc0ff5bdb74d355a92d77b7f05dbdccdfa4f83769863b700b988e8d868902bd2a8b59ace7001aec44345dfc697ba2bb04fd05f
diff --git a/sys-boot/limine/limine-8.0.7.ebuild b/sys-boot/limine/limine-8.0.7.ebuild
new file mode 100644
index 000000000..8f7c11f6a
--- /dev/null
+++ b/sys-boot/limine/limine-8.0.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LLVM_COMPAT=( {16..18} )
+inherit llvm-r1
+
+DESCRIPTION="Limine is a modern, advanced, and portable BIOS/UEFI multiprotocol bootloader"
+HOMEPAGE="https://limine-bootloader.org/"
+SRC_URI="https://github.com/limine-bootloader/limine/releases/download/v${PV}/limine-${PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+bios +bios-pxe +bios-cd +cd-efi +uefi32 +uefi64 +uefiaa64 +uefirv64 +uefiloong64"
+
+MY_LLVM_TARGETS="AArch64 ARM X86 RISCV LoongArch"
+MY_LLVM_FLAGS="llvm_targets_${MY_LLVM_TARGETS// /(-),llvm_targets_}(-)"
+
+BDEPEND="
+ app-alternatives/gzip
+ dev-lang/nasm
+ sys-apps/findutils
+ $(llvm_gen_dep "
+ sys-devel/llvm:\${LLVM_SLOT}[${MY_LLVM_FLAGS}]
+ sys-devel/clang:\${LLVM_SLOT}[${MY_LLVM_FLAGS}]
+ sys-devel/lld:\${LLVM_SLOT}
+ ")
+ cd-efi? ( sys-fs/mtools )
+"
+
+src_configure() {
+ local myconf=(
+ "$(use_enable bios)"
+ "$(use_enable bios-cd)"
+ "$(use_enable bios-pxe)"
+
+ "$(use_enable uefi32 uefi-ia32)"
+ "$(use_enable uefi64 uefi-x86-64)"
+ "$(use_enable uefiaa64 uefi-aarch64)"
+ "$(use_enable uefirv64 uefi-riscv64)"
+ "$(use_enable uefiloong64 uefi-loongarch64)"
+ "$(use_enable cd-efi uefi-cd)"
+ )
+
+ TOOLCHAIN_FOR_TARGET=llvm \
+ econf "${myconf[@]}"
+}