aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTakuya Wakazono <pastalian46@gmail.com>2024-11-14 20:53:06 +0900
committerTakuya Wakazono <pastalian46@gmail.com>2024-11-14 20:53:06 +0900
commitaca6db9408272567b1a9c8db806c61d459f7ac13 (patch)
treeec6139b571ba9603a6f55462dae02c16852f33db /sys-apps
parentdev-libs/libsolv: add 0.7.31 (diff)
downloadguru-aca6db9408272567b1a9c8db806c61d459f7ac13.tar.gz
guru-aca6db9408272567b1a9c8db806c61d459f7ac13.tar.bz2
guru-aca6db9408272567b1a9c8db806c61d459f7ac13.zip
sys-apps/dnf5: remove buggy tests
Removing buggy tests until upstream fixes them. https://github.com/rpm-software-management/dnf5/issues/1692 Closes: https://bugs.gentoo.org/939518 Signed-off-by: Takuya Wakazono <pastalian46@gmail.com>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/dnf5/dnf5-5.2.6.0-r1.ebuild (renamed from sys-apps/dnf5/dnf5-5.2.6.0.ebuild)4
-rw-r--r--sys-apps/dnf5/files/dnf5-5.2.6.0-remove-buggy-tests.patch22
2 files changed, 25 insertions, 1 deletions
diff --git a/sys-apps/dnf5/dnf5-5.2.6.0.ebuild b/sys-apps/dnf5/dnf5-5.2.6.0-r1.ebuild
index d5b62426e..53c63f2c5 100644
--- a/sys-apps/dnf5/dnf5-5.2.6.0.ebuild
+++ b/sys-apps/dnf5/dnf5-5.2.6.0-r1.ebuild
@@ -18,7 +18,7 @@ RESTRICT="!test? ( test )"
RDEPEND="
>=app-arch/rpm-4.17.0
- dev-cpp/sdbus-c++:=
+ dev-cpp/sdbus-c++:0/1
dev-cpp/toml11
>=dev-db/sqlite-3.35.0:3
>=dev-libs/glib-2.46.0:2
@@ -48,6 +48,8 @@ PATCHES=(
"${FILESDIR}/${PN}-5.2.5.0-remove-empty-dir.patch"
# Prevent test suite from writing to system files.
"${FILESDIR}/${PN}-5.2.5.0-sandbox-test.patch"
+ # bug #939518
+ "${FILESDIR}/${P}-remove-buggy-tests.patch"
)
src_prepare() {
diff --git a/sys-apps/dnf5/files/dnf5-5.2.6.0-remove-buggy-tests.patch b/sys-apps/dnf5/files/dnf5-5.2.6.0-remove-buggy-tests.patch
new file mode 100644
index 000000000..f07af504a
--- /dev/null
+++ b/sys-apps/dnf5/files/dnf5-5.2.6.0-remove-buggy-tests.patch
@@ -0,0 +1,22 @@
+Those tests causes a use-after-free.
+https://bugs.gentoo.org/939518
+https://github.com/rpm-software-management/dnf5/issues/1692
+diff --git a/test/dnf5-plugins/copr_plugin/CMakeLists.txt b/test/dnf5-plugins/copr_plugin/CMakeLists.txt
+index 2a99f6c6..ce87b437 100644
+--- a/test/dnf5-plugins/copr_plugin/CMakeLists.txt
++++ b/test/dnf5-plugins/copr_plugin/CMakeLists.txt
+@@ -24,5 +24,3 @@ target_link_libraries(run_tests_copr PRIVATE ${JSONC_LIBRARIES})
+
+ add_compile_definitions(TEST_DATADIR="${CMAKE_CURRENT_SOURCE_DIR}/data")
+
+-add_test(NAME test_copr COMMAND run_tests_copr)
+-set_tests_properties(test_copr PROPERTIES RUN_SERIAL TRUE)
+diff --git a/test/libdnf5-cli/CMakeLists.txt b/test/libdnf5-cli/CMakeLists.txt
+index e37cbfa5..02722d40 100644
+--- a/test/libdnf5-cli/CMakeLists.txt
++++ b/test/libdnf5-cli/CMakeLists.txt
+@@ -19,4 +19,3 @@ target_link_directories(run_tests_cli PRIVATE ${CMAKE_BINARY_DIR}/libdnf5)
+ target_link_libraries(run_tests_cli PRIVATE stdc++ libdnf5_static libdnf5-cli cppunit test_shared)
+
+
+-add_test(NAME test_libdnf_cli COMMAND run_tests_cli)