aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFilip Kobierski <fkobi@pm.me>2024-08-24 20:41:30 +0200
committerFilip Kobierski <fkobi@pm.me>2024-08-24 20:41:30 +0200
commit993bec4cfb5997d351dd2c2f160828624f6e793a (patch)
tree48da3a0d5b5aad8814063a46746616a8a74a9135 /sys-apps
parentsys-apps/asus-numpad: drop 0.1 (diff)
downloadguru-993bec4cfb5997d351dd2c2f160828624f6e793a.tar.gz
guru-993bec4cfb5997d351dd2c2f160828624f6e793a.tar.bz2
guru-993bec4cfb5997d351dd2c2f160828624f6e793a.zip
sys-apps/asus-numpad: bump EAPI, improve ebuild
Signed-off-by: Filip Kobierski <fkobi@pm.me>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/asus-numpad/asus-numpad-0.2-r1.ebuild (renamed from sys-apps/asus-numpad/asus-numpad-0.2.ebuild)12
-rw-r--r--sys-apps/asus-numpad/asus-numpad-9999.ebuild12
2 files changed, 10 insertions, 14 deletions
diff --git a/sys-apps/asus-numpad/asus-numpad-0.2.ebuild b/sys-apps/asus-numpad/asus-numpad-0.2-r1.ebuild
index 31a2c29bd..9d72a2c86 100644
--- a/sys-apps/asus-numpad/asus-numpad-0.2.ebuild
+++ b/sys-apps/asus-numpad/asus-numpad-0.2-r1.ebuild
@@ -1,14 +1,13 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/xytovl/asus-numpad.git"
inherit git-r3
else
- TAG="v${PV}"
- SRC_URI="https://github.com/xytovl/${PN}/archive/${TAG}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/xytovl/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi
@@ -20,9 +19,8 @@ HOMEPAGE="https://github.com/xytovl/asus-numpad"
LICENSE="GPL-3"
SLOT="0"
-COMMON_DEPEND=">=dev-libs/libevdev-1.12.0"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}"
+DEPEND=">=dev-libs/libevdev-1.12.0"
+RDEPEND=${DEPEND}
src_configure() {
meson_src_configure
diff --git a/sys-apps/asus-numpad/asus-numpad-9999.ebuild b/sys-apps/asus-numpad/asus-numpad-9999.ebuild
index 31a2c29bd..9d72a2c86 100644
--- a/sys-apps/asus-numpad/asus-numpad-9999.ebuild
+++ b/sys-apps/asus-numpad/asus-numpad-9999.ebuild
@@ -1,14 +1,13 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/xytovl/asus-numpad.git"
inherit git-r3
else
- TAG="v${PV}"
- SRC_URI="https://github.com/xytovl/${PN}/archive/${TAG}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/xytovl/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi
@@ -20,9 +19,8 @@ HOMEPAGE="https://github.com/xytovl/asus-numpad"
LICENSE="GPL-3"
SLOT="0"
-COMMON_DEPEND=">=dev-libs/libevdev-1.12.0"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}"
+DEPEND=">=dev-libs/libevdev-1.12.0"
+RDEPEND=${DEPEND}
src_configure() {
meson_src_configure