aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenri Gasc <gasc@eurecom.fr>2024-10-10 15:38:00 +0200
committerHenri Gasc <gasc@eurecom.fr>2024-10-10 18:04:18 +0200
commit23d5cdaf2c5509acdab7bd316d11afa745e2ffac (patch)
tree64c7383ee718f230f0ced9f1df2d9e29f4cab4fc /sci-mathematics
parentdev-python/moderngl: add 5.11.1, drop 5.10.0 (diff)
downloadguru-23d5cdaf2c5509acdab7bd316d11afa745e2ffac.tar.gz
guru-23d5cdaf2c5509acdab7bd316d11afa745e2ffac.tar.bz2
guru-23d5cdaf2c5509acdab7bd316d11afa745e2ffac.zip
sci-mathematics/pyromaths: Change how doc is handled
Closes: https://bugs.gentoo.org/937506 Signed-off-by: Henri Gasc <gasc@eurecom.fr>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/pyromaths/pyromaths-21.8.2-r1.ebuild (renamed from sci-mathematics/pyromaths/pyromaths-21.8.2.ebuild)24
1 files changed, 8 insertions, 16 deletions
diff --git a/sci-mathematics/pyromaths/pyromaths-21.8.2.ebuild b/sci-mathematics/pyromaths/pyromaths-21.8.2-r1.ebuild
index da1e87e8f..9d50692ec 100644
--- a/sci-mathematics/pyromaths/pyromaths-21.8.2.ebuild
+++ b/sci-mathematics/pyromaths/pyromaths-21.8.2-r1.ebuild
@@ -3,10 +3,16 @@
EAPI=8
+DOCS_BUILDER="sphinx"
+DOCS_DEPEND="
+ dev-python/sphinx-argparse
+"
+DOCS_DIR="Doc/source"
+
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
-inherit distutils-r1
+inherit distutils-r1 docs
DESCRIPTION="Create maths exercises in LaTeX and PDF format"
@@ -35,10 +41,6 @@ RDEPEND="
"
BDEPEND="
dev-python/jinja2-cli[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-argparse[${PYTHON_USEDEP}]
- )
"
DEPEND="${RDEPEND}"
@@ -47,13 +49,3 @@ PATCHES=(
)
distutils_enable_tests pytest
-
-python_compile() {
- distutils-r1_python_compile
- use doc && emake man -C Doc
-}
-
-python_install() {
- distutils-r1_python_install
- use doc && doman "${S}/Doc/build/man/pyromaths.1"
-}