aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorItai Ferber <itai@itaiferber.net>2024-08-22 13:08:49 -0400
committerItai Ferber <itai@itaiferber.net>2024-08-22 13:08:49 -0400
commitc2905adafc9d7810671b12b910376e6b00e17d5c (patch)
treee987f0189af95b489c48a34559476c770ebaea8b /net-vpn
parentnet-dns/noip-duc: Correct homepage URL (diff)
downloadguru-c2905adafc9d7810671b12b910376e6b00e17d5c.tar.gz
guru-c2905adafc9d7810671b12b910376e6b00e17d5c.tar.bz2
guru-c2905adafc9d7810671b12b910376e6b00e17d5c.zip
net-vpn/mullvadvpn-app: add 2024.5_beta1
Signed-off-by: Itai Ferber <itai@itaiferber.net>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/mullvadvpn-app/Manifest4
-rw-r--r--net-vpn/mullvadvpn-app/mullvadvpn-app-2024.5_beta1.ebuild76
2 files changed, 79 insertions, 1 deletions
diff --git a/net-vpn/mullvadvpn-app/Manifest b/net-vpn/mullvadvpn-app/Manifest
index 33accc1ea..200500608 100644
--- a/net-vpn/mullvadvpn-app/Manifest
+++ b/net-vpn/mullvadvpn-app/Manifest
@@ -1,2 +1,4 @@
-DIST MullvadVPN-2024.4_x86_64.rpm 90830721 BLAKE2B c9ac8bc13fc2f4789ba3e08cd8d4fe23c71b759313afed4fd7c1f3dd2f5f8d535aa48da4526e7039a64c6863747392c3537bff39cca9a9cbbfd3174a485ad4b5 SHA512 4d46bd92f5f4cbd95bfbd7e0e311ee7c2a88012b465bfe51f9d3cf760d23026dc8300511f1cef9486d70b6a10578057493afe93c98688087149bd381460b813d
DIST MullvadVPN-2024.4_aarch64.rpm 84958649 BLAKE2B 173f9675a64f16e3d1473022dee0c543faa3ce1f5a996504b3ab814a8db3efa3103ab055292e58d1c74a5b2f1283f3404dbd85695dc25f449acfb2bfff879de3 SHA512 1abcb5df358cdc1c18ea0d3e366241b2f875391eeb240af2955a907faed427655682d9e594bff1e314137711f5c141d4036e6f8eccc3178aefd9e7e65c415f51
+DIST MullvadVPN-2024.4_x86_64.rpm 90830721 BLAKE2B c9ac8bc13fc2f4789ba3e08cd8d4fe23c71b759313afed4fd7c1f3dd2f5f8d535aa48da4526e7039a64c6863747392c3537bff39cca9a9cbbfd3174a485ad4b5 SHA512 4d46bd92f5f4cbd95bfbd7e0e311ee7c2a88012b465bfe51f9d3cf760d23026dc8300511f1cef9486d70b6a10578057493afe93c98688087149bd381460b813d
+DIST MullvadVPN-2024.5-beta1_aarch64.rpm 85192345 BLAKE2B 9623694211b0518237645e5506ceb0c1e267f48e65bbc01c102d8a104b148ab0befdd09b37a39c5a2228531833d323bf105f5164d445931cebdfb3c2aafd3e17 SHA512 8e8294ba067e04dd503c8df32c18c6a8e6342e3c2d31bdcdb19eda001164246c99d31a6629dfefa7d58d9489e99904ce2b55c146ca0aa42197952d7c96346117
+DIST MullvadVPN-2024.5-beta1_x86_64.rpm 91094269 BLAKE2B f5eb6dfc96b4413119986ab026a09d57df419a1e208e6ba58954e22cadd83625fe9ee36926cdca5090c244c77243e63c4eb324ab26a570a4f81bbbff4ee33fe7 SHA512 218a95c440606c480b293cff852a67d9b97e1c40c729b5da352bd51b17ebec91aa39fb59fba1d5bc434596df2ade7194b4a2392661a7f1c869964bf5097a1efe
diff --git a/net-vpn/mullvadvpn-app/mullvadvpn-app-2024.5_beta1.ebuild b/net-vpn/mullvadvpn-app/mullvadvpn-app-2024.5_beta1.ebuild
new file mode 100644
index 000000000..1148a8d12
--- /dev/null
+++ b/net-vpn/mullvadvpn-app/mullvadvpn-app-2024.5_beta1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop rpm systemd shell-completion xdg
+
+MYPV="${PV/_beta/-beta}"
+DESCRIPTION="Tool used to manage daemon setup"
+HOMEPAGE="https://github.com/mullvad/mullvadvpn-app https://mullvad.net/"
+SRC_URI="
+ amd64? ( https://github.com/mullvad/mullvadvpn-app/releases/download/${MYPV}/MullvadVPN-${MYPV}_x86_64.rpm )
+ arm64? ( https://github.com/mullvad/mullvadvpn-app/releases/download/${MYPV}/MullvadVPN-${MYPV}_aarch64.rpm )
+"
+
+S="${WORKDIR}"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm64"
+
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ app-accessibility/at-spi2-core
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ x11-libs/gtk+
+ x11-libs/libdrm
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/pango
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ sed -i "s|SCRIPT_DIR=.*|SCRIPT_DIR=\"/opt/Mullvad VPN/\"|g" "${S}/opt/Mullvad VPN/mullvad-vpn" || die
+
+ # Using doins -r would strip executable bits from all binaries
+ cp -pPR "${S}"/opt "${D}"/ || die "Failed to copy files"
+ fperms +x "/opt/Mullvad VPN/chrome_crashpad_handler"
+ fperms 4755 "/opt/Mullvad VPN/chrome-sandbox"
+
+ dobin "${S}"/usr/bin/mullvad
+ dobin "${S}"/usr/bin/mullvad-daemon
+ dobin "${S}"/usr/bin/mullvad-exclude
+ dosym "../../opt/Mullvad VPN/mullvad-vpn" /usr/bin/mullvad-vpn
+ dosym "../../opt/Mullvad VPN/resources/mullvad-problem-report" /usr/bin/mullvad-problem-report
+
+ # mullvad-exclude uses cgroups to manage exclusions, which requires root permissions, but is
+ # also most often used to exclude graphical applications which can't or shouldn't run as root
+ # (i.e., can't be run under `sudo/doas /usr/bin/mullvad-exclude ...`, because `sudo`/`doas`
+ # change user). The setuid bit allows any user to exclude executables under their own UID.
+ fperms 4755 /usr/bin/mullvad-exclude
+
+ newinitd "${FILESDIR}"/mullvad-daemon.initd mullvad-daemon
+
+ systemd_newunit "${S}"/usr/lib/systemd/system/mullvad-daemon.service mullvad-daemon.service
+ systemd_newunit "${S}"/usr/lib/systemd/system/mullvad-early-boot-blocking.service mullvad-early-boot-blocking.service
+
+ newbashcomp "${S}"/usr/share/bash-completion/completions/mullvad mullvad
+ newfishcomp "${S}"/usr/share/fish/vendor_completions.d/mullvad.fish mullvad
+ newzshcomp "${S}"/usr/share/zsh/site-functions/_mullvad _mullvad
+
+ domenu "${S}"/usr/share/applications/mullvad-vpn.desktop
+ local x
+ for x in 16 32 48 64 128 256 512 1024; do
+ doicon -s ${x} "${S}"/usr/share/icons/hicolor/${x}x${x}/apps/mullvad-vpn.png
+ done
+}