aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorItai Ferber <itai@itaiferber.net>2024-07-25 10:26:21 -0400
committerItai Ferber <itai@itaiferber.net>2024-07-25 10:26:52 -0400
commit5ff1751883efd00e6e5ed6607517720f7faf811d (patch)
tree97241b3eb3405591e3df0cdd87bb09dcd4d7b625 /net-vpn
parentnet-vpn/mullvadvpn-app: add 2024.4, drop 2024.4_beta1 (diff)
downloadguru-5ff1751883efd00e6e5ed6607517720f7faf811d.tar.gz
guru-5ff1751883efd00e6e5ed6607517720f7faf811d.tar.bz2
guru-5ff1751883efd00e6e5ed6607517720f7faf811d.zip
net-vpn/mullvadvpn-app: drop 2024.3
Signed-off-by: Itai Ferber <itai@itaiferber.net>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/mullvadvpn-app/Manifest1
-rw-r--r--net-vpn/mullvadvpn-app/mullvadvpn-app-2024.3.ebuild75
2 files changed, 0 insertions, 76 deletions
diff --git a/net-vpn/mullvadvpn-app/Manifest b/net-vpn/mullvadvpn-app/Manifest
index 047afd24f..33accc1ea 100644
--- a/net-vpn/mullvadvpn-app/Manifest
+++ b/net-vpn/mullvadvpn-app/Manifest
@@ -1,3 +1,2 @@
-DIST MullvadVPN-2024.3_x86_64.rpm 88010345 BLAKE2B 8335327427e3033eca1219f16e340b0a5e9aac399e1d54f9abd771a0c02a5a6451dff89af7d9bc977ef2aca744259e99ba5ada1014eae6a69c38c384d1762d03 SHA512 4feec0521cd3a52b7d3aa82f851694ff8a27ab63188d673d6ce8b62d5485acbd8eefc6d35f99da6c40c6b6fce0e9c735d121329d97589a6869138aafafd62fd9
DIST MullvadVPN-2024.4_x86_64.rpm 90830721 BLAKE2B c9ac8bc13fc2f4789ba3e08cd8d4fe23c71b759313afed4fd7c1f3dd2f5f8d535aa48da4526e7039a64c6863747392c3537bff39cca9a9cbbfd3174a485ad4b5 SHA512 4d46bd92f5f4cbd95bfbd7e0e311ee7c2a88012b465bfe51f9d3cf760d23026dc8300511f1cef9486d70b6a10578057493afe93c98688087149bd381460b813d
DIST MullvadVPN-2024.4_aarch64.rpm 84958649 BLAKE2B 173f9675a64f16e3d1473022dee0c543faa3ce1f5a996504b3ab814a8db3efa3103ab055292e58d1c74a5b2f1283f3404dbd85695dc25f449acfb2bfff879de3 SHA512 1abcb5df358cdc1c18ea0d3e366241b2f875391eeb240af2955a907faed427655682d9e594bff1e314137711f5c141d4036e6f8eccc3178aefd9e7e65c415f51
diff --git a/net-vpn/mullvadvpn-app/mullvadvpn-app-2024.3.ebuild b/net-vpn/mullvadvpn-app/mullvadvpn-app-2024.3.ebuild
deleted file mode 100644
index 10a75386a..000000000
--- a/net-vpn/mullvadvpn-app/mullvadvpn-app-2024.3.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit desktop rpm systemd shell-completion xdg
-
-DESCRIPTION="Tool used to manage daemon setup"
-HOMEPAGE="https://github.com/mullvad/mullvadvpn-app https://mullvad.net/"
-SRC_URI="amd64? ( https://github.com/mullvad/mullvadvpn-app/releases/download/${PV}/MullvadVPN-${PV}_x86_64.rpm )"
-
-S="${WORKDIR}"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="-* ~amd64"
-
-RESTRICT="bindist mirror test strip"
-
-RDEPEND="
- app-accessibility/at-spi2-core
- dev-libs/nspr
- dev-libs/nss
- media-libs/alsa-lib
- media-libs/mesa
- net-print/cups
- x11-libs/gtk+
- x11-libs/libdrm
- x11-libs/libXcomposite
- x11-libs/libXdamage
- x11-libs/libXfixes
- x11-libs/libxkbcommon
- x11-libs/libXrandr
- x11-libs/pango
-"
-
-QA_PREBUILT="*"
-
-src_install() {
- sed -i "s|SCRIPT_DIR=.*|SCRIPT_DIR=\"/opt/Mullvad VPN/\"|g" "${S}"/opt/Mullvad\ VPN/mullvad-vpn
-
- # Using doins -r would strip executable bits from all binaries
- cp -pPR "${S}"/opt "${D}"/ || die "Failed to copy files"
- fperms +x "/opt/Mullvad VPN/chrome_crashpad_handler"
- fperms 4755 "/opt/Mullvad VPN/chrome-sandbox"
-
- # tbh I don't know if all next lines are needed or we can just do cp -pPR "${S}"/usr "${D}"/"
-
- local i
- dobin "${S}"/usr/bin/mullvad
- dobin "${S}"/usr/bin/mullvad-daemon
- dobin "${S}"/usr/bin/mullvad-exclude
- dosym "../../opt/Mullvad VPN/mullvad-vpn" /usr/bin/mullvad-vpn
- dosym "../../opt/Mullvad VPN/resources/mullvad-problem-report" /usr/bin/mullvad-problem-report
-
- # mullvad-exclude uses cgroups to manage exclusions, which requires root permissions, but is
- # also most often used to exclude graphical applications which can't or shouldn't run as root
- # (i.e., can't be run under `sudo/doas /usr/bin/mullvad-exclude ...`, because `sudo`/`doas`
- # change user). The setuid bit allows any user to exclude executables under their own UID.
- fperms 4755 /usr/bin/mullvad-exclude
-
- newinitd "${FILESDIR}"/mullvad-daemon.initd mullvad-daemon
-
- systemd_newunit "${S}"/usr/lib/systemd/system/mullvad-daemon.service mullvad-daemon.service
- systemd_newunit "${S}"/usr/lib/systemd/system/mullvad-early-boot-blocking.service mullvad-early-boot-blocking.service
-
- newbashcomp "${S}"/usr/share/bash-completion/completions/mullvad mullvad
- newfishcomp "${S}"/usr/share/fish/vendor_completions.d/mullvad.fish mullvad
- newzshcomp "${S}"/usr/share/zsh/site-functions/_mullvad _mullvad
-
- domenu "${S}"/usr/share/applications/mullvad-vpn.desktop
- local x
- for x in 16 32 48 64 128 256 512 1024; do
- doicon -s ${x} "${S}"/usr/share/icons/hicolor/${x}x${x}/apps/mullvad-vpn.png
- done
-}