aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Pimentel <adam.pimentel@protonmail.com>2022-09-08 15:33:21 -0400
committerAdam Pimentel <adam.pimentel@protonmail.com>2022-09-08 15:35:45 -0400
commitfb3dcffb1d8cb632b81de1809dbc41b90d32d677 (patch)
tree24478abd973dacc5fca065534bcf80806548c79f /net-p2p
parentmedia-video/obs-vkcapture: version bump to 1.2.0 (diff)
downloadguru-fb3dcffb1d8cb632b81de1809dbc41b90d32d677.tar.gz
guru-fb3dcffb1d8cb632b81de1809dbc41b90d32d677.tar.bz2
guru-fb3dcffb1d8cb632b81de1809dbc41b90d32d677.zip
net-p2p/feather: fixed live ebuild
Signed-off-by: Adam Pimentel <adam.pimentel@protonmail.com>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/feather/feather-2.1.0.ebuild5
-rw-r--r--net-p2p/feather/feather-9999.ebuild21
2 files changed, 13 insertions, 13 deletions
diff --git a/net-p2p/feather/feather-2.1.0.ebuild b/net-p2p/feather/feather-2.1.0.ebuild
index fe658d7c6..c9324c8e6 100644
--- a/net-p2p/feather/feather-2.1.0.ebuild
+++ b/net-p2p/feather/feather-2.1.0.ebuild
@@ -20,8 +20,8 @@ MONERO_DIST_COMIT="b45c66e9c62d7e8f24abbcb447f408e618bfd450"
DESCRIPTION="A free, open-source Monero wallet"
HOMEPAGE="https://featherwallet.org"
SRC_URI="https://github.com/feather-wallet/feather/archive/refs/tags/${PVR}.tar.gz -> ${PF}.tar.gz
- https://github.com/tevador/polyseed/archive/${POLYSEED_DIST_COMIT}.tar.gz -> ${PF}-polyseed.tar.gz
- https://github.com/itay-grudev/SingleApplication/archive/${SINGLEAPPLICATION_DIST_COMIT}.tar.gz -> ${PF}-singleapplication.tar.gz
+ https://github.com/tevador/polyseed/archive/${POLYSEED_DIST_COMIT}.tar.gz -> ${PF}-polyseed.tar.gz
+ https://github.com/itay-grudev/SingleApplication/archive/${SINGLEAPPLICATION_DIST_COMIT}.tar.gz -> ${PF}-singleapplication.tar.gz
https://github.com/feather-wallet/monero/archive/${MONERO_DIST_COMIT}.tar.gz -> ${PF}-monero.tar.gz
https://github.com/miniupnp/miniupnp/archive/${MINIUPNP_DIST_COMIT}.tar.gz -> ${PF}-monero-miniupnp.tar.gz
https://github.com/tevador/RandomX/archive/${RANDOMX_DIST_COMIT}.tar.gz -> ${PF}-monero-randomx.tar.gz
@@ -42,7 +42,6 @@ DEPEND="
dev-libs/libgcrypt:=
dev-libs/libsodium:=
dev-libs/libzip:=
- dev-libs/monero-seed
dev-libs/openssl:=
>=dev-qt/qtcore-5.15:5
>=dev-qt/qtgui-5.15:5
diff --git a/net-p2p/feather/feather-9999.ebuild b/net-p2p/feather/feather-9999.ebuild
index 2897655f1..15e38dd01 100644
--- a/net-p2p/feather/feather-9999.ebuild
+++ b/net-p2p/feather/feather-9999.ebuild
@@ -8,7 +8,7 @@ inherit cmake git-r3
DESCRIPTION="A free, open-source Monero wallet"
HOMEPAGE="https://featherwallet.org"
SRC_URI=""
-EGIT_REPO_URI="https://git.featherwallet.org/feather/feather.git"
+EGIT_REPO_URI="https://github.com/feather-wallet/feather.git"
# Feather is released under the terms of the BSD license, but it vendors
# code from Monero and Tor too.
@@ -22,19 +22,18 @@ DEPEND="
dev-libs/libgcrypt:=
dev-libs/libsodium:=
dev-libs/libzip:=
- dev-libs/monero-seed
dev-libs/openssl:=
- >=dev-qt/qtcore-5.15
- >=dev-qt/qtgui-5.15
- >=dev-qt/qtnetwork-5.15
- >=dev-qt/qtsvg-5.15
- >=dev-qt/qtwebsockets-5.15
- >=dev-qt/qtwidgets-5.15
- >=dev-qt/qtxml-5.15
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtnetwork-5.15:5
+ >=dev-qt/qtsvg-5.15:5
+ >=dev-qt/qtwebsockets-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ >=dev-qt/qtxml-5.15:5
media-gfx/qrencode:=
net-dns/unbound:=[threads]
net-libs/czmq:=
- qrcode? ( media-gfx/zbar:=[v4l] )
+ media-gfx/zbar:=[v4l]
"
RDEPEND="
${DEPEND}
@@ -54,9 +53,11 @@ src_configure() {
-DINSTALL_VENDORED_LIBUNBOUND=OFF
-DMANUAL_SUBMODULES=1
-DSTATIC=OFF
+ -DSELF_CONTAINED=OFF
-DUSE_DEVICE_TREZOR=OFF
-DXMRIG=$(usex xmrig)
-DWITH_SCANNER=$(usex qrcode)
+ -DVERSION_IS_RELEASE=true
)
cmake_src_configure