aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2024-08-05 11:32:13 +0200
committerDavid Roman <davidroman96@gmail.com>2024-08-05 11:32:13 +0200
commitf08c6128d20d0f0d81078c5acdce33ceb0672de9 (patch)
treeb32ba0c3f0218a98079e1adfcc84ca9b34c33bce /net-misc/yt-dlg
parentprofiles: mask media-gfx/libpsautohint for removal (diff)
downloadguru-f08c6128d20d0f0d81078c5acdce33ceb0672de9.tar.gz
guru-f08c6128d20d0f0d81078c5acdce33ceb0672de9.tar.bz2
guru-f08c6128d20d0f0d81078c5acdce33ceb0672de9.zip
net-misc/yt-dlg: add 2024.03.19
Signed-off-by: David Roman <davidroman96@gmail.com>
Diffstat (limited to 'net-misc/yt-dlg')
-rw-r--r--net-misc/yt-dlg/Manifest1
-rw-r--r--net-misc/yt-dlg/yt-dlg-2024.03.19.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/yt-dlg/Manifest b/net-misc/yt-dlg/Manifest
index 9831e9e51..b9d70a9ed 100644
--- a/net-misc/yt-dlg/Manifest
+++ b/net-misc/yt-dlg/Manifest
@@ -1 +1,2 @@
DIST yt-dlg-2023.08.16.gh.tar.gz 1481142 BLAKE2B d64bd9e52531c1c66ef83e18d960dc63200cfd7185af9b14339a5fd852a36966e8cbbd769ecc65e457d52fb0a46f84f84147116a8771d18ea80237d03ec0ab20 SHA512 efc7aaa88b18bc58466fbc0fa62d7b26f857bf759cb7960f3728a351e66d2dc4d13ae8002fce140e03f9e0ff89940686a3753c24796e78777b33928d86fcdedc
+DIST yt-dlg-2024.03.19.gh.tar.gz 1481178 BLAKE2B aca69edf26d906a28fd60c7d2b8c450f74dbbd3c21d8f63866807886e2fe95f71a13039e6d666ffe29d52dfe0db596f5ace9a5a5feea6785affe5c2e1f28a94c SHA512 c151bed0e45398de8080219895a686dadaebdc9b47631eee52861ec5ee35665983ef36f09f11acd44e163acb215d50f1c3cc52094e6ab4f220372e487c412fee
diff --git a/net-misc/yt-dlg/yt-dlg-2024.03.19.ebuild b/net-misc/yt-dlg/yt-dlg-2024.03.19.ebuild
new file mode 100644
index 000000000..40b8d3514
--- /dev/null
+++ b/net-misc/yt-dlg/yt-dlg-2024.03.19.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit desktop distutils-r1 xdg
+
+DESCRIPTION="A cross platform front-end GUI of the popular youtube-dl written in wxPython."
+HOMEPAGE="https://yt-dlg.github.io/yt-dlg/"
+# Using latest commit from Mars 19, 2024 as of August 5, 2024.
+# Latest releases and tags are from 2021 and are probably deprecated and incompatible with current Python versions.
+# Same applies for the dependencies of yt-dlp.
+SHA="264699bb425efd988523ebb8bbfb8f67d009f884"
+SRC_URI="https://github.com/yt-dlg/yt-dlg/archive/${SHA}.tar.gz -> ${P}.gh.tar.gz"
+
+S="${WORKDIR}/${PN}-${SHA}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="ffmpeg"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-python/wxpython-4.2.0:*[${PYTHON_USEDEP}]
+ net-misc/yt-dlp[${PYTHON_USEDEP}]
+ >=dev-python/PyPubSub-4.0.3
+ ffmpeg? ( media-video/ffmpeg )
+"
+RDEPEND="${DEPEND}"
+
+# I don't know how to enable the test phase.
+distutils_enable_tests pytest
+
+DOCS=( README.md )
+
+python_test() {
+ local tests=( ditem dlist parsers utils widgets )
+ local current_test
+ for current_test in tests; do
+ "${EPYTHON}" "tests/test_${curent_test}.py" || die "Tests fail with ${EPYTHON}"
+ done
+}
+
+src_install() {
+ distutils-r1_src_install
+ domenu yt-dlg.desktop
+}