aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>2023-11-27 15:47:07 -0500
committerPhilippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>2023-11-27 15:47:19 -0500
commitac8b8fc448fa017dddfc45e1cc4ce14b8ea2dcfa (patch)
tree8bba5bc7860a881a124a06782fb3cedd458bbe1f /net-mail
parentgames-util/mangohud: add 9999 (diff)
downloadguru-ac8b8fc448fa017dddfc45e1cc4ce14b8ea2dcfa.tar.gz
guru-ac8b8fc448fa017dddfc45e1cc4ce14b8ea2dcfa.tar.bz2
guru-ac8b8fc448fa017dddfc45e1cc4ce14b8ea2dcfa.zip
net-mail/dovecot-fts-xapian: add 1.5.7
Signed-off-by: Philippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/dovecot-fts-xapian/Manifest1
-rw-r--r--net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.5.7.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-mail/dovecot-fts-xapian/Manifest b/net-mail/dovecot-fts-xapian/Manifest
index 28f1b15ec..2478c7c46 100644
--- a/net-mail/dovecot-fts-xapian/Manifest
+++ b/net-mail/dovecot-fts-xapian/Manifest
@@ -1,2 +1,3 @@
DIST dovecot-fts-xapian-1.5.4.tar.gz 33101 BLAKE2B f2bf7c2cee8930cb8791035d434468537decd72f0643b308f437ad634affa555c486ac4524a1b63b7cc06304e77c431f1e846497b6080c07911a82c20c602c8d SHA512 773579959c79142ab3a24ceaa7da7fd68a9c7dde4439bd613112fc02f4b23d4d7fd258563f771dbe06db4000f9be6a219bd88b07f57521ae45246029af58570d
DIST dovecot-fts-xapian-1.5.5.tar.gz 33228 BLAKE2B b8e86b3655a6b7291961cfbd39d6ef93ab2e2fbb049e97ebd07b473eb5fc5ecf91950343adfa9c267791442d581ebea47416d8e674d7f3019091fbd69b6e60f1 SHA512 229362207bfa7bb13b1ded4d8b2a2aef7a4a72306e140dc4bd5778991220b27d296ca3659993856f83c80c437f7feadebad1e3ac06f8120a6e45b69f6dbb1ecb
+DIST dovecot-fts-xapian-1.5.7.tar.gz 33594 BLAKE2B 5d83cf5292ecf7d7245a56d21587302ea8c3bc5b0374c5c77013059fa66e4d187bb26b9c1d928e8ad324d235a79bd97a6878086fc19b493b1aeae1a312bceaf1 SHA512 eb3b7e19ba522dd9e9c2952c3022b15249889c814e8a90b50836526ab5000b26e0e835b71d3a4439f03d5399277b70a3ffeb366ca42061b647ab8ce251268c3b
diff --git a/net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.5.7.ebuild b/net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.5.7.ebuild
new file mode 100644
index 000000000..9e8a22927
--- /dev/null
+++ b/net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.5.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Dovecot FTS plugin backed by Xapian"
+HOMEPAGE="https://github.com/grosjo/fts-xapian"
+SRC_URI="https://github.com/grosjo/fts-xapian/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/fts-xapian-${PV}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="static-libs"
+
+RDEPEND="
+ dev-libs/icu:=
+ >=dev-libs/xapian-1.4:=
+ net-mail/dovecot:=
+ "
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ ${FILESDIR}/bug-887887_allow-O2-override.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Disable hardening so CFLAGS are left up to the Gentoo user
+ # https://bugs.gentoo.org/888751
+ econf \
+ --enable-hardening=no \
+ --with-dovecot="${EPREFIX}/usr/$(get_libdir)/dovecot" \
+ $( use_enable static-libs static )
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}