aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-12-23 15:07:23 +0000
committerAisha Tammy <gentoo@aisha.cc>2021-12-23 15:07:23 +0000
commitffa14bb00c8728959db17bd60ca297189a83250b (patch)
tree43d1358e9a5d5c68bfdddd88a55e3f138749ed29 /net-libs
parentsys-kernel/uek-sources: unbreakable enterprise kernel from oracle (diff)
downloadguru-ffa14bb00c8728959db17bd60ca297189a83250b.tar.gz
guru-ffa14bb00c8728959db17bd60ca297189a83250b.tar.bz2
guru-ffa14bb00c8728959db17bd60ca297189a83250b.zip
net-libs/dpdk: fast userspace networking libraries
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/dpdk/Manifest1
-rw-r--r--net-libs/dpdk/dpdk-21.11.ebuild63
-rw-r--r--net-libs/dpdk/metadata.xml8
3 files changed, 72 insertions, 0 deletions
diff --git a/net-libs/dpdk/Manifest b/net-libs/dpdk/Manifest
new file mode 100644
index 000000000..cf0fb5cc1
--- /dev/null
+++ b/net-libs/dpdk/Manifest
@@ -0,0 +1 @@
+DIST dpdk-21.11.tar.xz 15102516 BLAKE2B e82fb03242b74e458810ee5e0d21feaf5d6d781b81b8dc5c2a2ab977bac202290dadc8734ea13993bb1cb1df4b5c4d770df574052a384b590ac798d19c370c59 SHA512 843282023c2f77a9b8af393d50c6dde54f09d490cd6f4a99f03d4df5df13a7d963aa86885fdf64e13f9da71e01c881d1f301dd093574a32cddd84f4b1fb58fd5
diff --git a/net-libs/dpdk/dpdk-21.11.ebuild b/net-libs/dpdk/dpdk-21.11.ebuild
new file mode 100644
index 000000000..ba9c719e8
--- /dev/null
+++ b/net-libs/dpdk/dpdk-21.11.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit python-single-r1 meson
+
+DESCRIPTION="Data Plane Development Kit libraries for fast userspace networking"
+HOMEPAGE="https://dpdk.org/"
+SRC_URI="https://fast.dpdk.org/rel/${P}.tar.xz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# tests require rte_kni module to be loaded
+# and also needs network and /dev access
+# and need to be run as root
+RESTRICT="test"
+
+DEPEND="${PYTHON_DEPS}
+ ~sys-kernel/rte_kni-kmod-${PV}
+ app-crypt/intel-ipsec-mb
+ dev-libs/elfutils
+ dev-libs/isa-l
+ dev-libs/jansson
+ dev-libs/libbpf
+ dev-libs/libbsd
+ dev-libs/openssl
+ net-libs/libmnl
+ net-libs/libpcap
+ sys-apps/dtc
+ sys-cluster/rdma-core
+ sys-process/numactl
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-lang/nasm
+ test? ( $(python_gen_cond_dep '
+ dev-python/pyelftools[${PYTHON_USEDEP}]
+ ') )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Denable_kmods=false
+ -Dmachine=default
+ -Dplatform=generic
+ $(meson_use test tests)
+ )
+ meson_src_configure
+ python_setup
+}
+
+src_install() {
+ meson_src_install
+ local pyfiles=( "${ED}/usr/bin/*.py" )
+ for pyfile in "${pyfiles[@]}"; do
+ python_fix_shebang "${pyfile}"
+ done
+}
diff --git a/net-libs/dpdk/metadata.xml b/net-libs/dpdk/metadata.xml
new file mode 100644
index 000000000..65ac1f205
--- /dev/null
+++ b/net-libs/dpdk/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+</pkgmetadata>