aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJoe Kappus <joe@wt.gd>2024-06-08 03:47:26 -0400
committerJoe Kappus <joe@wt.gd>2024-06-08 03:47:26 -0400
commite277f5c131adecac1beee7c08110a959ab62b32a (patch)
tree8e7807e970abb98b32145de6a7e47022019b7c67 /net-im
parentnet-nntp/pan: drop 0.157 (diff)
downloadguru-e277f5c131adecac1beee7c08110a959ab62b32a.tar.gz
guru-e277f5c131adecac1beee7c08110a959ab62b32a.tar.bz2
guru-e277f5c131adecac1beee7c08110a959ab62b32a.zip
net-im/mautrix-whatsapp: add 0.10.7, remove pypi upstream, add RDEPEND
I think chuso meant to bump this and must have forgot, the deps were on their server. Closes: https://bugs.gentoo.org/932869 Signed-off-by: Joe Kappus <joe@wt.gd>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/mautrix-whatsapp/Manifest2
-rw-r--r--net-im/mautrix-whatsapp/mautrix-whatsapp-0.10.0.ebuild7
-rw-r--r--net-im/mautrix-whatsapp/mautrix-whatsapp-0.10.7.ebuild63
-rw-r--r--net-im/mautrix-whatsapp/metadata.xml1
4 files changed, 70 insertions, 3 deletions
diff --git a/net-im/mautrix-whatsapp/Manifest b/net-im/mautrix-whatsapp/Manifest
index 23a567620..f8f165f94 100644
--- a/net-im/mautrix-whatsapp/Manifest
+++ b/net-im/mautrix-whatsapp/Manifest
@@ -1,2 +1,4 @@
DIST mautrix-whatsapp-0.10.0-deps.tar.xz 44605336 BLAKE2B 631844436ca1fb408a1dbd074d613f5b21c789bc7af931336204c4c104a0e7f039ddddc7c94c651211e12253bcf63b72a899f4b2bb554eed6f778a1e747dd762 SHA512 fb06e5d121c2e1d2ed67ca21973a37187d0f79d5cc1206bc8aa7a031503967932254e430db00ee95645770eea7509f0ec9ab24fa3fe6a26bb5fb28149873a584
DIST mautrix-whatsapp-0.10.0.gh.tar.gz 152560 BLAKE2B b455c54fec79c0d56b61d441291a3f5ae1ab55db3f23e69d2fd5c11cc0bcbd69d5d8f14cd44c6a252d1f72c37af0d67ac959cc3a9163fe772d3d530d4f5f2af0 SHA512 0906b1e01f26d25adf337a012e73fa28bf9961a30add61ae7a22aaf903ce28d50e00c34124ed6703c9be86a38c3e29d638c2fa969013608ee38034cc01b5882f
+DIST mautrix-whatsapp-0.10.7-deps.tar.xz 42991792 BLAKE2B 73265c85603bf913405df0ed010e30faa308e834d1017b144c6052c0346b116e4543e50589427876a4d42f4286fa15450f2553afd0dbb6277d118547af378978 SHA512 f2ab8e41fb942e2a17ff9d9859b6c5d8b247f9fb0bd3bbefcb42abf3e37c496f61dabdbd06139ddc9cbaf1e3d75bf294d26693759dcad86f6fb6859c637ba67e
+DIST mautrix-whatsapp-0.10.7.gh.tar.gz 159078 BLAKE2B 9e85517e95da8ee4011aaffd51be6440a36dad2b742addce8445781555756df3ba2bb540ce3c2b9e613371eca4e7e021ae08273e39a41e57b54ca0430219bed1 SHA512 b0d3d572bbd29e5b4391662fd3fa1e6849d9f51a094257072883ec2797972defbfc3e22ab6fa0354b634045974bbe8a6d090699330c3ace1021f944757a766f3
diff --git a/net-im/mautrix-whatsapp/mautrix-whatsapp-0.10.0.ebuild b/net-im/mautrix-whatsapp/mautrix-whatsapp-0.10.0.ebuild
index 7dd38106f..1871f9e0f 100644
--- a/net-im/mautrix-whatsapp/mautrix-whatsapp-0.10.0.ebuild
+++ b/net-im/mautrix-whatsapp/mautrix-whatsapp-0.10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,7 +18,10 @@ IUSE="crypt"
DEPEND="crypt? ( dev-libs/olm )"
-RDEPEND="acct-user/${PN}"
+RDEPEND="
+ ${DEPEND}
+ acct-user/${PN}
+"
src_compile() {
ego build $(use crypt || echo '-tags nocrypto')
diff --git a/net-im/mautrix-whatsapp/mautrix-whatsapp-0.10.7.ebuild b/net-im/mautrix-whatsapp/mautrix-whatsapp-0.10.7.ebuild
new file mode 100644
index 000000000..777debbc3
--- /dev/null
+++ b/net-im/mautrix-whatsapp/mautrix-whatsapp-0.10.7.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module optfeature systemd
+
+DESCRIPTION="A Matrix-WhatsApp puppeting bridge "
+HOMEPAGE="https://github.com/mautrix/whatsapp/"
+SRC_URI="https://github.com/mautrix/whatsapp/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
+ https://distfiles.chuso.net/distfiles/${P}-deps.tar.xz"
+S="${WORKDIR}/whatsapp-${PV}"
+
+LICENSE="AGPL-3 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="crypt"
+
+DEPEND="crypt? ( dev-libs/olm )"
+
+RDEPEND="
+ ${DEPEND}
+ acct-user/${PN}
+"
+
+src_compile() {
+ ego build $(use crypt || echo '-tags nocrypto')
+}
+
+src_install() {
+ dobin "${PN}"
+
+ keepdir /var/log/mautrix/${PN/mautrix-/}
+ fowners -R root:mautrix /var/log/mautrix
+ fperms -R 770 /var/log/mautrix
+ sed -i -e "s_\./logs_/var/log/mautrix_" "example-config.yaml" || die
+
+ insinto "/etc/mautrix"
+ newins "example-config.yaml" "${PN/-/_}.yaml"
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ fowners -R root:mautrix /etc/mautrix
+ fperms -R 770 /etc/mautrix
+}
+
+pkg_postinst() {
+ optfeature "sending GIFs" media-video/ffmpeg
+
+ elog "Before you can use ${PN}, you must configure it correctly"
+ elog "The configuration file is located at \"/etc/mautrix/${PN/-/_}.yaml\""
+ elog "When done, run the following command: emerge --config ${CATEGORY}/${PN}"
+ elog "Then, you must register the bridge with your homeserver"
+ elog "Refer your homeserver's documentation for instructions"
+ elog "The registration file is located at /var/lib/${PN/-/\/}/registration.yaml"
+ elog "Finally, you may start the ${PN} daemon"
+}
+
+pkg_config() {
+ su - "${PN}" -s /bin/sh -c \
+ "/usr/bin/${PN} -c /etc/mautrix/${PN/-/_}.yaml -g -r /var/lib/${PN/-/\/}/registration.yaml"
+}
diff --git a/net-im/mautrix-whatsapp/metadata.xml b/net-im/mautrix-whatsapp/metadata.xml
index fc68fa52f..a31a577ec 100644
--- a/net-im/mautrix-whatsapp/metadata.xml
+++ b/net-im/mautrix-whatsapp/metadata.xml
@@ -17,6 +17,5 @@
<doc>https://docs.mau.fi/bridges/go/whatsapp/index.html</doc>
<bugs-to>https://github.com/mautrix/whatsapp/issues</bugs-to>
<remote-id type="github">mautrix/whatsapp</remote-id>
- <remote-id type="pypi">mautrix-whatsapp</remote-id>
</upstream>
</pkgmetadata>