aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-02-06 20:07:25 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-02-06 20:13:30 +0500
commitde49c63f6cacf09c7cc7d4b1c3687aaa672082d1 (patch)
tree80acb15a2e3dfcd56c6e2c4adb594ea70039975c /net-im
parentnet-im/nheko: don't require ssl support for cpp-httplib (diff)
downloadguru-de49c63f6cacf09c7cc7d4b1c3687aaa672082d1.tar.gz
guru-de49c63f6cacf09c7cc7d4b1c3687aaa672082d1.tar.bz2
guru-de49c63f6cacf09c7cc7d4b1c3687aaa672082d1.zip
net-im/nheko: drop 0.11.3
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/nheko/Manifest1
-rw-r--r--net-im/nheko/nheko-0.11.3.ebuild100
2 files changed, 0 insertions, 101 deletions
diff --git a/net-im/nheko/Manifest b/net-im/nheko/Manifest
index 211658a5f..17bbfb1b5 100644
--- a/net-im/nheko/Manifest
+++ b/net-im/nheko/Manifest
@@ -1,2 +1 @@
-DIST nheko-0.11.3.tar.gz 1780179 BLAKE2B 095314ea420bd78cff71fe9e8bd48c1319248fa5c31bfc3741aa72cfa7585660f74f7eb3b9848b53ccfbc979283db8ca2e52e8e4f2749280ee1c867a35baf075 SHA512 bd5b94def3c56bb2c91c40c3ef967ee3b14cb71a7e5b01028743a849932c918620c2b1a1b822705e49dacc80dae6c48712f63bf9a68698858b0faaf1a816c9cd
DIST nheko-v0.11.3.tar.bz2 1222761 BLAKE2B 218246824512b13fc3448142e5e127b207952e3f66c2b308ca281d7f9e6b0198760d9408b467bf9442a0df306d2b23ffc5034cba5c675299aac85ac4ebe23280 SHA512 bd051144a16cd628d6259a7ce4acf10fd7b7ef3d8b0036cbf1f2a80c550062a04062a61c66e7a060f853d53c1eaa50fadb0223641e98283001aabf037c0e4de1
diff --git a/net-im/nheko/nheko-0.11.3.ebuild b/net-im/nheko/nheko-0.11.3.ebuild
deleted file mode 100644
index 66b6ef0e2..000000000
--- a/net-im/nheko/nheko-0.11.3.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake optfeature xdg
-
-DESCRIPTION="Native desktop client for Matrix using Qt"
-HOMEPAGE="https://github.com/Nheko-Reborn/nheko"
-SRC_URI="https://github.com/Nheko-Reborn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="X +pie video voip"
-REQUIRED_USE="video? ( voip )"
-
-MY_GST_V="1.18"
-RDEPEND="
- app-text/cmark:=
- >=dev-cpp/blurhash-0.2.0:=
- dev-cpp/cpp-httplib:=
- dev-cpp/qt-jdenticon
- dev-db/lmdb:=
- >=dev-db/lmdb++-1.0.0
- dev-libs/libfmt:=
- >=dev-libs/mtxclient-0.9.0:=
- >=dev-libs/qtkeychain-0.12.0:=
- >=dev-libs/re2-0.2022.04.01:=
- dev-libs/spdlog:=
- dev-qt/qtconcurrent:5
- dev-qt/qtdeclarative:5[widgets]
- dev-qt/qtgraphicaleffects:5
- dev-qt/qtgui:5[dbus,jpeg,png]
- dev-qt/qtimageformats:5
- dev-qt/qtmultimedia:5[gstreamer,qml,widgets]
- dev-qt/qtquickcontrols2:5[widgets]
- dev-qt/qtsvg:5
- virtual/notification-daemon
- voip? (
- >=media-plugins/gst-plugins-dtls-${MY_GST_V}
- media-plugins/gst-plugins-libnice
- >=media-plugins/gst-plugins-meta-${MY_GST_V}[opus]
- >=media-plugins/gst-plugins-srtp-${MY_GST_V}
- >=media-plugins/gst-plugins-webrtc-${MY_GST_V}
- video? (
- >=media-libs/gst-plugins-base-${MY_GST_V}[opengl]
- >=media-plugins/gst-plugins-meta-${MY_GST_V}[v4l,vpx]
- >=media-plugins/gst-plugins-qt5-${MY_GST_V}
- X? (
- >=media-plugins/gst-plugins-ximagesrc-${MY_GST_V}
- x11-libs/libxcb:=
- x11-libs/xcb-util-wm
- )
- )
- )
-"
-DEPEND="
- dev-cpp/nlohmann_json
- ${RDEPEND}
-"
-BDEPEND="
- dev-qt/linguist-tools:5
- || (
- app-text/asciidoc
- dev-ruby/asciidoctor
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-fix-explicit-optional-construction.patch
- "${FILESDIR}"/${P}-fix-build-against-fmt10.patch
-)
-
-src_configure() {
- local -a mycmakeargs=(
- -DVOIP=$(usex voip)
- -DCMAKE_POSITION_INDEPENDENT_CODE=$(usex pie)
- -DUSE_BUNDLED_CPPHTTPLIB=no
- -DUSE_BUNDLED_BLURHASH=no
- )
- if use video && use X; then
- mycmakeargs+=(-DSCREENSHARE_X11=yes)
- else
- mycmakeargs+=(-DSCREENSHARE_X11=no)
- fi
-
- cmake_src_configure
-}
-
-pkg_postinst() {
- optfeature "audio & video file playback support" \
- "media-plugins/gst-plugins-meta[ffmpeg]"
- optfeature "secrets storage support other than kwallet (for example gnome-keyring or keepassxc)" \
- "dev-libs/qtkeychain[keyring]"
- optfeature "additional, less common, image format support" \
- "kde-frameworks/kimageformats"
-
- xdg_pkg_postinst
-}