aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-05-21 17:17:55 -0400
committerJulien Roy <julien@jroy.ca>2024-05-21 17:29:22 -0400
commit40aabc10c82c647cef686837f481f0b34d3ac512 (patch)
treebf311dee394fdc76852e97e8a3e221dc9f2db87a /net-im
parentsys-kernel/ugrd: removed empty KEYWORDS (diff)
downloadguru-40aabc10c82c647cef686837f481f0b34d3ac512.tar.gz
guru-40aabc10c82c647cef686837f481f0b34d3ac512.tar.bz2
guru-40aabc10c82c647cef686837f481f0b34d3ac512.zip
net-im/mautrix-meta: add 0.3.1
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/mautrix-meta/Manifest2
-rw-r--r--net-im/mautrix-meta/mautrix-meta-0.3.1.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/net-im/mautrix-meta/Manifest b/net-im/mautrix-meta/Manifest
index e1e440c83..a3bda6a2d 100644
--- a/net-im/mautrix-meta/Manifest
+++ b/net-im/mautrix-meta/Manifest
@@ -2,3 +2,5 @@ DIST mautrix-meta-0.2.0.gh.tar.gz 198829 BLAKE2B 0dd9f02d5518d8fa3839c3df9388618
DIST mautrix-meta-0.2.0.tar.xz 28251872 BLAKE2B bca146d5da3093742fa8a6cb218251c75ba213c1dac48a9a8535971a38baf43c854f90882f40b0797029785bb40785d305d48feeab7cea6d985dfbf86614f00b SHA512 a5c267b49127ddc0052e2f823ed784951d5347567f31ec284516c8abab72a2f209069cfd378385075f86fd87416608d7d9dccb80247d7a44f46f4a037cc74b7e
DIST mautrix-meta-0.3.0-deps.tar.xz 32145360 BLAKE2B 0c3c5a987d602067b9431637589d4d448580a3ce21d179f051c9ad45acb24f1f54d9e12d096f7223f3591b6335bc8e103302eb647f34b9cd98e7d5c225aa9c6e SHA512 cb6048c33b19fcfeb0dad78510a44bea3b907726b20e62280f66339f9d57168b259fb1f075a49d27d9e973683b0cb737d8a5439d56d336304be104e24be809a0
DIST mautrix-meta-0.3.0.gh.tar.gz 202451 BLAKE2B cf3a7cd2bd27d8a497c42fd960993d1df7714500abc67b9e30d2853e71070262238272ddbec513f056560a57e3e6028183b90a862139bbb6407028c482c2569b SHA512 099c105ad8834f585215d0d9e3db16c1fe6d6064fe480b944e895527e44c069623f7667db8e84f90004df72dd49bdd1e1359b46e7987814e7c41a0b344ec3a67
+DIST mautrix-meta-0.3.1-deps.tar.xz 28436296 BLAKE2B 044812d4dfc89fd7d13e38595de1322b14dcbca0ae907c4a6a463047f1ed22e83fa0b825857c3eb134b22f49e7c308749bbf60bbf9725a64ae8b1952b08f7482 SHA512 2f753f1e02a9d6225f7370b3d30c06a91127a2e4d4c4e12032a27e9f0136d7590a52a281369d42b1d7b76f6a5b5c2cffbfbe1ea2a96e1c1eb6f145dcbb483fdb
+DIST mautrix-meta-0.3.1.gh.tar.gz 203444 BLAKE2B 294171599408b3f5f40a244d952b7f06678f52c015bb94ce2d4dad0568642fac399467bd86b81036c200b47a74a389614bd41b74e560d92e4de2b77ca58acd5a SHA512 e0141b9adc9361236d24c94a66fdbbfcd10789f7a8f7d7a582f709c2e716eb72b7d4564c5dc58e2a5c82b37709ad2eb3a45e782aca8d74a430d2a15c0ee6db32
diff --git a/net-im/mautrix-meta/mautrix-meta-0.3.1.ebuild b/net-im/mautrix-meta/mautrix-meta-0.3.1.ebuild
new file mode 100644
index 000000000..3eae17ffe
--- /dev/null
+++ b/net-im/mautrix-meta/mautrix-meta-0.3.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd
+
+DESCRIPTION="A Matrix-Facebook puppeting bridge"
+HOMEPAGE="https://github.com/mautrix/meta"
+SRC_URI="https://github.com/mautrix/meta/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
+ https://jroy.ca/dist/${P}-deps.tar.xz
+"
+S="${WORKDIR}/meta-${PV}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ acct-user/${PN}
+ dev-libs/olm
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ ego build
+}
+
+src_install() {
+ dobin mautrix-meta
+
+ keepdir /var/log/mautrix/meta
+ fowners -R root:mautrix /var/log/mautrix
+ fperms -R 770 /var/log/mautrix
+ sed -i -e "s/\.\/logs/\/var\/log\/${PN/-/\\\/}/" "example-config.yaml" || die
+
+ insinto "/etc/mautrix"
+ newins "example-config.yaml" "${PN/-/_}.yaml"
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ fowners -R root:mautrix /etc/mautrix
+ fperms -R 770 /etc/mautrix
+}
+
+pkg_postinst() {
+ einfo
+ elog ""
+ elog "Before you can use ${PN}, you must configure it correctly"
+ elog "The configuration file is located at \"/etc/mautrix/${PN/-/_}.yaml\""
+ elog "When done, run the following command: emerge --config ${CATEGORY}/${PN}"
+ elog "Then, you must register the bridge with your homeserver"
+ elog "Refer your homeserver's documentation for instructions"
+ elog "The registration file is located at /var/lib/${PN/-/\/}/registration.yaml"
+ elog "Finally, you may start the ${PN} daemon"
+ einfo
+}
+
+pkg_config() {
+ su - "${PN}" -s /bin/sh -c \
+ "/usr/bin/${PN} -c /etc/mautrix/${PN/-/_}.yaml -g -r /var/lib/${PN/-/\/}/registration.yaml"
+}