aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAdrian Schollmeyer <nex+b-g-o@nexadn.de>2021-12-13 22:22:31 +0100
committerAdrian Schollmeyer <nex+b-g-o@nexadn.de>2021-12-13 22:22:43 +0100
commit35c33c691e9b9811f26e3425d55ceff3036eb3a3 (patch)
treeee4c1c3f78c9cd2cfec8ed6a5373eb3815192c3a /net-im
parentdev-libs/olm: Remove old ebuilds (diff)
downloadguru-35c33c691e9b9811f26e3425d55ceff3036eb3a3.tar.gz
guru-35c33c691e9b9811f26e3425d55ceff3036eb3a3.tar.bz2
guru-35c33c691e9b9811f26e3425d55ceff3036eb3a3.zip
net-im/abaddon: Add live ebuild (-9999)
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Adrian Schollmeyer <nex+b-g-o@nexadn.de>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/abaddon/abaddon-9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-im/abaddon/abaddon-9999.ebuild b/net-im/abaddon/abaddon-9999.ebuild
new file mode 100644
index 000000000..9a4a04789
--- /dev/null
+++ b/net-im/abaddon/abaddon-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop git-r3
+
+DESCRIPTION="Alternative Discord client using GTK instead of Electron"
+HOMEPAGE="https://github.com/uowuo/abaddon"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/uowuo/abaddon.git"
+# Submodules shouldn't be used since all dependencies are provided by
+# portage
+EGIT_SUBMODULES=()
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ dev-cpp/gtkmm:3.0=
+ dev-db/sqlite:3
+ net-misc/curl
+ >=net-libs/ixwebsocket-11.0.8
+ sys-libs/zlib:=
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/nlohmann_json
+"
+BDEPEND=""
+
+src_install() {
+ dodoc README.md
+
+ dobin "${BUILD_DIR}"/abaddon
+
+ insinto /usr/share/${PN}
+ doins -r res/*
+
+ make_desktop_entry /usr/bin/${PN}
+}