aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2024-05-09 10:44:17 +0200
committerKurt Kanzenbach <kurt@kmk-computers.de>2024-05-09 10:44:17 +0200
commita83c7dd6fb91083f5e4c93811c01135f78c59304 (patch)
tree44c8fc8f6620b49afd8714fde5c74580664eb1f1 /net-dialup
parentsys-process/xe: new package, add 1.0 (diff)
downloadguru-a83c7dd6fb91083f5e4c93811c01135f78c59304.tar.gz
guru-a83c7dd6fb91083f5e4c93811c01135f78c59304.tar.bz2
guru-a83c7dd6fb91083f5e4c93811c01135f78c59304.zip
net-dialup/tio: add 3.2
Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/tio/Manifest1
-rw-r--r--net-dialup/tio/tio-3.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/net-dialup/tio/Manifest b/net-dialup/tio/Manifest
index 1e1963527..3becab1e4 100644
--- a/net-dialup/tio/Manifest
+++ b/net-dialup/tio/Manifest
@@ -1 +1,2 @@
DIST tio-2.8.tar.xz 3441388 BLAKE2B 934d10f9f91926fae78d4d4c41ddc3ed60e148fea4da81763f052835a993fbf2ebdc4b5d666d9b34ad44f33a8f3c3edd45e14589995dfc0de03254104acb4107 SHA512 b9bac84eb84147a964a504c56dd5aa1ffe706dafc8a7ced4e42a7bb9e1ef262e7f4f015879e5a20b7bfbb1dfe9474bd4ad920b677750b812996b412d05d76272
+DIST tio-3.2.tar.xz 3452984 BLAKE2B 32abe46a8d010ed18b3eec7426788d07c73e7d87d1d3d6fb5bfc08b15cbdc4acaf5e49123d7b9fc1e6559bdae0e21fb20ceb945b97046508349d63423b02b9ba SHA512 37ee36a52b0a41bd8e8fdc0329036fdaedd3130d2e19a92c8f14d86fd2193a5ed1354893c3a8f05e102db5fcb496993fb1700303fd0d2820b9e519abb33976cf
diff --git a/net-dialup/tio/tio-3.2.ebuild b/net-dialup/tio/tio-3.2.ebuild
new file mode 100644
index 000000000..329bb2790
--- /dev/null
+++ b/net-dialup/tio/tio-3.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} )
+
+inherit lua-single meson bash-completion-r1
+
+DESCRIPTION="Simple TTY terminal application"
+HOMEPAGE="https://tio.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RDEPEND="
+ ${LUA_DEPS}
+ dev-libs/glib
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbashcompletiondir="$(get_bashcompdir)"
+ )
+
+ meson_src_configure
+}