aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2022-06-17 17:31:18 +0200
committerOliver Freyermuth <o.freyermuth@googlemail.com>2022-06-17 17:40:20 +0200
commitb76209822cdf5f4755ec0f0f38f30f9da955b9e9 (patch)
tree035203d52b172a6f1cd76405a032f07b0559457e /mpv-plugin
parentmpv-plugin/mpv-mpris: add 0.8 (diff)
downloadguru-b76209822cdf5f4755ec0f0f38f30f9da955b9e9.tar.gz
guru-b76209822cdf5f4755ec0f0f38f30f9da955b9e9.tar.bz2
guru-b76209822cdf5f4755ec0f0f38f30f9da955b9e9.zip
mpv-plugin/mpv-mpris: drop 0.7, 0.7.1
Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com>
Diffstat (limited to 'mpv-plugin')
-rw-r--r--mpv-plugin/mpv-mpris/Manifest1
-rw-r--r--mpv-plugin/mpv-mpris/mpv-mpris-0.7.1.ebuild70
-rw-r--r--mpv-plugin/mpv-mpris/mpv-mpris-0.7.ebuild71
3 files changed, 0 insertions, 142 deletions
diff --git a/mpv-plugin/mpv-mpris/Manifest b/mpv-plugin/mpv-mpris/Manifest
index 24eb33b97..bb19e16db 100644
--- a/mpv-plugin/mpv-mpris/Manifest
+++ b/mpv-plugin/mpv-mpris/Manifest
@@ -1,3 +1,2 @@
DIST mpv-mpris-0.7.1.tar.gz 13432 BLAKE2B 884204c2186bc3b52378113dde87e58578b3811ec1a40576eb30e779fe3a3575ad9db802a51434e9fc3d22785db6036f898c76acab61780fac4b35276a17524f SHA512 7e928bbbf85b5c8e1e92ce51e65986ef7a7fe27a1e382b0148cdd70e22e5320be37a573c6206b3a1ab05119d9d24b861fd45081a008111f1da37673aa3896f23
-DIST mpv-mpris-0.7.tar.gz 12982 BLAKE2B db919cdad6528519211725694f63871e371a33a331c46eebb202fa87d452d1cf30cecf3d4c2b26cb187cfa2c4cdd53411b88e6e7855510ffbaeef28ab3eb8346 SHA512 b370c9550622302cfdd07c21ae2f03a4e66e80da02e8f38c68d447ef273ae582ad6d918e207a9fb8c917a851163c6aadc08d3d68ad8e70ec85b37732c0cac96f
DIST mpv-mpris-0.8.tar.gz 13477 BLAKE2B 57ac9e0604bfcb979595f42a9bede20cb4e27c07e768cade3a996bbcb7226cf01704cfc52448a5eb363e1aba1e0b48e90edfcc858a7913649c740c0fa82c5ed1 SHA512 97387caa98296bbcb71c847ada45f8baac8cfb9536554d38accd706800d9b867ac0012d330e9b548926184fff9e4952ff90b22a3e7d42c68ac74fbd6d61c3006
diff --git a/mpv-plugin/mpv-mpris/mpv-mpris-0.7.1.ebuild b/mpv-plugin/mpv-mpris/mpv-mpris-0.7.1.ebuild
deleted file mode 100644
index 2b4e36729..000000000
--- a/mpv-plugin/mpv-mpris/mpv-mpris-0.7.1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-DESCRIPTION="MPRIS plugin for mpv"
-HOMEPAGE="https://github.com/hoyon/mpv-mpris"
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/hoyon/${PN}.git"
-else
- SRC_URI="https://github.com/hoyon/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-fi
-
-SLOT="0"
-LICENSE="MIT"
-IUSE="+autoload test"
-
-RDEPEND="
- dev-libs/glib:2
- media-video/mpv:=[cplugins,libmpv]
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig
- test? (
- app-misc/jq
- app-shells/bash
- app-text/jo
- media-sound/playerctl
- net-misc/socat
- sys-apps/dbus
- virtual/awk
- x11-apps/xauth
- x11-misc/xvfb-run
- x11-themes/sound-theme-freedesktop
- )
-"
-RESTRICT="!test? ( test )"
-
-src_compile() {
- tc-export CC
- emake PKG_CONFIG="$(tc-getPKG_CONFIG)"
-}
-
-src_test() {
- emake test
-}
-
-src_install() {
- newlib.so mpris.so ${PN}.so
- use autoload && dosym -r /usr/$(get_libdir)/${PN}.so /etc/mpv/scripts/mpris.so
- einstalldocs
-}
-
-pkg_postinst() {
- if ! use autoload; then
- elog
- elog "The plugin has not been installed to /etc/mpv/scripts for autoloading."
- elog "You have to activate it manually by passing"
- elog " '${EPREFIX}/usr/$(get_libdir)/${PN}.so'"
- elog "as a script option to mpv or symlinking the library to 'scripts' in your mpv"
- elog "config directory."
- elog "Alternatively, activate the autoload use flag."
- elog
- fi
-}
diff --git a/mpv-plugin/mpv-mpris/mpv-mpris-0.7.ebuild b/mpv-plugin/mpv-mpris/mpv-mpris-0.7.ebuild
deleted file mode 100644
index 8814420b5..000000000
--- a/mpv-plugin/mpv-mpris/mpv-mpris-0.7.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-DESCRIPTION="MPRIS plugin for mpv"
-HOMEPAGE="https://github.com/hoyon/mpv-mpris"
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/hoyon/${PN}.git"
-else
- SRC_URI="https://github.com/hoyon/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-fi
-
-SLOT="0"
-LICENSE="MIT"
-IUSE="+autoload test"
-
-RDEPEND="
- dev-libs/glib:2
- media-video/mpv:=[cplugins,libmpv]
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig
- test? (
- app-misc/jq
- app-shells/bash
- app-text/jo
- media-sound/playerctl
- net-misc/socat
- sys-apps/dbus
- virtual/awk
- x11-apps/xauth
- x11-misc/xvfb-run
- x11-themes/sound-theme-freedesktop
- )
-"
-RESTRICT="!test? ( test )"
-
-src_compile() {
- tc-export CC
- emake PKG_CONFIG="$(tc-getPKG_CONFIG)"
-}
-
-src_test() {
- emake test
-}
-
-src_install() {
- insinto "/usr/$(get_libdir)/mpv"
- doins mpris.so
- use autoload && dosym -r /usr/$(get_libdir)/mpv/mpris.so /etc/mpv/scripts/mpris.so
- einstalldocs
-}
-
-pkg_postinst() {
- if ! use autoload; then
- elog
- elog "The plugin has not been installed to /etc/mpv/scripts for autoloading."
- elog "You have to activate it manually by passing"
- elog " '${EPREFIX}/usr/$(get_libdir)/mpv/mpris.so' "
- elog "as a script option to mpv or symlinking the library to 'scripts' in your mpv"
- elog "config directory."
- elog "Alternatively, activate the autoload use flag."
- elog
- fi
-}