aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Smaniotto <smaniotto.nicola@gmail.com>2022-07-13 23:25:06 +0200
committerNicola Smaniotto <smaniotto.nicola@gmail.com>2022-07-13 23:33:06 +0200
commit455f3d8b4103de3906d2bebc9b2813bcf4acdda4 (patch)
tree97ebbc86e20dce47162d3e32995f6e6b68c19075 /media-video
parentmedia-video/syncplay: add myself as a maintainer (diff)
downloadguru-455f3d8b4103de3906d2bebc9b2813bcf4acdda4.tar.gz
guru-455f3d8b4103de3906d2bebc9b2813bcf4acdda4.tar.bz2
guru-455f3d8b4103de3906d2bebc9b2813bcf4acdda4.zip
media-video/syncplay: add 1.6.9
This new version drops support for PyQt5, depending instead only on PySide2 as does upstream. The patches for PyQt5 are still available for 1.6.7-r1, and I may reintroduce them in the future. Signed-off-by: Nicola Smaniotto <smaniotto.nicola@gmail.com>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/syncplay/Manifest1
-rw-r--r--media-video/syncplay/syncplay-1.6.9.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/media-video/syncplay/Manifest b/media-video/syncplay/Manifest
index 77603bf87..344ca6451 100644
--- a/media-video/syncplay/Manifest
+++ b/media-video/syncplay/Manifest
@@ -1 +1,2 @@
DIST syncplay-1.6.7.tar.gz 1898354 BLAKE2B bc33ad13d5cc455a593979ca08c3a0d8cb64a44610d5d245920c9978859624fa655cdd953361e82dc3505dd785c6a06bc17641bea0e78d5fdf922975fe813b48 SHA512 9b4757befd56569b9061493227931df99ac59ffee91f14c5d0ae932b1744ab7314d4ba4082323781294a70adecdf68a01e1511fbbb1aa9becff0f6c20945ad90
+DIST syncplay-1.6.9.tar.gz 1900259 BLAKE2B d535f5057a790ac860e6d0ac376069565fa02076dbc0c1d9eb7f54f87f96bbf7aef85136c8c5b67f1a5cf64a5204a617db26e6931368ba490a3ea9128282e473 SHA512 317e7cc966182259e552898ae05e620caf0f8e0ae0b6917235c391bcae1ef9679f1e97cfb46f6d8c6edcd9a5c573e5ab4ff5e27b5e203980a99ade065d9a6b65
diff --git a/media-video/syncplay/syncplay-1.6.9.ebuild b/media-video/syncplay/syncplay-1.6.9.ebuild
new file mode 100644
index 000000000..889f7ce1b
--- /dev/null
+++ b/media-video/syncplay/syncplay-1.6.9.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_SINGLE_IMPL=1
+
+inherit desktop distutils-r1 optfeature xdg
+
+DESCRIPTION="Client/server to synchronize media playback"
+HOMEPAGE="https://github.com/Syncplay/syncplay https://syncplay.pl"
+SRC_URI="https://github.com/${PN^}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="+client server"
+REQUIRED_USE="|| ( client server )"
+
+RDEPEND="
+ $( python_gen_cond_dep \
+ '>=dev-python/certifi-2018.11.29[${PYTHON_USEDEP}]
+ >=dev-python/twisted-16.4.0[${PYTHON_USEDEP},ssl]'
+ )
+ client? (
+ $( python_gen_cond_dep \
+ 'dev-python/QtPy[${PYTHON_USEDEP},gui,pyside2]'
+ )
+ || (
+ media-video/vlc[lua]
+ media-video/mpv[lua]
+ media-video/mplayer
+ )
+ )
+"
+
+python_install() {
+ python_domodule syncplay
+ for size in 256 128 96 64 48 32 24 16; do
+ doicon -s ${size} "${PN}/resources/hicolor/${size}x${size}/apps/syncplay.png"
+ done
+ if use client; then
+ python_newscript syncplayClient.py syncplay
+ domenu syncplay/resources/syncplay.desktop
+ fi
+ if use server; then
+ python_newscript syncplayServer.py syncplay-server
+ domenu syncplay/resources/syncplay-server.desktop
+ newinitd "${FILESDIR}/${PN}-server-init" "${PN}"
+ newconfd "${FILESDIR}/${PN}-server-init-conf" "${PN}"
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if use client; then
+ optfeature_header "Syncplay is compatible with the following players, install:"
+ optfeature "VLC support" media-video/vlc[lua]
+ optfeature "MPV support" media-video/mpv[lua]
+ optfeature "MPlayer support" media-video/mplayer
+ fi
+}