aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucio Sauer <watermanpaint@posteo.net>2024-02-25 10:35:04 +0100
committerLucio Sauer <watermanpaint@posteo.net>2024-02-25 10:35:04 +0100
commitfefd0fc087daf8e6a4d27b423f3ee16b98e5ee50 (patch)
tree228c65ddf3640146154bc2e4077ba087f989264d /media-libs
parentmedia-libs/dr_mp3: use the edo eclass (diff)
downloadguru-fefd0fc087daf8e6a4d27b423f3ee16b98e5ee50.tar.gz
guru-fefd0fc087daf8e6a4d27b423f3ee16b98e5ee50.tar.bz2
guru-fefd0fc087daf8e6a4d27b423f3ee16b98e5ee50.zip
media-libs/dr_flac: use the edo eclass
Signed-off-by: Lucio Sauer <watermanpaint@posteo.net>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/dr_flac/dr_flac-0.12.42.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/media-libs/dr_flac/dr_flac-0.12.42.ebuild b/media-libs/dr_flac/dr_flac-0.12.42.ebuild
index b69060087..830a44411 100644
--- a/media-libs/dr_flac/dr_flac-0.12.42.ebuild
+++ b/media-libs/dr_flac/dr_flac-0.12.42.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs
+inherit edo toolchain-funcs
DESCRIPTION="Single-header FLAC audio decoder library"
HOMEPAGE="https://github.com/mackron/dr_libs/"
@@ -60,7 +60,6 @@ src_compile() {
pushd tests > /dev/null || die
for tcase in ${TESTCASES[@]}; do
- einfo "Compiling test case ${tcase}."
case ${tcase} in
*.cpp)
MY_C=${MY_CXX}
@@ -84,7 +83,7 @@ src_compile() {
*)
;;
esac
- ${MY_BUILD} || die "Build failed: ${MY_BUILD}"
+ edo ${MY_BUILD}
done
popd || die
fi
@@ -93,8 +92,7 @@ src_compile() {
src_test() {
pushd tests > /dev/null || die
for tcase in ${TESTCASES[@]}; do
- einfo "Running test case ${tcase}."
- ./bin/${tcase} || die "Test case ${tcase} failed."
+ edo bin/${tcase}
done
popd || die
}