aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Nicolas <patricknicolas@laposte.net>2025-02-05 16:19:27 +0100
committerPatrick Nicolas <patricknicolas@laposte.net>2025-02-05 16:32:55 +0100
commite8d43075dc0737a43cca4d33835b198de722b424 (patch)
treed3d7725456f04a71f3b9ab2b739cedf4cb8dae26 /media-libs
parentmedia-libs/wivrn: fix download of apk in wizard (diff)
downloadguru-e8d43075dc0737a43cca4d33835b198de722b424.tar.gz
guru-e8d43075dc0737a43cca4d33835b198de722b424.tar.bz2
guru-e8d43075dc0737a43cca4d33835b198de722b424.zip
media-libs/wivrn: drop 0.21
Signed-off-by: Patrick Nicolas <patricknicolas@laposte.net>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/wivrn/Manifest2
-rw-r--r--media-libs/wivrn/wivrn-0.21.ebuild135
2 files changed, 0 insertions, 137 deletions
diff --git a/media-libs/wivrn/Manifest b/media-libs/wivrn/Manifest
index 84363fb7b..65df55285 100644
--- a/media-libs/wivrn/Manifest
+++ b/media-libs/wivrn/Manifest
@@ -1,4 +1,2 @@
-DIST wivrn-0.21-server-build-deps.tar.xz 21294816 BLAKE2B a0b94ab15d39ef73ef384ebb38e29149666a73014b8e0ae9f2b6c53d416190afc8b06948a187381823f502a0673839a9c041d754600367697748c91fc2b6fe82 SHA512 33707e1ff92fde0b7bee497a6af0fddc9033afe6e09c0aae5ec7ba6557b3c321edde48db24b8a98e4155aca9c227976375d1591ab8e472a8686c7c57b491142e
-DIST wivrn-0.21.tar.gz 11125575 BLAKE2B 15b22363751f441cdf84d83d08aa5dbb5a02e77d90862a1aab20b22e3d3e93b0b61d6ad0b9b3a6fb4a2ecf4288360ea51a2884a7ec233eb21681533e87d4cf0f SHA512 8f27624351955053264cc2264f87a7b03e83f11f1c328c9f80e8bbec89d23ffc25948d9a1f579a4ea1ec3e6105f3ed4f918f6593476652ff126ded57e1fdc914
DIST wivrn-0.22-server-build-deps.tar.xz 21634036 BLAKE2B 1b6ddb85617f02c683d3da1908e4afa92ca620ebace42c6030ece9cabde1311d4262bcd02a66166bf19a247b149f9bdeec3cfa21abbbb0a5cbadb0c97f0e0317 SHA512 98b99adb3b00fca1a1650f0cd082cb363da66c3245976a51ede6fa7117f52c1fec3269644d6917111897e3e2c972a6b9ea12c78882fed49bafec9ad83e6e512f
DIST wivrn-0.22.tar.gz 11159586 BLAKE2B e83b3d95ad92c752e39d5233c2636f5cf095183880fa12a08589afa1e645a5ea7b41cdb985c5f43107c03c0c1aa3b13718cc4f9ddf7da9f4f7d1159a9057bfe0 SHA512 24fc6f36e4c9345a9f3fc3e6c2c47fbee5cdbc2f9864e58e5750209f58e32c40e08d48d091d7b2d5a2d161c4017642e3747799d8efc3e7bc5d6d040191022536
diff --git a/media-libs/wivrn/wivrn-0.21.ebuild b/media-libs/wivrn/wivrn-0.21.ebuild
deleted file mode 100644
index df6aa339d..000000000
--- a/media-libs/wivrn/wivrn-0.21.ebuild
+++ /dev/null
@@ -1,135 +0,0 @@
-# Copyright 2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake fcaps xdg
-
-DESCRIPTION="WiVRn OpenXR streaming"
-HOMEPAGE="https://github.com/WiVRn/WiVRn"
-
-LICENSE="GPL-3 Apache-2.0 MIT"
-SLOT="0"
-IUSE="gui nvenc +pipewire pulseaudio systemd vaapi wireshark-plugins x264"
-REQUIRED_USE="|| ( nvenc vaapi x264 )"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/WiVRn/WiVRn.git"
- MONADO_REPO_URI="https://gitlab.freedesktop.org/monado/monado.git"
-else
- SRC_URI="
- https://github.com/WiVRn/WiVRn/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
- https://github.com/WiVRn/WiVRn/releases/download/v${PV}/server-build-deps.tar.xz -> ${P}-server-build-deps.tar.xz"
- KEYWORDS="~amd64"
-fi
-
-RDEPEND="
- vaapi? (
- media-video/ffmpeg[libdrm,vaapi]
- )
- x264? (
- media-libs/x264
- )
- dev-libs/libbsd
- pipewire? (
- media-video/pipewire
- )
- pulseaudio? (
- media-libs/libpulse
- )
- media-libs/openxr-loader
- net-dns/avahi
- systemd? (
- sys-apps/systemd
- )
- wireshark-plugins? (
- net-analyzer/wireshark
- )
- gui? (
- dev-qt/qtbase:6
- )
-"
-DEPEND="
- ${RDEPEND}
- dev-cpp/cli11
- dev-cpp/eigen
- dev-cpp/nlohmann_json
- dev-libs/boost
-"
-BDEPEND="
- dev-util/glslang
- dev-util/gdbus-codegen
- gui? (
- gnome-base/librsvg
- )
-"
-
-if [[ ${PV} == 9999 ]]; then
- src_unpack() {
- git-r3_src_unpack
- default_src_unpack
-
- local MONADO_COMMIT=$(grep "GIT_TAG" "${P}/CMakeLists.txt" | awk '{print $2}')
- git-r3_fetch "${MONADO_REPO_URI}" "${MONADO_COMIT}"
- git-r3_checkout "${MONADO_REPO_URI}" "${WORKDIR}/monado-src"
- }
-
- src_prepare() {
- default_src_prepare
- eapply --directory="${WORKDIR}/monado-src" "${WORKDIR}/${P}/patches/monado"/*
- cmake_src_prepare
- }
-else
- src_unpack() {
- default_src_unpack
- cd "${WORKDIR}"
- mv "WiVRn-${PV}" "${P}"
- }
-fi
-
-src_configure() {
- if [[ ${PV} == 9999 ]]; then
- GIT_DESC=$(git describe --always)
- else
- GIT_DESC=${PV}
- fi
- local mycmakeargs=(
- -DGIT_DESC=${GIT_DESC}
- -DWIVRN_BUILD_CLIENT=OFF
- -DWIVRN_BUILD_SERVER=ON
- -DWIVRN_BUILD_DASHBOARD=$(usex gui)
- -DWIVRN_BUILD_DISSECTOR=$(usex wireshark-plugins)
- -DWIVRN_USE_PIPEWIRE=$(usex pipewire)
- -DWIVRN_USE_PULSEAUDIO=$(usex pulseaudio)
- -DWIVRN_USE_NVENC=$(usex nvenc)
- -DWIVRN_USE_VAAPI=$(usex vaapi)
- -DWIVRN_USE_X264=$(usex x264)
- -DWIVRN_USE_SYSTEMD=$(usex systemd)
- -DWIVRN_USE_SYSTEM_OPENXR=ON
- -DWIVRN_USE_SYSTEM_BOOST=ON
- -DFETCHCONTENT_FULLY_DISCONNECTED=ON
- -DFETCHCONTENT_BASE_DIR="${WORKDIR}"
- -DENABLE_COLOURED_OUTPUT=OFF
- )
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- dosym -r /usr/share/openxr/1/openxr_wivrn.json /etc/openxr/1/active_runtime.json
-}
-
-pkg_postinst()
-{
- fcaps cap_sys_nice bin/wivrn-server
- xdg_pkg_postinst
- elog "WiVRn requires a compatible client on VR headset to run."
- if [[ ${PV} == 9999 ]]; then
- elog "For most headsets it can be downloaded from CI artifacts on https://github.com/WiVRn/WiVRn/actions/workflows/Build.yml"
- else
- elog "For most headsets it can be downloaded on https://github.com/WiVRn/WiVRn/releases/tag/v${PV}"
- fi
-}