aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Nicolas <patricknicolas@laposte.net>2024-11-03 17:56:57 +0100
committerPatrick Nicolas <patricknicolas@laposte.net>2024-11-03 17:56:57 +0100
commit6d35e4efed36521e44b3099a48a422ef0f265f74 (patch)
tree260a7083a1f2a64dee0cd53910d96cfce3ea22c7 /media-libs
parentmedia-libs/wivrn: fix build dependencies (diff)
downloadguru-6d35e4efed36521e44b3099a48a422ef0f265f74.tar.gz
guru-6d35e4efed36521e44b3099a48a422ef0f265f74.tar.bz2
guru-6d35e4efed36521e44b3099a48a422ef0f265f74.zip
media-libs/wivrn: add 0.21, drop 0.19
Signed-off-by: Patrick Nicolas <patricknicolas@laposte.net>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/wivrn/Manifest4
-rw-r--r--media-libs/wivrn/wivrn-0.21.ebuild (renamed from media-libs/wivrn/wivrn-0.19.ebuild)49
2 files changed, 34 insertions, 19 deletions
diff --git a/media-libs/wivrn/Manifest b/media-libs/wivrn/Manifest
index ed35a8c2c..58324b7d6 100644
--- a/media-libs/wivrn/Manifest
+++ b/media-libs/wivrn/Manifest
@@ -1,4 +1,4 @@
-DIST wivrn-0.19-server-build-deps.tar.xz 21027752 BLAKE2B 8de78f1f356747e7ffa64a14c1d4d3888f9df658ddb1bc5556788873dfcae48612a586bc176f20c54466ad8895bddfac05423195d8f1d070a8a12178eaf9340a SHA512 4c75aa3b1b64df1ea2e1cd258c5ad602230c1a4cc3dbbbbd3c6e41ae562719996e983fd2f95c1da0a8d4f53017cf108cebd6177e7439ac1bc050a10c7339480b
-DIST wivrn-0.19.tar.gz 11281543 BLAKE2B cc182cacdc35eccdd815730bbecfa007c0a096690b06a773b9da570115c693e6a2e1266e5ad30d9ce34db2640e3f251e630a825f4cf2f5f14ef51dfbf784b99e SHA512 47d985156e234702d5a55febfa8e3d62154db77db40da9b1d2c7e63e649b2c9550f0b40a68610b597bcf6f2f0f32ebaf1a9dd474509f3e376e60fe669cc1a630
DIST wivrn-0.20-server-build-deps.tar.xz 21140156 BLAKE2B 17836be45393a0fbd3f45d8654e88ce677a94c7f641f4662c6bcfd47fb70d87394a05544995d79e9203294c0c83d95a221af6b5d73e7cf078e7db9aa7f8f1f67 SHA512 a86d9d74afd316a4740b80302dbae63ec13609abd4c33a0b97bdbfbeb6caa36035a5f1b60245c8bec5ab460c7486089efa6eae4b8a0a8121b6d33a4ee9a46417
DIST wivrn-0.20.tar.gz 11433225 BLAKE2B 15c00dcd23bf9751d7b119a301298a5487128b6c06b91fd7ed3787b4ac9375d0a822036d76e0e9fe113700524bf0fa27459bfc8173f02eb893233f5fac566d59 SHA512 d83be879d31740e2ce382ee9ed095a6299ed6a435a5ef1cffa88aca9af0bb5d242374a90bcf0ff936611454950566da4e3aaa216085259d8301d9122b0159af9
+DIST wivrn-0.21-server-build-deps.tar.xz 21294816 BLAKE2B a0b94ab15d39ef73ef384ebb38e29149666a73014b8e0ae9f2b6c53d416190afc8b06948a187381823f502a0673839a9c041d754600367697748c91fc2b6fe82 SHA512 33707e1ff92fde0b7bee497a6af0fddc9033afe6e09c0aae5ec7ba6557b3c321edde48db24b8a98e4155aca9c227976375d1591ab8e472a8686c7c57b491142e
+DIST wivrn-0.21.tar.gz 11125575 BLAKE2B 15b22363751f441cdf84d83d08aa5dbb5a02e77d90862a1aab20b22e3d3e93b0b61d6ad0b9b3a6fb4a2ecf4288360ea51a2884a7ec233eb21681533e87d4cf0f SHA512 8f27624351955053264cc2264f87a7b03e83f11f1c328c9f80e8bbec89d23ffc25948d9a1f579a4ea1ec3e6105f3ed4f918f6593476652ff126ded57e1fdc914
diff --git a/media-libs/wivrn/wivrn-0.19.ebuild b/media-libs/wivrn/wivrn-0.21.ebuild
index 15d153a54..df6aa339d 100644
--- a/media-libs/wivrn/wivrn-0.19.ebuild
+++ b/media-libs/wivrn/wivrn-0.21.ebuild
@@ -1,27 +1,22 @@
# Copyright 2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit cmake
+inherit cmake fcaps xdg
DESCRIPTION="WiVRn OpenXR streaming"
HOMEPAGE="https://github.com/WiVRn/WiVRn"
LICENSE="GPL-3 Apache-2.0 MIT"
SLOT="0"
-IUSE="nvenc +pipewire pulseaudio systemd vaapi wireshark-plugins x264"
+IUSE="gui nvenc +pipewire pulseaudio systemd vaapi wireshark-plugins x264"
REQUIRED_USE="|| ( nvenc vaapi x264 )"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/WiVRn/WiVRn.git"
-
- MONADO_V=dfc602288ab05131584a3f2be18031a13fccd061
- PFR_V=2.2.0
- SRC_URI="
- https://github.com/boostorg/pfr/archive/refs/tags/${PFR_V}.tar.gz -> boostpfr_${PFR_V}.tar.gz
- https://gitlab.freedesktop.org/monado/monado/-/archive/${MONADO_V}/monado-${MONADO_V}.tar.bz2"
+ MONADO_REPO_URI="https://gitlab.freedesktop.org/monado/monado.git"
else
SRC_URI="
https://github.com/WiVRn/WiVRn/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
@@ -51,23 +46,39 @@ RDEPEND="
wireshark-plugins? (
net-analyzer/wireshark
)
+ gui? (
+ dev-qt/qtbase:6
+ )
"
-
-BDEPEND="
+DEPEND="
${RDEPEND}
dev-cpp/cli11
dev-cpp/eigen
dev-cpp/nlohmann_json
+ dev-libs/boost
+"
+BDEPEND="
dev-util/glslang
+ dev-util/gdbus-codegen
+ gui? (
+ gnome-base/librsvg
+ )
"
if [[ ${PV} == 9999 ]]; then
src_unpack() {
git-r3_src_unpack
default_src_unpack
- cd "${WORKDIR}"
- mv "monado-${MONADO_V}" "monado-src"
- mv "pfr-${PFR_V}" "boostpfr-src"
+
+ local MONADO_COMMIT=$(grep "GIT_TAG" "${P}/CMakeLists.txt" | awk '{print $2}')
+ git-r3_fetch "${MONADO_REPO_URI}" "${MONADO_COMIT}"
+ git-r3_checkout "${MONADO_REPO_URI}" "${WORKDIR}/monado-src"
+ }
+
+ src_prepare() {
+ default_src_prepare
+ eapply --directory="${WORKDIR}/monado-src" "${WORKDIR}/${P}/patches/monado"/*
+ cmake_src_prepare
}
else
src_unpack() {
@@ -79,7 +90,7 @@ fi
src_configure() {
if [[ ${PV} == 9999 ]]; then
- GIT_DESC=$(git describe)
+ GIT_DESC=$(git describe --always)
else
GIT_DESC=${PV}
fi
@@ -87,6 +98,7 @@ src_configure() {
-DGIT_DESC=${GIT_DESC}
-DWIVRN_BUILD_CLIENT=OFF
-DWIVRN_BUILD_SERVER=ON
+ -DWIVRN_BUILD_DASHBOARD=$(usex gui)
-DWIVRN_BUILD_DISSECTOR=$(usex wireshark-plugins)
-DWIVRN_USE_PIPEWIRE=$(usex pipewire)
-DWIVRN_USE_PULSEAUDIO=$(usex pulseaudio)
@@ -94,7 +106,8 @@ src_configure() {
-DWIVRN_USE_VAAPI=$(usex vaapi)
-DWIVRN_USE_X264=$(usex x264)
-DWIVRN_USE_SYSTEMD=$(usex systemd)
- -DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON
+ -DWIVRN_USE_SYSTEM_OPENXR=ON
+ -DWIVRN_USE_SYSTEM_BOOST=ON
-DFETCHCONTENT_FULLY_DISCONNECTED=ON
-DFETCHCONTENT_BASE_DIR="${WORKDIR}"
-DENABLE_COLOURED_OUTPUT=OFF
@@ -106,11 +119,13 @@ src_configure() {
src_install() {
cmake_src_install
- dosym /usr/share/openxr/1/openxr_wivrn.json /etc/openxr/1/active_runtime.json
+ dosym -r /usr/share/openxr/1/openxr_wivrn.json /etc/openxr/1/active_runtime.json
}
pkg_postinst()
{
+ fcaps cap_sys_nice bin/wivrn-server
+ xdg_pkg_postinst
elog "WiVRn requires a compatible client on VR headset to run."
if [[ ${PV} == 9999 ]]; then
elog "For most headsets it can be downloaded from CI artifacts on https://github.com/WiVRn/WiVRn/actions/workflows/Build.yml"