aboutsummaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorMarco Scardovi <marco@scardovi.com>2021-06-23 22:29:21 +0200
committerMarco Scardovi <marco@scardovi.com>2021-06-23 22:29:21 +0200
commit0d782f6a1265cc6b0983af258cc1d4b1690cc027 (patch)
tree7e9134d93840d7d071cceee93820eec513c0811d /gui-wm
parentsys-power/gtherm: add new package (diff)
downloadguru-0d782f6a1265cc6b0983af258cc1d4b1690cc027.tar.gz
guru-0d782f6a1265cc6b0983af258cc1d4b1690cc027.tar.bz2
guru-0d782f6a1265cc6b0983af258cc1d4b1690cc027.zip
gui-wm/phosh-meta: add new package
phosh-meta is the meta-package to install phosh on mobile phones. phosh is the DM based on gnome-40 specifically crafted for mobile phones/tablets like librem 5 and pinephone. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Marco Scardovi <marco@scardovi.com>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/phosh-meta/metadata.xml8
-rw-r--r--gui-wm/phosh-meta/phosh-meta-0.2.ebuild49
2 files changed, 57 insertions, 0 deletions
diff --git a/gui-wm/phosh-meta/metadata.xml b/gui-wm/phosh-meta/metadata.xml
new file mode 100644
index 000000000..144c8091c
--- /dev/null
+++ b/gui-wm/phosh-meta/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marco@scardovi.com</email>
+ <name>Marco Scardovi</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/gui-wm/phosh-meta/phosh-meta-0.2.ebuild b/gui-wm/phosh-meta/phosh-meta-0.2.ebuild
new file mode 100644
index 000000000..04f873cd5
--- /dev/null
+++ b/gui-wm/phosh-meta/phosh-meta-0.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Meta package for Phosh"
+HOMEPAGE="https://github.com/dreemurrs-embedded/Pine64-Arch"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+DEPEND="
+ app-editors/gedit
+ app-mobilephone/mobile-config-firefox
+ app-mobilephone/flashlight
+ app-text/evince
+ gnome-base/gnome-control-center
+ gnome-extra/gnome-contacts
+ media-video/megapixels
+ gnome-extra/gnome-calculator
+ gnome-extra/gnome-calendar
+ gui-wm/phosh
+ net-voip/calls
+ net-im/chatty
+ net-dns/dnsmasq
+ sys-power/gtherm
+ sys-auth/rtkit
+ x11-misc/squeekboard
+ x11-terms/gnome-terminal
+ x11-themes/sound-theme-librem5
+ www-client/epiphany
+"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+pkg_postinst() {
+ [ -e /usr/share/applications-bak ] || mkdir /usr/share/applications-bak
+ for i in vim org.gnupg.pinentry-qt org.gnome.Extensions mupdf \
+ gnome-printers-panel gnome-wifi-pannel pidgin wpa_gui cups \
+ Gentoo-system-config-printer
+ do
+ if [ -e /usr/share/applications/$i.desktop ]; then
+ mv /usr/share/applications/$i.desktop /usr/share/applications-bak
+ fi
+ done
+}