aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRemigiusz Micielski <remigiusz.micielski@gmail.com>2023-04-11 11:45:46 +0200
committerRemigiusz Micielski <remigiusz.micielski@gmail.com>2023-04-11 11:45:46 +0200
commite4f0156d7054eb856a18f01e4c1b1c2b6196b089 (patch)
tree7d0ecda055431c3f399b808a3a6008c8e9bd8ef2 /gui-libs
parentgui-libs/xdg-desktop-portal-hyprland: add hyprland-protocols subproject (diff)
downloadguru-e4f0156d7054eb856a18f01e4c1b1c2b6196b089.tar.gz
guru-e4f0156d7054eb856a18f01e4c1b1c2b6196b089.tar.bz2
guru-e4f0156d7054eb856a18f01e4c1b1c2b6196b089.zip
gui-libs/xdg-desktop-portal-hyprland: add 0.2.1, update 9999
Signed-off-by: Remigiusz Micielski <remigiusz.micielski@gmail.com>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/xdg-desktop-portal-hyprland/Manifest1
-rw-r--r--gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-0.2.1.ebuild82
-rw-r--r--gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild1
3 files changed, 84 insertions, 0 deletions
diff --git a/gui-libs/xdg-desktop-portal-hyprland/Manifest b/gui-libs/xdg-desktop-portal-hyprland/Manifest
index b555e4ae5..cd38d3838 100644
--- a/gui-libs/xdg-desktop-portal-hyprland/Manifest
+++ b/gui-libs/xdg-desktop-portal-hyprland/Manifest
@@ -1,3 +1,4 @@
DIST hyprland-protocol-0.1.0.tar.gz 6343 BLAKE2B cffa25c1fbac992db9aee57956615c2a5f8a6e90150d86246218e6d346e566a43527f56cab08b07359bd2f56b1e02b741fb0dbb37ec35fbadd22dfdb2006d3b0 SHA512 f8534c0f6562ce3c770ed9c79b8b78504d6f3aa75001c74ecfa5418af939e88a020ca1cef08d20c62e73c764d66452b5ce212a0f0d2e9a3aaba635ee80b142c5
+DIST hyprland-protocol-0.2.1.tar.gz 6343 BLAKE2B cffa25c1fbac992db9aee57956615c2a5f8a6e90150d86246218e6d346e566a43527f56cab08b07359bd2f56b1e02b741fb0dbb37ec35fbadd22dfdb2006d3b0 SHA512 f8534c0f6562ce3c770ed9c79b8b78504d6f3aa75001c74ecfa5418af939e88a020ca1cef08d20c62e73c764d66452b5ce212a0f0d2e9a3aaba635ee80b142c5
DIST xdg-desktop-hyprland-0.1.0.tar.gz 45350 BLAKE2B 7b0349f3d0ff4708df3068d71deecb675109c905e0cea6fa0724a2645267a70038a54e2a9eb536e6dbc0d0a138071ceb91527e0df91c83cda0b57e3cf3b519d2 SHA512 b8cfda484d5d50c7fae33eb020c101990ceb244bdfebac46c9820267697eae76bb1e6261c1b03d8fb0148eb81c64f01c59eb94171cb87407541d20117fa48f18
DIST xdg-desktop-hyprland-0.2.1.tar.gz 49895 BLAKE2B 2823133cf0253e36b5a8777184ac220e9b7800d8bf2307599b764cb20f9eb5b3600adaf9d29e6b5707eb99aa3d75719c246b95eca30ef261a90c8d82d675a5ae SHA512 38cfae4736f7016cc3bf998963f42ec5e8e61a1954a4509152834fa2ba33fbc88723af9833881f5ab6e89e92edb0f6840b8ca645b7fa3162220864e9a9aa2725
diff --git a/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-0.2.1.ebuild b/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-0.2.1.ebuild
new file mode 100644
index 000000000..10b789489
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-0.2.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="xdg-desktop-portal backend for hyprland"
+HOMEPAGE="https://github.com/hyprwm/xdg-desktop-portal-hyprland"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/hyprwm/xdg-desktop-portal-hyprland.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ PROTOCOMMIT=4d29e48433270a2af06b8bc711ca1fe5109746cd
+ SRC_URI="https://github.com/hyprwm/xdg-desktop-portal-hyprland/archive/refs/tags/v${PV}.tar.gz \
+ -> xdg-desktop-hyprland-${PV}.tar.gz
+ https://github.com/hyprwm/hyprland-protocols/archive/${PROTOCOMMIT}.tar.gz \
+ -> hyprland-protocol-${PV}.tar.gz"
+fi
+
+LICENSE="MIT"
+SLOT="0/9999"
+IUSE="elogind systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ >=media-video/pipewire-0.3.41:=
+ dev-libs/inih
+ dev-libs/wayland
+ dev-qt/qtbase
+ dev-qt/qtcore
+ dev-qt/qtgui
+ dev-qt/qtwayland:6
+ dev-qt/qtwidgets
+ media-libs/mesa
+ sys-apps/util-linux
+ x11-libs/libdrm
+ || (
+ systemd? ( >=sys-apps/systemd-237 )
+ elogind? ( >=sys-auth/elogind-237 )
+ sys-libs/basu
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ sys-apps/xdg-desktop-portal
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.24
+ virtual/pkgconfig
+"
+
+src_unpack() {
+ default
+
+ rmdir "${S}/subprojects/hyprland-protocols"
+ mv "${WORKDIR}/hyprland-protocols-${PROTOCOMMIT}" "${S}/subprojects/hyprland-protocols" || die
+}
+
+src_configure() {
+ local emasonargs=()
+ if use systemd; then
+ emasonargs+=(-Dsd-bus-provider=libsystemd)
+ elif use elogind; then
+ emasonargs+=(-Dsd-bus-provider=libelogind)
+ else
+ emasonargs+=(-Dsd-bus-provider=basu)
+ fi
+ meson_src_configure
+}
+
+src_compile() {
+ meson_src_compile
+ emake -C hyprland-share-picker all
+}
+
+src_install() {
+ meson_src_install
+ dobin "${S}/hyprland-share-picker/build/hyprland-share-picker"
+}
diff --git a/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild b/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild
index a16147f38..10b789489 100644
--- a/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild
+++ b/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild
@@ -35,6 +35,7 @@ DEPEND="
dev-qt/qtwayland:6
dev-qt/qtwidgets
media-libs/mesa
+ sys-apps/util-linux
x11-libs/libdrm
|| (
systemd? ( >=sys-apps/systemd-237 )