aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2024-02-21 15:53:50 +0100
committerPascal Jäger <pascal.jaeger@leimstift.de>2024-02-21 16:02:34 +0100
commitf32e399d011e61a4582493933184beb6180089be (patch)
tree580c2373c3e911c3312d4dfde0c8e85270be106e /gui-apps
parentdev-python/jsonpath-rw-ext: use PEP517 build (diff)
downloadguru-f32e399d011e61a4582493933184beb6180089be.tar.gz
guru-f32e399d011e61a4582493933184beb6180089be.tar.bz2
guru-f32e399d011e61a4582493933184beb6180089be.zip
gui-apps/nwg-panel: add 0.9.24
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/nwg-panel/Manifest1
-rw-r--r--gui-apps/nwg-panel/nwg-panel-0.9.24.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/gui-apps/nwg-panel/Manifest b/gui-apps/nwg-panel/Manifest
index a99f8a20c..8232e859f 100644
--- a/gui-apps/nwg-panel/Manifest
+++ b/gui-apps/nwg-panel/Manifest
@@ -1,3 +1,4 @@
DIST nwg-panel-0.9.21.tar.gz 224453 BLAKE2B 33037f4934d42469e3ce4e35ca36cc9421f3ea594000e6fd90ac44739eb5b220a80d6e7a6f1162b5c8cfb32c64bd1fd9dd678e6b46cbd166cc04014951739c23 SHA512 542b574427b7f9ae2d6b57a32ecfd39282971fe848ff16a6c54f2f85898dfb30d9823a43fe9a509cf486cecb59ec675aa0b1cb2713dd2cc29b03a1ddb130eac4
DIST nwg-panel-0.9.22.tar.gz 226330 BLAKE2B b3fce928e16177c58d4180178db6e702416fd04f2e4c80d155722c24df3299e2e1cd0646d85adf2d84ea64d59ecdc35eb36dd5011246189e989b32903db354e4 SHA512 d9be742b307152e76c8e97d16cb5eeb0e67018a8b84ea7e03838cc4b8d9881f50f297911ecb38209ce778112ae9645995727dbda8bf9981cc32da9dc02ff7c39
DIST nwg-panel-0.9.23.tar.gz 227040 BLAKE2B bc0f5afd220bab8f360874b9744b21c8f1730cbd124763fe57d9707ae1169cce6d155dfe49dca37d45d398b5aeda38f3f68764e7cd5e11ac5392ad61d6b2a615 SHA512 1363ffab1124a17a4320a0350595808dda76fcfe1a97191e3b504b99a0733c9860d4aa35a97299605226f988687c3b4cf14794fe065e2e1ec11e1ca2e0fb0e9c
+DIST nwg-panel-0.9.24.tar.gz 227084 BLAKE2B 8a86923a0d457d55a1269b00c6955c51410fbd8f838c1b9b4526c37200b4f55c161d0df1ee4a3a0ef83f115c33563ffc8cc5907d601495d1b433ec04e93ac198 SHA512 68329511f20ce88738fb2b30efaa542fcbaf1376a7cb269755f99489cd89984d8986230eebd4c0c610cf5e935f85ba4d33108b7beff64dabc0d67f8f2af04c5b
diff --git a/gui-apps/nwg-panel/nwg-panel-0.9.24.ebuild b/gui-apps/nwg-panel/nwg-panel-0.9.24.ebuild
new file mode 100644
index 000000000..dde513ba9
--- /dev/null
+++ b/gui-apps/nwg-panel/nwg-panel-0.9.24.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit desktop distutils-r1 systemd xdg-utils
+
+if [[ "${PV}" == 9999 ]]
+then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/nwg-piotr/nwg-panel.git"
+else
+ SRC_URI="https://github.com/nwg-piotr/nwg-panel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="GTK3-based panel for sway and Hyprland Wayland compositors"
+HOMEPAGE="https://github.com/nwg-piotr/nwg-panel"
+LICENSE="MIT"
+
+SLOT="0"
+
+RDEPEND="
+ x11-libs/gtk+:3
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/i3ipc[${PYTHON_USEDEP}]
+ dev-python/dasbus[${PYTHON_USEDEP}]
+ gui-apps/nwg-icon-picker
+ media-sound/playerctl
+ gui-libs/gtk-layer-shell
+"
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ domenu nwg-panel-config.desktop
+ domenu nwg-processes.desktop
+ doicon nwg-panel.svg
+ doicon nwg-processes.svg
+ doicon nwg-shell.svg
+ systemd_dounit nwg-panel.service
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}