aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-07-02 19:03:20 -0700
committerJohn M. Harris Jr. <johnmh@johnmh.me>2024-07-02 19:03:20 -0700
commite2a745227955d2711dd809ada11bb449c4c96271 (patch)
tree5cde942c6c71e9d0bbf8c9259ccf5eadf9a06bba /gui-apps
parentdev-python/mwclient: new package (diff)
downloadguru-e2a745227955d2711dd809ada11bb449c4c96271.tar.gz
guru-e2a745227955d2711dd809ada11bb449c4c96271.tar.bz2
guru-e2a745227955d2711dd809ada11bb449c4c96271.zip
gui-apps/hyprshade: add 3.2.1
Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/hyprshade/Manifest1
-rw-r--r--gui-apps/hyprshade/hyprshade-3.2.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/gui-apps/hyprshade/Manifest b/gui-apps/hyprshade/Manifest
new file mode 100644
index 000000000..98acc4e1b
--- /dev/null
+++ b/gui-apps/hyprshade/Manifest
@@ -0,0 +1 @@
+DIST hyprshade-3.2.1.gh.tar.gz 40194411 BLAKE2B dfae66884bdae6e409115d8d9200af72302a00984c430348b04b4f16d1441b047d8bbae2bb87d06e3a16f3c6dfbade2219cd9bad04a01fec5ddee86693b398ff SHA512 b21685684b01b7e01e1b17215f4d10c3420010f90041cbab25a159a0415779460cbda666adb4aab4786d55abba4b0205c6d7709c9443613ffff71dfd3ed38fdc
diff --git a/gui-apps/hyprshade/hyprshade-3.2.1.ebuild b/gui-apps/hyprshade/hyprshade-3.2.1.ebuild
new file mode 100644
index 000000000..e71b05a5c
--- /dev/null
+++ b/gui-apps/hyprshade/hyprshade-3.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/loqusion/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/loqusion/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Hyprland shader configuration tool"
+HOMEPAGE="https://github.com/loqusion/hyprshade"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/chevron
+ gui-wm/hyprland
+"
+
+distutils_enable_tests pytest