aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaichi Yamamoto <dev@dyama.net>2024-09-25 10:16:50 +0900
committerDaichi Yamamoto <dev@dyama.net>2024-09-25 10:21:10 +0900
commit7c37b049ecc8848bcabb87ad267eec5ba8522e63 (patch)
tree587378fba2b44d1c27ec1134b1ae95591e767a98 /gui-apps
parentsys-fs/dwarfs: add 0.10.1 (diff)
downloadguru-7c37b049ecc8848bcabb87ad267eec5ba8522e63.tar.gz
guru-7c37b049ecc8848bcabb87ad267eec5ba8522e63.tar.bz2
guru-7c37b049ecc8848bcabb87ad267eec5ba8522e63.zip
gui-apps/azote: add 1.13.1, drop 1.13.0
Signed-off-by: Daichi Yamamoto <dev@dyama.net>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/azote/Manifest2
-rw-r--r--gui-apps/azote/azote-1.13.1.ebuild (renamed from gui-apps/azote/azote-1.13.0.ebuild)12
-rw-r--r--gui-apps/azote/azote-9999.ebuild12
-rw-r--r--gui-apps/azote/files/azote-1.13.1-pyproject.patch (renamed from gui-apps/azote/files/azote-1.13.0-pyproject.patch)4
4 files changed, 21 insertions, 9 deletions
diff --git a/gui-apps/azote/Manifest b/gui-apps/azote/Manifest
index dfaf599b8..64d649427 100644
--- a/gui-apps/azote/Manifest
+++ b/gui-apps/azote/Manifest
@@ -1 +1 @@
-DIST azote-1.13.0.tar.gz 7972973 BLAKE2B 5584f4cbced1eaec560ab24fef7d9a7865fe1ae676e95c2e46abf5d443d972aed25da08986ced86841adb57ec3efc7690e04d452c7438187366e54a2b7e9ed07 SHA512 5a61cb0e9320705ec191b049bb946159f5970ac8f78386539c73b643794a2e0233c5cd967c3df854b0abe45f2d9376ec13b7a6452d8d70b1d0cf0d974f65b890
+DIST azote-1.13.1.tar.gz 7973313 BLAKE2B 86c54fc1f9b06ff8a8405784a5d54e6021d1f43d0dce45e3211f4395a68238ae6fb7e088634826eb95b05126dea717e96373348958380427d24639a1376f64b7 SHA512 fd6d1ac24e05ed98785b20d1e47b65e77b5bf3a55a25ce7fb29e0394f0ce540d11cc39dfb40f0aa12a4900d9524219bf534fc411360009a48456c71c2774da2a
diff --git a/gui-apps/azote/azote-1.13.0.ebuild b/gui-apps/azote/azote-1.13.1.ebuild
index a14f31f7b..933b37146 100644
--- a/gui-apps/azote/azote-1.13.0.ebuild
+++ b/gui-apps/azote/azote-1.13.1.ebuild
@@ -14,7 +14,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/nwg-piotr/azote"
else
- SRC_URI="https://github.com/nwg-piotr/azote/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/nwg-piotr/azote/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi
@@ -30,9 +30,11 @@ RDEPEND="
"
PATCHES=(
- "${FILESDIR}"/${PN}-1.13.0-pyproject.patch
+ "${FILESDIR}"/${PN}-1.13.1-pyproject.patch
)
+DOCS=( README.md )
+
python_install_all() {
distutils-r1_python_install_all
@@ -40,10 +42,14 @@ python_install_all() {
domenu dist/azote.desktop
+ insinto /usr/share/pixmaps
+ doins dist/azote.svg
insinto /usr/share/azote
- doins dist/azote.svg dist/indicator_{active,attention}.png
+ doins dist/indicator_*.png
insinto /usr/share/licenses/azote
doins LICENSE-COLORTHIEF
+
+ einstalldocs
}
pkg_postinst() {
diff --git a/gui-apps/azote/azote-9999.ebuild b/gui-apps/azote/azote-9999.ebuild
index a14f31f7b..933b37146 100644
--- a/gui-apps/azote/azote-9999.ebuild
+++ b/gui-apps/azote/azote-9999.ebuild
@@ -14,7 +14,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/nwg-piotr/azote"
else
- SRC_URI="https://github.com/nwg-piotr/azote/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/nwg-piotr/azote/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi
@@ -30,9 +30,11 @@ RDEPEND="
"
PATCHES=(
- "${FILESDIR}"/${PN}-1.13.0-pyproject.patch
+ "${FILESDIR}"/${PN}-1.13.1-pyproject.patch
)
+DOCS=( README.md )
+
python_install_all() {
distutils-r1_python_install_all
@@ -40,10 +42,14 @@ python_install_all() {
domenu dist/azote.desktop
+ insinto /usr/share/pixmaps
+ doins dist/azote.svg
insinto /usr/share/azote
- doins dist/azote.svg dist/indicator_{active,attention}.png
+ doins dist/indicator_*.png
insinto /usr/share/licenses/azote
doins LICENSE-COLORTHIEF
+
+ einstalldocs
}
pkg_postinst() {
diff --git a/gui-apps/azote/files/azote-1.13.0-pyproject.patch b/gui-apps/azote/files/azote-1.13.1-pyproject.patch
index d71442e8a..991fd62eb 100644
--- a/gui-apps/azote/files/azote-1.13.0-pyproject.patch
+++ b/gui-apps/azote/files/azote-1.13.1-pyproject.patch
@@ -56,7 +56,7 @@ Subject: [PATCH 2/2] scratch
diff --git a/setup.py b/setup.py
deleted file mode 100644
-index bc0cd1e..0000000
+index 8f1e4f6..0000000
--- a/setup.py
+++ /dev/null
@@ -1,30 +0,0 @@
@@ -71,7 +71,7 @@ index bc0cd1e..0000000
-
-setup(
- name='azote',
-- version='1.13.0',
+- version='1.13.1',
- description='Wallpaper manager for sway and some other WMs',
- packages=find_packages(),
- include_package_data=True,