aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2024-03-06 14:09:35 +0100
committerPascal Jäger <pascal.jaeger@leimstift.de>2024-03-06 14:12:18 +0100
commit084dbf9bce5b5f62f649e14ef275fb3b50259abf (patch)
tree004dcd49af53da6e2e1d607c08469bdce208f111 /gui-apps
parentgui-apps/nwg-panel: add 0.9.25 (diff)
downloadguru-084dbf9bce5b5f62f649e14ef275fb3b50259abf.tar.gz
guru-084dbf9bce5b5f62f649e14ef275fb3b50259abf.tar.bz2
guru-084dbf9bce5b5f62f649e14ef275fb3b50259abf.zip
gui-apps/nwg-shell: add 0.5.33
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/nwg-shell/Manifest1
-rw-r--r--gui-apps/nwg-shell/nwg-shell-0.5.33.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/gui-apps/nwg-shell/Manifest b/gui-apps/nwg-shell/Manifest
index 6786361f7..0cdc8664f 100644
--- a/gui-apps/nwg-shell/Manifest
+++ b/gui-apps/nwg-shell/Manifest
@@ -1,2 +1,3 @@
DIST nwg-shell-0.5.31.tar.gz 2181632 BLAKE2B 173fb14aeeae8c0788ee8b4deb614538128e623032231eb427b9dbdafd3b84d4cbaa8f109adf30c7c382796211cc72385f24d955776f0fee511a719aa572fde4 SHA512 1b26f14f14123dc7c7c48839dfa473c45688f17e2274c00b41f9bbcea9959d871606a88ed3517aa1dcfa22d346b4a9b0369b6c58ba27ba4e119269e0031840d2
DIST nwg-shell-0.5.32.tar.gz 2181719 BLAKE2B f2b67a2a41a0f1b7123ba74410a2630ccdcd2a6f7ae5318ff1ffc95ff36d012bc4536c40467ac68a2d40bb2556cb47c157b6f1f7987efb69307f3f5bbd19dde5 SHA512 52402569d36d96ab119dbae12a615bbab55e7c025ac08f1a0fbd220703c94ce6628684c304efd5e2810258f75fcdb0fde93f0f074f21846c52962232173452f1
+DIST nwg-shell-0.5.33.tar.gz 2181780 BLAKE2B 0d675bf7230d254e0accd1805329fad90b85f38e74e468a5cf8fa139d9c9fdc833353aa5514ba9c3b32a47afe25439c8c96fbc7e2af763a4db921b781b68a593 SHA512 ae4091faaee6dfb3f0f5f01ab5697ded6e4c508c15082b83bf024afec93d51e7fd165ad7780ea1fe88e6d630d3c1b9d2a6255f73484ffb1db969a38b6abf1d18
diff --git a/gui-apps/nwg-shell/nwg-shell-0.5.33.ebuild b/gui-apps/nwg-shell/nwg-shell-0.5.33.ebuild
new file mode 100644
index 000000000..e533477e8
--- /dev/null
+++ b/gui-apps/nwg-shell/nwg-shell-0.5.33.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+SRC_URI="https://github.com/nwg-piotr/nwg-shell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="libraries an common functions for the nwg-shell project"
+HOMEPAGE="https://github.com/nwg-piotr/nwg-shell"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ gui-apps/grim
+ gui-apps/swappy
+ gui-apps/slurp
+"
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ default
+ dobin scripts/*
+}
+
+pkg_postinst() {
+ elog "To install nwg-shell for the current user, run"
+ elog "nwg-shell-installer -w (for sway) or"
+ elog "nwg-shell-installer -w -hypr (for hyprland)"
+}