aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuan Liao <liaoyuan@gmail.com>2024-04-27 07:38:07 -0400
committerYuan Liao <liaoyuan@gmail.com>2024-04-27 07:38:07 -0400
commit301fe9aa9a0702eac8be1ebf6372ed4fac470ea5 (patch)
tree3d0cb435d44706c960b5c121c14e56086ab962b1 /gnome-extra
parentprofiles: mask dev-python/evernote3 for removal (diff)
downloadguru-301fe9aa9a0702eac8be1ebf6372ed4fac470ea5.tar.gz
guru-301fe9aa9a0702eac8be1ebf6372ed4fac470ea5.tar.bz2
guru-301fe9aa9a0702eac8be1ebf6372ed4fac470ea5.zip
gnome-extra/extension-manager: Drop 0.4.3
Signed-off-by: Yuan Liao <liaoyuan@gmail.com>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/extension-manager/Manifest1
-rw-r--r--gnome-extra/extension-manager/extension-manager-0.4.3.ebuild83
2 files changed, 0 insertions, 84 deletions
diff --git a/gnome-extra/extension-manager/Manifest b/gnome-extra/extension-manager/Manifest
index b8efe9a95..214884f85 100644
--- a/gnome-extra/extension-manager/Manifest
+++ b/gnome-extra/extension-manager/Manifest
@@ -1,2 +1 @@
-DIST extension-manager-0.4.3.tar.gz 1479403 BLAKE2B 5d183cf8af08b07878a65305f5b814f5e74a600a305845c9d953cb4debf8476e4e81e932dd645eb54e9c45e662c69c7f2c44e4e40698137d1724c23ab3b42e95 SHA512 036ee3f5c2b6e70e36060112744a760f7f6f29cd7dbc9eafa035942bb283b18b94d55c68285f5c546480e2683e2ceddb4f6e1d309002b18894bccb3b6b87a67d
DIST extension-manager-0.5.0.tar.gz 2246539 BLAKE2B 650033c0a61d7ee4b3b752c12d8474398990f86cdc66c02681c2a1255b4c3afb12db874e8591df6bb4749bf17f322cd20094b0cce35600f82fa6f2cf4ae3f752 SHA512 975f71c072b12358760439ab9254ed8967cfb9c9c8cd38e93d38db0fb8138e4911a7a63c924f8a62b46fbedc83246e156765f3be9e092096d8647d78a0e7717f
diff --git a/gnome-extra/extension-manager/extension-manager-0.4.3.ebuild b/gnome-extra/extension-manager/extension-manager-0.4.3.ebuild
deleted file mode 100644
index 008277ed5..000000000
--- a/gnome-extra/extension-manager/extension-manager-0.4.3.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit gnome2-utils meson xdg
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/mjakeman/extension-manager.git"
-else
- SRC_URI="https://github.com/mjakeman/extension-manager/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-DESCRIPTION="A native tool for browsing, installing, and managing GNOME Shell Extensions"
-HOMEPAGE="https://mattjakeman.com/apps/extension-manager"
-
-LICENSE="GPL-3+"
-SLOT="0"
-
-BDEPEND="
- dev-libs/glib:2
- dev-util/blueprint-compiler
- sys-devel/gettext
- virtual/pkgconfig
-"
-
-RDEPEND="
- dev-libs/glib:2
- dev-libs/json-glib
- gui-libs/gtk:4[introspection]
- >=gui-libs/libadwaita-1.4.0:1[introspection]
- gui-libs/text-engine
- net-libs/libsoup:3.0
-"
-
-DEPEND="
- ${RDEPEND}
-"
-
-src_configure() {
- local emesonargs=(
- -Dpackage="ebuild"
- -Ddistributor="Gentoo GURU <guru-bugs@gentoo.org>"
-
- # sys-libs/libbacktrace has been last-rited in ::gentoo
- # and is thus unavailable
- -Dbacktrace=false
- )
- if has live ${PROPERTIES}; then
- # Produce a development build for live ebuild
- emesonargs+=( -Ddevelopment=true )
- fi
- meson_src_configure
-}
-
-# Tests are skipped because as of version 0.3.0, the tests only validate
-# resource files and do not verify any functionality of the program. Those
-# validations are either already handled by QA checks or not relevant on
-# Gentoo. For more information about the rationale, please refer to:
-# https://github.com/gentoo/guru/commit/f896bee213fbb62c70e818c1bf503fee2a41919a#comments
-#
-# If tests are to be executed in the future because the upstream adds
-# functionality tests or for other reasons, and should there be no convenient
-# way to skip the validations, the following variable values need to be set:
-#
-# IUSE="test"
-# RESTRICT="!test? ( test )"
-# BDEPEND="test? ( dev-libs/appstream-glib dev-util/desktop-file-utils )"
-src_test() {
- :
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- gnome2_schemas_update
-}
-
-pkg_postrm() {
- xdg_pkg_postrm
- gnome2_schemas_update
-}