aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdel KARA SLIMANE <adel.ks@zegrapher.com>2024-09-25 22:36:41 +0200
committerAdel KARA SLIMANE <adel.ks@zegrapher.com>2024-09-25 22:37:18 +0200
commitbbfec5a8d6f8cc7241b579be85053f6d9c1d980e (patch)
treebf8b4d23d8856d33e195b6bd075807ea0c3ba5e0 /games-util
parentnet-p2p/monero: update live ebuild (diff)
downloadguru-bbfec5a8d6f8cc7241b579be85053f6d9c1d980e.tar.gz
guru-bbfec5a8d6f8cc7241b579be85053f6d9c1d980e.tar.bz2
guru-bbfec5a8d6f8cc7241b579be85053f6d9c1d980e.zip
games-util/libtess2: improve ebuild, go back to original repo
Signed-off-by: Adel KARA SLIMANE <adel.ks@zegrapher.com>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/libtess2/Manifest2
-rw-r--r--games-util/libtess2/files/meson.build37
-rw-r--r--games-util/libtess2/libtess2-1.0.2.ebuild27
-rw-r--r--games-util/libtess2/libtess2-1.0.3.ebuild31
4 files changed, 65 insertions, 32 deletions
diff --git a/games-util/libtess2/Manifest b/games-util/libtess2/Manifest
index fde6e9563..393d673f6 100644
--- a/games-util/libtess2/Manifest
+++ b/games-util/libtess2/Manifest
@@ -1 +1 @@
-DIST libtess2-v1.0.3.tar.bz2 52901 BLAKE2B 6921a13f5291cc1651e7c43eb85f72a37a32be3ce56b5e25dcdf240e8b0e976c43e2d668a35e3559cff3eece6c884bf4c0bec58cd9c30c2a204a68240703b110 SHA512 2e42a9af344c4cfe716234edc102d139cbf33d1efaa6c253b89f78a3b981e22a05d3bff883494856df779f267867882bc3eef434df2e07e33adc9ddeacac6a5b
+DIST libtess2-1.0.2.tar.gz 59626 BLAKE2B eea77bac09e6ef29993e9428cb776b56c60b1832cfc8aea50c114ba72f8fd081fd955eb46c014a932e9b2a2717e6423489afe4d9e975ebc53c5a53c18a264006 SHA512 c2b3385c0c54f2f38a01f757c89ae32152f01cc1615a3857a002a1928b0fa1b5344a778de73ef0b53c2131adbf0c3918935ac38781dceefb5daa97cfac8ba231
diff --git a/games-util/libtess2/files/meson.build b/games-util/libtess2/files/meson.build
new file mode 100644
index 000000000..147b1d12a
--- /dev/null
+++ b/games-util/libtess2/files/meson.build
@@ -0,0 +1,37 @@
+project('libtess2', 'c',
+version : '0.12.0',
+default_options : [
+ 'buildtype=release',
+ 'optimization=3',
+ 'default_library=static',
+ 'prefer_static=true',
+ 'b_ndebug=if-release',
+ 'c_args=-pipe',
+ 'cpp_args=-pipe',
+]
+)
+
+inc = include_directories(
+ 'Include',
+ 'Source'
+)
+
+install_headers('Include/tesselator.h')
+
+sources = files(
+ 'Source/bucketalloc.c',
+ 'Source/dict.c',
+ 'Source/geom.c',
+ 'Source/mesh.c',
+ 'Source/priorityq.c',
+ 'Source/sweep.c',
+ 'Source/tess.c',
+)
+
+lib = library('tess2',
+ sources,
+ include_directories: inc,
+ install: true)
+
+pkg = import('pkgconfig')
+pkg.generate(lib)
diff --git a/games-util/libtess2/libtess2-1.0.2.ebuild b/games-util/libtess2/libtess2-1.0.2.ebuild
new file mode 100644
index 000000000..42c3035f8
--- /dev/null
+++ b/games-util/libtess2/libtess2-1.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Game and tools oriented refactored version of GLU tesselator"
+
+HOMEPAGE="https://github.com/memononen/libtess2"
+SRC_URI="https://github.com/memononen/libtess2/archive/refs/tags/v${PV}.tar.gz -> $P.tar.gz"
+S="${WORKDIR}/${PN}-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=media-libs/glew-2.2.0
+ >=media-libs/glfw-3.0.0
+ >=media-libs/glu-9.0.2
+"
+
+src_unpack() {
+ default
+ cp "${FILESDIR}/meson.build" "${S}/" || die
+}
diff --git a/games-util/libtess2/libtess2-1.0.3.ebuild b/games-util/libtess2/libtess2-1.0.3.ebuild
deleted file mode 100644
index 1d2ab0a77..000000000
--- a/games-util/libtess2/libtess2-1.0.3.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DESCRIPTION="Game and tools oriented refactored version of GLU tesselator"
-
-HOMEPAGE="https://gitlab.eurecom.fr/gasc/libtess2"
-SRC_URI="https://gitlab.eurecom.fr/gasc/libtess2/-/archive/v${PV}/libtess2-v${PV}.tar.bz2"
-S="${WORKDIR}/${PN}-v${PV}"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="
- >=media-libs/glew-2.2.0
- >=media-libs/glfw-3.0.0
- >=media-libs/glu-9.0.2"
-BDEPEND="
- ${DEPEND}
- >=dev-util/premake-5.0.0_alpha16"
-
-src_compile() {
- emake clean build
-}
-
-src_install() {
- echo ${D}
- emake DESTDIR="${D}/usr" install
-}