aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2023-12-28 19:44:27 +0000
committerGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2023-12-28 19:44:27 +0000
commit250f7e701ef7f3aecb2bddcf0d69e2483727d16d (patch)
treee1230424f49e8e83b8c8091973687f0195ea0e10 /games-util
parentgames-util/r2modman-bin: fix SRC_URI and clenup ebuild (diff)
downloadguru-250f7e701ef7f3aecb2bddcf0d69e2483727d16d.tar.gz
guru-250f7e701ef7f3aecb2bddcf0d69e2483727d16d.tar.bz2
guru-250f7e701ef7f3aecb2bddcf0d69e2483727d16d.zip
games-util/r2modman-bin: update LICENSE
Signed-off-by: Gonçalo Negrier Duarte <gonegrier.duarte@gmail.com>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/r2modman-bin/r2modman-bin-3.1.45.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/games-util/r2modman-bin/r2modman-bin-3.1.45.ebuild b/games-util/r2modman-bin/r2modman-bin-3.1.45.ebuild
index 1793d4513..979bc070d 100644
--- a/games-util/r2modman-bin/r2modman-bin-3.1.45.ebuild
+++ b/games-util/r2modman-bin/r2modman-bin-3.1.45.ebuild
@@ -20,7 +20,7 @@ SRC_URI="
DESCRIPTION="A simple and easy to use mod manager for several games using Thunderstore"
HOMEPAGE="https://github.com/ebkr/r2modmanPlus"
-LICENSE="GPL-3"
+LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
@@ -28,12 +28,15 @@ KEYWORDS="~amd64 ~x86"
S="${WORKDIR}"
src_install() {
- ## Install binaries file
+ # Install binaries file
mv "${M_PN}-${PV}" "${M_PN}" || die #Fix folder name
insinto /opt
doins -r "${M_PN}"
fperms 755 "/opt/${M_PN}/r2modman"
+ #Install License file in proper location
+ find "${ED}" -name "LICENSE*" -delete || die
+
# Install desktop file
domenu "${FILESDIR}/${M_PN}".desktop
@@ -47,7 +50,3 @@ src_install() {
newicon -s 192 "${DISTDIR}/${M_PN}"-192x192.png "${M_PN}".png
newicon -s 256 "${DISTDIR}/${M_PN}"-256x256.png "${M_PN}".png
}
-
-pkg_postinst() {
- xdg_desktop_database_update
-}