aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfgang E. Sanyer <ezzieyguywuf@gmail.com>2024-04-02 22:56:53 -0400
committerWolfgang E. Sanyer <ezzieyguywuf@gmail.com>2024-04-02 23:02:11 -0400
commite322d3ef11591dc425c9069ebed10195658cea8e (patch)
tree2503c3e1c39bf6e1d54b538080df6ec38b9bebd2 /games-util/dwarf-therapist
parentdev-python/b2sdk-1.21.0: update PYTHON_COMPAT (diff)
downloadguru-e322d3ef11591dc425c9069ebed10195658cea8e.tar.gz
guru-e322d3ef11591dc425c9069ebed10195658cea8e.tar.bz2
guru-e322d3ef11591dc425c9069ebed10195658cea8e.zip
games-util/dwarf-therapist: bump to 42.1.5
Signed-off-by: Wolfgang E. Sanyer <ezzieyguywuf@gmail.com>
Diffstat (limited to 'games-util/dwarf-therapist')
-rw-r--r--games-util/dwarf-therapist/Manifest1
-rw-r--r--games-util/dwarf-therapist/dwarf-therapist-42.1.5.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/games-util/dwarf-therapist/Manifest b/games-util/dwarf-therapist/Manifest
index 2dd141b3b..4638e6022 100644
--- a/games-util/dwarf-therapist/Manifest
+++ b/games-util/dwarf-therapist/Manifest
@@ -1,2 +1,3 @@
DIST Dwarf-Therapist-41.2.2.tar.gz 1126446 BLAKE2B 44b84661892a50b225c5b69b6196e8397359d073bc9c268713fe93a35852370cfcfcc76df1c52aad814ceb46a74b6a9a7b3bd37bfc5cfec1eb2273b148b3cdb1 SHA512 0235c809be389743fb8205bf43770215efe72c4a178c854b14d1d9ea3a12213abaf58e2832d4c2bcf071d68216a4beff513c7e22712de996c0b6e9024c3010c2
DIST Dwarf-Therapist-41.2.5.tar.gz 1125524 BLAKE2B a545bac1a87aac09adb22d1863f783389bb3924464e706da534a8b24a1aaadf91e5d10b8b4fe366b7f97b78a7ffec16107bb3ff0719843dfd12e71625c50ade7 SHA512 676c5ef18ff6311ff09beaf59144ac568bf4cf3034c1a9bac65c355029a9718c14bf90a0b6c0f2b357afa95c66a6ab546c0d91fe89cf67987c4e4f432c2177e1
+DIST Dwarf-Therapist-42.1.5.tar.gz 1090721 BLAKE2B cdad4ad611bfbd0a38908ca11697e6550272c5f743b6ad5c123bcf789d3e88876fcb17fc7c109a77bbb9319cf78b7e9095ed13fc4121ffafe01281b2870e83e7 SHA512 71dcb8a814de277cb5c49b22edef32b04ff2e10f9833ef1d65d01d919e6d429d5309e2814d30c2a4e8b21331de530699762b80daade5146aeb8e8f7761095f9a
diff --git a/games-util/dwarf-therapist/dwarf-therapist-42.1.5.ebuild b/games-util/dwarf-therapist/dwarf-therapist-42.1.5.ebuild
new file mode 100644
index 000000000..f193752d1
--- /dev/null
+++ b/games-util/dwarf-therapist/dwarf-therapist-42.1.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop linux-info xdg-utils
+
+MY_PN="Dwarf-Therapist"
+MY_PV="v${PV}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="For managing dwarves in Dwarf Fortress"
+HOMEPAGE="https://github.com/Dwarf-Therapist/Dwarf-Therapist"
+SRC_URI="https://github.com/Dwarf-Therapist/${MY_PN}/archive/refs/tags/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtwidgets:5
+"
+
+CONFIG_CHECK="~CROSS_MEMORY_ATTACH"
+WARNING_CROSS_MEMORY_ATTACH="required to interact with Dwarf Fortress"
+
+src_install() {
+ # Install some sort of documentation
+ dodoc README.rst
+
+ # Add the desktop file
+ domenu dist/xdg/applications/dwarftherapist.desktop
+
+ # install icons
+ insinto /usr/share/
+ doins -r dist/xdg/icons
+
+ # install memory layout files for dwarf-fortress versions
+ insinto /usr/share/dwarftherapist/memory_layouts
+ doins -r share/memory_layouts/linux
+
+ # and of course, the binary
+ newbin "${BUILD_DIR}/dwarftherapist" dwarf-therapist
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}