aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-06-08 11:50:22 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-06-08 11:50:22 +0200
commit5282a28cd427b5b670bc144ef70778a7b2bf3115 (patch)
tree2441fe5ab6b4333e8e77d3db53f71ee3fe5dd776 /games-util/NotEnoughProduction/NotEnoughProduction-0.0.4.ebuild
parentnet-wireless/eiwd: more USE flags (diff)
downloadguru-5282a28cd427b5b670bc144ef70778a7b2bf3115.tar.gz
guru-5282a28cd427b5b670bc144ef70778a7b2bf3115.tar.bz2
guru-5282a28cd427b5b670bc144ef70778a7b2bf3115.zip
games-util/NotEnoughProduction: version bump
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'games-util/NotEnoughProduction/NotEnoughProduction-0.0.4.ebuild')
-rw-r--r--games-util/NotEnoughProduction/NotEnoughProduction-0.0.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-util/NotEnoughProduction/NotEnoughProduction-0.0.4.ebuild b/games-util/NotEnoughProduction/NotEnoughProduction-0.0.4.ebuild
new file mode 100644
index 000000000..53abaced1
--- /dev/null
+++ b/games-util/NotEnoughProduction/NotEnoughProduction-0.0.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit desktop java-pkg-2 xdg
+
+DESCRIPTION="Tool for building production chains for modded minecraft"
+HOMEPAGE="https://github.com/bigbass1997/NotEnoughProduction"
+SRC_URI="
+ https://github.com/bigbass1997/${PN}/releases/download/v${PV}/${P}.zip
+ https://raw.githubusercontent.com/bigbass1997/${PN}/master/lwjgl3/src/main/resources/libgdx128.png -> ${PN}-128.png
+ https://raw.githubusercontent.com/bigbass1997/${PN}/master/lwjgl3/src/main/resources/libgdx64.png -> ${PN}-64.png
+ https://raw.githubusercontent.com/bigbass1997/${PN}/master/lwjgl3/src/main/resources/libgdx32.png -> ${PN}-32.png
+ https://raw.githubusercontent.com/bigbass1997/${PN}/master/lwjgl3/src/main/resources/libgdx16.png -> ${PN}-16.png
+"
+KEYWORDS="~amd64 ~x86"
+LICENSE="CC-BY-NC-SA-4.0"
+SLOT="0"
+
+RDEPEND="virtual/jre:1.8"
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ default
+ cp "${DISTDIR}/${PN}"-{16,32,64,128}.png "${S}" || die
+}
+
+src_install() {
+ java-pkg_newjar "${WORKDIR}/${P}.jar" "${P}.jar"
+
+ dobin "${FILESDIR}/${PN}"
+
+ newicon -s 128x128 "${PN}-128.png" nep.png
+ newicon -s 64x64 "${PN}-64.png" nep.png
+ newicon -s 32x32 "${PN}-32.png" nep.png
+ newicon -s 16x16 "${PN}-16.png" nep.png
+ make_desktop_entry "${PN}" "Not Enough Production" nep Utility
+}