aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-04-01 09:13:59 +0400
committerVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-04-01 09:13:59 +0400
commit4b5f2f9692a0504148e97dbad5269d089f159d9a (patch)
treeebd936f9938096059c08f3f26280ff0ecc8ec932 /games-strategy
parentapp-admin/himitsu-totp: add 0.1 (diff)
downloadguru-4b5f2f9692a0504148e97dbad5269d089f159d9a.tar.gz
guru-4b5f2f9692a0504148e97dbad5269d089f159d9a.tar.bz2
guru-4b5f2f9692a0504148e97dbad5269d089f159d9a.zip
games-strategy/swine: new package, the game is a freeware
Signed-off-by: Vitaly Zdanevich <zdanevich.vitaly@ya.ru>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/swine/Manifest1
-rw-r--r--games-strategy/swine/metadata.xml8
-rw-r--r--games-strategy/swine/swine-1.ebuild52
3 files changed, 61 insertions, 0 deletions
diff --git a/games-strategy/swine/Manifest b/games-strategy/swine/Manifest
new file mode 100644
index 000000000..616cbd79b
--- /dev/null
+++ b/games-strategy/swine/Manifest
@@ -0,0 +1 @@
+DIST swine.tar.xz 586370844 BLAKE2B 89ef83e0c0df58938f66aff096e281a9dedc26777afb560173bfa9d35f1a53bc0044f5974439cd2c012cd8912b77e19827489335f5349ac38a7c8bef85e4b4d6 SHA512 d58c3412d7ee7a49758b228ae1f7d91d11e2c997fc7a9497137657bd265f289cc9d09a8714a7309fbbcd0b115732edf7572d392b3361133228e86bf8f99b68fa
diff --git a/games-strategy/swine/metadata.xml b/games-strategy/swine/metadata.xml
new file mode 100644
index 000000000..812e586b9
--- /dev/null
+++ b/games-strategy/swine/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Vitaly Zdanevich</name>
+ <email>zdanevich.vitaly@ya.ru</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-strategy/swine/swine-1.ebuild b/games-strategy/swine/swine-1.ebuild
new file mode 100644
index 000000000..6643d2ae4
--- /dev/null
+++ b/games-strategy/swine/swine-1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit wrapper
+
+DESCRIPTION="Simple RTS from 2005, Metacritic is 65, user score is 8.2"
+HOMEPAGE="https://en.wikipedia.org/wiki/S.W.I.N.E."
+
+SRC_URI="https://archive.org/download/$PN.tar.xz/$PN.tar.xz"
+
+KEYWORDS="~amd64"
+S="${WORKDIR}"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+RESTRICT="strip"
+
+RDEPEND="
+ virtual/wine
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+
+ exec=swine.exe
+
+ mkdir -p "$ED$/opt"
+
+ mkdir "$ED/opt" || die
+ mkdir -p "$ED/usr/bin/" || die
+ cp -r "$PN" "$ED/opt/$PN" || die
+ fperms o+w "/opt/$PN/$PN.log" # Will not start without it
+
+ echo "cd /opt/$PN; wine $exec; cd -" > "$ED/usr/bin/$PN"
+ # I tried
+ # make_wrapper "$PN" "env WINEPREFIX=/home/\$USER/.wine-swine wine /opt/$PN/swine.exe"
+ # but game got error - because we need to run from the game directory
+ fperms +x "/usr/bin/$PN"
+
+}
+
+pkg_postinst() {
+ einfo "Downloaded from https://www.moddb.com/games/swn/downloads/s-w-i-n-e-full-game"
+ einfo "More about the game:"
+ einfo "https://www.youtube.com/channel/UCNtssCCyFCEr6N8N5T9kvHQ"
+ einfo "https://www.wikidata.org/wiki/Q844994"
+ einfo "https://www.metacritic.com/game/s-w-i-n-e/"
+ einfo "The game is installed to /opt/$PN/ - if you want to run it by another Wine or operating system"
+}