aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2019-05-18 17:51:12 +0900
committerWilliam Breathitt Gray <vilhelm.gray@gmail.com>2019-05-18 17:55:30 +0900
commited563bffcfcc1b590531ea8f6f4b3bad3963ca68 (patch)
tree8f5210ec28a4330d30d32dab14e6c945df9e0742 /games-fps
parentdev-util/codespell: bump to 1.15.0 (diff)
downloadguru-ed563bffcfcc1b590531ea8f6f4b3bad3963ca68.tar.gz
guru-ed563bffcfcc1b590531ea8f6f4b3bad3963ca68.tar.bz2
guru-ed563bffcfcc1b590531ea8f6f4b3bad3963ca68.zip
games-fps/chocolate-doom: python is a BDEPEND dependency
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/chocolate-doom/chocolate-doom-3.0.0.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/games-fps/chocolate-doom/chocolate-doom-3.0.0.ebuild b/games-fps/chocolate-doom/chocolate-doom-3.0.0.ebuild
index 88f45ceaa..06015a5b8 100644
--- a/games-fps/chocolate-doom/chocolate-doom-3.0.0.ebuild
+++ b/games-fps/chocolate-doom/chocolate-doom-3.0.0.ebuild
@@ -3,7 +3,9 @@
EAPI=7
-inherit xdg
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit python-any-r1 xdg
DESCRIPTION="A Doom source port that is minimalist and historically accurate"
HOMEPAGE="https://www.chocolate-doom.org"
@@ -20,10 +22,10 @@ DEPEND="
media-libs/sdl2-net
libsamplerate? ( media-libs/libsamplerate )
png? ( media-libs/libpng:= )"
-RDEPEND="
- ${DEPEND}
+RDEPEND="${DEPEND}"
+BDEPEND="
python? (
- dev-lang/python
+ ${PYTHON_DEPS}
dev-python/pillow
)"