aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <william.gray@linaro.org>2022-09-08 12:17:12 -0400
committerWilliam Breathitt Gray <william.gray@linaro.org>2022-09-08 12:17:24 -0400
commitea524f86185713fc26c331f40529fa783ff93df5 (patch)
tree296e16bc28adebcb0433fe0ec6b39ffcd3e652c0 /games-fps
parentdev-cpp/drogon: fix race condition in tests (diff)
downloadguru-ea524f86185713fc26c331f40529fa783ff93df5.tar.gz
guru-ea524f86185713fc26c331f40529fa783ff93df5.tar.bz2
guru-ea524f86185713fc26c331f40529fa783ff93df5.zip
games-fps/crispy-doom: add 5.12.0
Signed-off-by: William Breathitt Gray <william.gray@linaro.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/crispy-doom/Manifest1
-rw-r--r--games-fps/crispy-doom/crispy-doom-5.12.0.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/games-fps/crispy-doom/Manifest b/games-fps/crispy-doom/Manifest
index f5a77ae7a..b0653fb58 100644
--- a/games-fps/crispy-doom/Manifest
+++ b/games-fps/crispy-doom/Manifest
@@ -3,3 +3,4 @@ DIST crispy-doom-5.10.1.tar.gz 2649358 BLAKE2B 920df67f123218d737de1a1b147d96090
DIST crispy-doom-5.10.2.tar.gz 2648117 BLAKE2B 2a502dca71418a9358c474801e175b510f7fcbf1453df6a061d20439e79c642881ad6166c0788840e4f8c64f70c6ea95d1a97bbab7c83e0f4d3c2af8296a64dd SHA512 a1ee20510608bb889236288b30eb5d84b841c267b0907f5155497d3824021b9490365bc29e83a3e59c0519eaab35802aea71935e82b4f7a09b7b07fd933a296b
DIST crispy-doom-5.10.3.tar.gz 2648144 BLAKE2B 050f6e28c5db73d6f11539bee7e1de7a390fa6f3169d4bbede698b736523b9a0255cba3f67ec99653fef4925843c5e107200bed981bb0db96ff1373434ffb134 SHA512 f98d8cbfb748bccca1ef50d9d46355d5b6f6dfa44b271803193f3e41e48c28fa8c6ad5bbe3a7a4ae36585cc150f2acad7ad5bd4b7a411faf45b234455d83d651
DIST crispy-doom-5.11.1.tar.gz 2664465 BLAKE2B 80b67193fb3b626f22e4570a1c17de70376846464bb82103196776d8b300f0c30a38612ee6c99f0abf71a7852109c91ce5b84c49dc6810bdb093a31e347e9125 SHA512 c970f1b32d15f91c6ec693571b9179a7607190a03cbbd2651bba0368120a25ef6ade2f157a2782dc4ea8cf05df23e66e6e7c8d2ea011bbb7626f4487f4e3b4c9
+DIST crispy-doom-5.12.0.tar.gz 2425206 BLAKE2B 18c0bd66dcec7b30404e32aa045d5666b89d68f2b9efb6f83455ab007d78816f72218591e5ddcf6ea68a02588f19e98057545dc27219407e450bf4ce600e3c1f SHA512 eb7b4da44c9b261712da4da1935de747928488571ba2be9f0fa43cedd2a0bab3e0f4e0ce1cec247f44ab1b61fc2aa1f545bb0ef50f5f8ac1d3c564342d992a11
diff --git a/games-fps/crispy-doom/crispy-doom-5.12.0.ebuild b/games-fps/crispy-doom/crispy-doom-5.12.0.ebuild
new file mode 100644
index 000000000..983b8c325
--- /dev/null
+++ b/games-fps/crispy-doom/crispy-doom-5.12.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10,11} )
+
+inherit autotools prefix python-any-r1 xdg
+
+DESCRIPTION="A limit-removing enhanced-resolution Doom source port based on Chocolate Doom"
+HOMEPAGE="https://github.com/fabiangreffrath/crispy-doom"
+SRC_URI="https://github.com/fabiangreffrath/${PN}/archive/${P}.tar.gz"
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc libsamplerate +midi png truecolor vorbis zlib"
+
+DEPEND="
+ media-libs/libsdl2[video]
+ media-libs/sdl2-mixer[midi?,vorbis?]
+ media-libs/sdl2-net
+ libsamplerate? ( media-libs/libsamplerate )
+ png? ( media-libs/libpng:= )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+# ${PYTHON_DEPS} for bash-completion
+BDEPEND="
+ ${PYTHON_DEPS}
+ doc? ( ${PYTHON_DEPS} )"
+
+S="${WORKDIR}"/${PN}-${P}
+
+DOCS=(
+ "AUTHORS"
+ "ChangeLog"
+ "NEWS.md"
+ "NOT-BUGS.md"
+ "PHILOSOPHY.md"
+ "README.md"
+ "README.Music.md"
+ "README.Strife.md"
+)
+
+src_prepare() {
+ default
+
+ hprefixify src/d_iwad.c
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-bash-completion \
+ $(use_enable doc) \
+ --disable-fonts \
+ --disable-icons \
+ $(use_with libsamplerate) \
+ $(use_with png libpng) \
+ --enable-sdl2mixer \
+ --enable-sdl2net \
+ $(use_enable truecolor) \
+ $(use_with zlib) \
+ --disable-zpool
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # Remove redundant documentation files
+ rm -r "${ED}/usr/share/doc/"* || die
+
+ einstalldocs
+}