aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2021-03-25 08:45:48 +0900
committerWilliam Breathitt Gray <vilhelm.gray@gmail.com>2021-03-25 08:46:55 +0900
commit3f8b30195440e52b58b572af3aaf5e5dde3204d3 (patch)
tree56afcd7c914f583630faefb062b7fedbe6cd6157 /games-fps
parentgui-apps/sfwbar: new version (diff)
downloadguru-3f8b30195440e52b58b572af3aaf5e5dde3204d3.tar.gz
guru-3f8b30195440e52b58b572af3aaf5e5dde3204d3.tar.bz2
guru-3f8b30195440e52b58b572af3aaf5e5dde3204d3.zip
games-fps/crispy-doom: Version bump to 5.10.1
Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/crispy-doom/Manifest1
-rw-r--r--games-fps/crispy-doom/crispy-doom-5.10.1.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/games-fps/crispy-doom/Manifest b/games-fps/crispy-doom/Manifest
index a9a9ba362..3ecc10c3e 100644
--- a/games-fps/crispy-doom/Manifest
+++ b/games-fps/crispy-doom/Manifest
@@ -1,4 +1,5 @@
DIST crispy-doom-5.10.0.tar.gz 2640909 BLAKE2B 67112cdb0b8a4caa1de9fc3fcd752be8775d154a5df194941bd1a024f607c9b7f0925994ed236a6e8f9579910af8dd29585f9fce77f72a1c20ab66177f7bca4d SHA512 b289939af35bbe3a933827fe834cbff8a267b6280749b27084abdf25174042bbdcaca313359258d7ab3fecacedd9b0f06b92624f2a7599ffff37a5e0db2436b1
+DIST crispy-doom-5.10.1.tar.gz 2649358 BLAKE2B 920df67f123218d737de1a1b147d96090a8ebb6021e4b532f30430441c8dcb4ef069e7045381a8ce8e8754d49a9595efa4d4700d4c3986728b9e2edfdc3d6c66 SHA512 134354c6692151902bd7f5349a88d5899e88f1f8e55499cb15f600c2c6cd0f89fa83dc17a26313b903bb801bd807ee1b5616d3cd5c7bda7e5d8e608a59194681
DIST crispy-doom-5.9.0.tar.gz 2641211 BLAKE2B a97bb7d9bda0c4e984054a0051cadfcaba7c758829bec9e615801bbf91dc1c8063decfedf5b76056cd2fb05e8fcf4113f19c10d72604399b715011d994af3e8b SHA512 9970291f374003ac2a1d9e4c44db18b97a41ae3348a5e100ec369affc162d681d15ce61846480667c8a7418700b78a4380bedab1e3acae77976eb4271a22b644
DIST crispy-doom-5.9.1.tar.gz 2640684 BLAKE2B 2bf862d8134689afba101abeed5cf1e1695378f235718941bf9fc2717bc93dd848173bb758e8bf0bc4a8ab1bfa75533c2ae838210326451f7c4285b0acb2e08b SHA512 1f9ed3520fe3d0fd176d3bcd6a2a3f5e730c29312ad20a4c1f692cc69881069efbf35d758dfcdafd402a499333dd2ae54764f4ec007375138ecf9cab84ebdbcd
DIST crispy-doom-5.9.2.tar.gz 2642419 BLAKE2B 63d9a89d6099485c79ff4cad69975de790b32a4ece4bded172ebf771a2bf1b4dcd21ab58383ca3c5eea32a4eff72e65ec0e3a283c85f1bc62be680de04f88e52 SHA512 bcd48a75d80b963e1b00b5acc5fc863c014cfde39f67efec50852667ed80545c78b4ed3f82b28762806f0aa3999ed26018dd6ccb34149c395409cd3c47509273
diff --git a/games-fps/crispy-doom/crispy-doom-5.10.1.ebuild b/games-fps/crispy-doom/crispy-doom-5.10.1.ebuild
new file mode 100644
index 000000000..d862f61a7
--- /dev/null
+++ b/games-fps/crispy-doom/crispy-doom-5.10.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit autotools prefix python-any-r1 xdg
+
+DESCRIPTION="A limit-removing enhanced-resolution Doom source port based on Chocolate Doom"
+HOMEPAGE="https://github.com/fabiangreffrath/crispy-doom"
+SRC_URI="https://github.com/fabiangreffrath/${PN}/archive/${P}.tar.gz"
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion doc libsamplerate +midi png truecolor vorbis zlib"
+
+DEPEND="
+ media-libs/libsdl2[video]
+ media-libs/sdl2-mixer[midi?,vorbis?]
+ media-libs/sdl2-net
+ libsamplerate? ( media-libs/libsamplerate )
+ png? ( media-libs/libpng:= )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ bash-completion? ( ${PYTHON_DEPS} )
+ doc? ( ${PYTHON_DEPS} )"
+
+S="${WORKDIR}"/${PN}-${P}
+
+DOCS=(
+ "AUTHORS"
+ "ChangeLog"
+ "NEWS.md"
+ "NOT-BUGS.md"
+ "PHILOSOPHY.md"
+ "README.md"
+ "README.Music.md"
+ "README.Strife.md"
+)
+
+src_prepare() {
+ default
+
+ hprefixify src/d_iwad.c
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable bash-completion) \
+ $(use_enable doc) \
+ --disable-fonts \
+ --disable-icons \
+ $(use_with libsamplerate) \
+ $(use_with png libpng) \
+ $(use_enable truecolor) \
+ $(use_with zlib)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # Remove redundant documentation files
+ rm -r "${ED}/usr/share/doc/"* || die
+
+ einstalldocs
+}